Ir al contenido
ice

Solucionar error de dependencia fontsproto>=2.1.3

Recommended Posts

00b91-vertical

 

Bueno teniendo en cuenta que hace tiempo no escribimos nada en el blog y justo tengo un poco de "mala" suerte y cuando quise actualizar Archlinux tuve el error con la dependencia fontsproto>=2.1.3, entonces armo éste mini how to para solucionar ése "cuasi" bug que tienen algunos archers. Más allá que pasó hace unos días, aproximadamente el 10/02, tal vez antes, lo dejo aquí por las dudas. Asi que como decimos habitualmente... Comencemos! 1- Cuando queremos actualizar nuestro sistema con el clásico (o en mi caso):

Cita

$ sudo pacman -Syyu && yaourt -Syua

1.png

 

Actualiza correctamente los repositorios, pero, luego de confirmar el reemplazar diferentes paquetes del repo extra que tenemos, me encuentro con el error:

Cita

"error: no se pudo preparar la operación (no se pudieron satisfacer las dependencias):: libxfont: quitando <> se rompe la dependencia con <=2.1.3>>".

 

2.png

 

Y claro, quedaba ahí. Doy de nuevo por las dudas y seguía lo mismo, hasta que dije, mmm ése paquete no depende de ningún otro. 1.a - Nos fijamos si lo tenemos instalado con:

Cita

$ sudo pacman -Q libxfont

2 - Entonces lo elimino:

Cita

$ sudo pacman -Rscn libxfont

3.png

 

3 - Luego volví con la misma sentancia del paso 1.

Cita

$ sudo pacman -Syyu && yaourt -Syua

4.png

 

4 - Listo!

 

¿Por qué sucede ésto? Sabemos que tenemos una distribución y algunas veces nos puede suceder ésto, tal vez en algún momento en el repositorio "extra" se encontraba ése paquete y lo utilizamos por alguna razón. Actualmente ahora no está en el mismo, entonces es lo que nos produjo dicho error de dependencias; tan simple como éso, entonces procedemos a desintalarlo para solucionar el "inconveniente" que teníamos.

 

Nota: Quiero aclarar que ésto está, bah o sucedió en varias distribuciones derivadas de Arch también, llámese Antergos, Manjaro, Chakra, etc.

 

Nota 1: Por las dudas aclaro que desestimamos la cantidad de paquetes para actualizar, porque dependerá del tiempo que lleven sin actualizar.

 

Nota 2: También voy aclarar por las dudas que el uso de yaourt es opcional.

 

¿Qué usamos?

Distribución: Archlinux.

Cómandos: pacman.

 

Abrazo de gol!

Compartir este post


Enlace al post
Compartir en otros sitios

Registra una cuenta o conéctate para comentar

Debes ser un miembro de la comunidad para dejar un comentario

Crear una cuenta

Regístrate en nuestra comunidad. ¡Es fácil!

Registrar una cuenta nueva

Iniciar Sesión

¿Ya tienes cuenta? Conéctate aquí.

Iniciar Sesión

×