Ir al contenido
  • 0
Conéctate para seguir esto  
Silen

Tearing en Kde opensuse Nvidia

Pregunta

Hola,

 

lo pregunto , porque ya no se que hacer .Tengo screen tearing en kde con opensuse tumbleweed  con nvdia  en google chrome . Aparte, El efecto del cubo en el cambiador de escritorios se ve fatal 

 

He creado en fichero 20-nvidia.conf (tambien lo he renombrado a xorg) en /etc/x11/xorg.conf.d

con el contenido 

 

Spoiler

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 384.98  (buildmeister@swio-display-x86-rhel47-02)  Thu Oct 26 15:54:54 PDT 2017

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from data in "/etc/sysconfig/mouse"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "IMPS/2"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "yes"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Samsung S22D300"
    HorizSync       30.0 - 81.0
    VertRefresh     50.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 960"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
    #Option         "AllowIndirectGLXProtocol" "off"
    Option         "TripleBuffer" "on"
    
EndSection

Este archivo lo he puesto tambien (para probar ) en /usr/share/x11/xorg.d pero nada

 

Tambien he creado el Kwin.sh  dentro de /etc/profile.d

conenido

export __GL_YIELD="USLEEP"

export KWIN_TRIPLE_BUFFER=1

 

Pero nada el tearing de chrome no se va , en firefox , perfecto 

 

Con antergos en gnome todo perfecto a la primera .He tocada varias veces la configuracion de chrome         chrome://flags no nada , no lo consigo, alguna idea , solución .. por favor....   

 

Gracias

 

 

Compartir este post


Enlace al post
Compartir en otros sitios

5 respuestas a esta pregunta

Recommended Posts

  • 0

Chromium/Chrome iene sus más y sus menos con la aceleración por hardware y si la configuración general no tiene efecto sobre éste, yo lo plantearía a la inversa.

Deshabilitar totalmente la aceleración por hardware en opciones avanzadas.

 

8DOQwvS.jpg

 

yUZH8Tp.jpg

 

El efecto del cubo seguramente esté afectado por la composición. Asegúrate que en las opciones de Kwin la composición para elementos a pantalla completa está deshabilitada

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Gracias Shiba,

 

Ya lo probe y  sigue  igual .Lo malo es que en el VLC también me tira un tearing que te mueres. Lo curioso, es que antes de instalar el driver nvidia va perfecto el escritorio, el cubo etc , menos el vlc que no tiene imagen 

El Chrome no lo he probado con el driver libre. ¿El problema sera de kde o de nvidia?

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Se pueden hacer varias pruebas al vuelo:

nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceCompositionPipeline = On }"
nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"

O un poco más bestia

nvidia-settings --assign CurrentMetaMode="$(nvidia-settings -q CurrentMetaMode -t|tr '\n' ' '|sed -e 's/.*:: \(.*\)/\1\n/g' -e 's/}/, ForceCompositionPipeline = On}/g')" > /dev/null 

 

Si nvidia-settings es capaz de modificar la composición, es que por alguna razón está ignorando la configuración de Xorg.

 

 

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

He estado viendo en Antergos con gnome que todo  me va perfecto (el cambio a opensuse aqui es un capricho/aprender) El archivo de Nvidia esta en usr/share/x11/xorg.d y el archivo se llama 10-nvidia-drm-outputclass.conf y el contenido es este 

 

Section "OutputClass"
    Identifier "intel"
    MatchDriver "i915"
    Driver "modesetting"
EndSection

Section "OutputClass"
    Identifier "nvidia"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "AllowEmptyInitialConfiguration"
    Option "PrimaryGPU" "yes"
    ModulePath "/usr/lib/nvidia/xorg"
EndSection

 

y en este test sale perfecto y el vlc tambien

 

Si tengo 2 graficas la integrada y la nvidia ,puedo elegir cual quiero que coja , si es asi como ? En opciones de la bios 

 

 

Compartir este post


Enlace al post
Compartir en otros sitios

Registra una cuenta o conéctate para comentar

Debes ser un miembro de la comunidad para dejar un comentario

Crear una cuenta

Regístrate en nuestra comunidad. ¡Es fácil!

Registrar una cuenta nueva

Iniciar Sesión

¿Ya tienes cuenta? Conéctate aquí.

Iniciar Sesión
Conéctate para seguir esto  

×