Jump to content
  • 0

Problemas con el WiFi y el Kernel


Velik
 Share
Followers 0

Question

    Buenos días.

 

    Últimamente he estado teniendo problemas con el WiFi en mi PC, cuando enciendo el PC con Xubuntu me doy cuenta de que mi PC no se conecta a ninguna Red Inalambrica y no aparece ninguna, he usado varios trucos para que funcione pero siempre cambia y a veces no funcionan, trucos como apagar y volver a encender la tarjeta de red; apagar la tarjeta de red, luego suspender el PC, volverlo a encender y volver a encender la tarjeta, conectarme a mi WiFi usando el comando "nmcli dev wifi con "ssid" password "contraseña"; reiniciar el PC; reiniciar el servicio network-manager; matar el proceso de nm-applet y volverlo a iniciar; combinar varias de los trucos.

 

    Después de tanto fastidio decidí instalar Ubuntu, al principio parecía que iba bien, pero luego de un reinicio para actualizar volvió el problema, al final descubrí que la causa fue el kernel, no se exactamente en que versión de Linux empezó a molestar, pero en la versión 4.4.0-31 funciona bien, mientras que en la 4.4.0-38 no. También vi que el problema sucedía en la 4.4.22, aunque no se si en versiones posteriores a la 4.4 el fallo continua o esta arreglado.

 

    Tengo instalado Ubuntu 16.04.1, mi computadora es una HP Mini 100e y la tarjeta inalámbrica es una Realtek RTL8191SE.

 

    De antemano agradezco la ayuda.

Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Estos problemas pasan a veces y lo mejor suele ser usar el kernel que menos problemas te ponga.

O sea usar la version en que ese problema no te afecta y marcarlo como el kernel para arranque por definicion , asi podras recibir y / o actualizar ramas de kernel disponibles con la certeza de que siempre bootea con el definido y si quieres probar o ir probando con otras versiones que se vayan actualizando para asi ver que kernel mas actual no tiene ese problema .

 

Te doy mi ejemplo yo en el Ubuntu 12.04 quando salio tube muchos problemas de rendimiento grafico a la medida que pas el tiempo y los kernel de esa version se fueron actualizando mi problema fue siendo minorado creo que en a version 12.04.3 ya no me daba tanto lag , el mismo computador con la version 14.04 nunca tubo ese tipo de problema .

Es como si hubiera Kernels que parece que salen muy bien para un pc y el siguiente no sale tan bueno , y en estos casos toca tirar de instalar un kernel diferente y mantenerlo .

 

Saludos.

Link to post
Share on other sites
  • 0

Estos problemas pasan a veces y lo mejor suele ser usar el kernel que menos problemas te ponga.

O sea usar la version en que ese problema no te afecta y marcarlo como el kernel para arranque por definicion , asi podras recibir y / o actualizar ramas de kernel disponibles con la certeza de que siempre bootea con el definido y si quieres probar o ir probando con otras versiones que se vayan actualizando para asi ver que kernel mas actual no tiene ese problema .

 

Te doy mi ejemplo yo en el Ubuntu 12.04 quando salio tube muchos problemas de rendimiento grafico a la medida que pas el tiempo y los kernel de esa version se fueron actualizando mi problema fue siendo minorado creo que en a version 12.04.3 ya no me daba tanto lag , el mismo computador con la version 14.04 nunca tubo ese tipo de problema .

Es como si hubiera Kernels que parece que salen muy bien para un pc y el siguiente no sale tan bueno , y en estos casos toca tirar de instalar un kernel diferente y mantenerlo .

 

Saludos.

Pues la verdad parece ser que es un problema de la distro con el kernel, tal vez por arte de magia se arregle en la próxima versión de Ubuntu (La 16.10 o la 16.04.1) ya que parece que todas las versiones de Linux falla, hasta probe la 4.7.5 y sigue igual. Al parecer tendré que aguantar hasta que se arregle solo el problema.

 

Gracias por la ayuda y tenga un buen día.

Link to post
Share on other sites
  • 0

Un detalle, ¿estas usando dos gestores de redes, o hay un gestor de redes y aparte hay un archivo con una configuración de la red en

/etc ? Es que ya ha pasado otras veces y entran en conflicto las dos configuraciones, en el foro hay temas con problemas parecidos.

Edited by pacoeloyo
Link to post
Share on other sites
  • 0

Un detalle, ¿estas usando dos gestores de redes, o hay un gestor de redes y aparte hay un archivo con una configuración de la red en

/etc ? Es que ya ha pasado otras veces y entran en conflicto las dos configuraciones, en el foro hay temas con problemas parecidos.

Estoy usando el predeterminado de Ubuntu e igualmente lo hacia con Xubuntu. Y sobre los archivos de configuración en /etc, pues no se cuales serían los que tendría que buscar.

Link to post
Share on other sites
  • 0

Si te sirve de algo , muchos amigos de aqui del foro se acordaran de que en esos tiempso que tube porblemas de lag recurri aqui mismo y hice con la ayuda de Shiba87 y otros amigos de aqui configruaciones manuales pero tube ganos muy pequeños el tema era el soporte en ese Kernel aunque mi tema era grafico lo de la red podria ser una mala adaptacion del modulo en ramas Kernel presentes .

 

Yo llegue a pensar que no me podria mover al 14.04 pues temia que tubiera muchos problemas y en mi caso tengo hoy dia el mismo rendimiento que el viejo 10.04 y la cosa va muy bien incluso con la grafica antigua una ATI que era la que tenia en ese tiempo del problema con el 12.04 , asi que creo que es una cosa de tiempo muy probablemente y mientras puedes inentar configurar a mano a ver si se solventa la cosa o bien tirar por un Kernel anterior y respecto al tema Kernel → tiene sentido que sea la distro que sea o su maioria te den ese problema ya que el porblema esta en el nucleo en si y no en las pós-configuraciones de distribución.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share
×
×
  • Create New...