Ir al contenido
  • 0
Conéctate para seguir esto  
Rohlling

Se cuelga en la carga de linux. Posible conflicto con la gráfica.

Pregunta

Bueno, hace unos días se me fue la imagen y decidí que era hora de hacer funcionar la gráfica dedicada nvidia (que para eso me la incluí en el presupuesto).

Mientras hago instalaciones modo texto, no hay problema, pero una vez instalado el sistema, a la hora de iniciarse, se queda enganchado en la carga inicial.

He probado con vagos, debian, mint, y kaos.  Los live no van, menos en la de kaos, en su versión non-free (vamos, cargando el firmware privativo de nvidia).

He realizado una prueba final, que consiste en volver a la integrada intel, realizando una instalación de debian sin ningún problema, reiniciando unas cuantas veces, y comprobando que no hay ningún problema.

Después he vuelto a configurar la placa para que inicie la gráfica dedicada, y al iniciar el sistema linux se ha quedado en el siguiente mensaje:

 

[....] Waiting for /dev to be fully populated...

 

Lleva así bastantes minutos.

 

Sospecho que hay un conflicto con la gráfica.  Antes de hacer el cambio, he comprobado el kernel que tenía (3.13) y he instalado los controladores privativos de nvidia.  Me salió un mensaje diciendo que había un conflicto con los existentes en el kernel (nouveau), supuestamente resuelto en un reinicio.  No se que más contar.

 

Datos de interés:

 

- Placa Base: Gigabyte B85-HD3

- Gráfica: Asus Geforce GT 610

 

 

Si no me queda más remedio, me tocará volver a la integrada, pero me gustaría poder utilizar la otra. Alguna idea?

Compartir este post


Enlace al post
Compartir en otros sitios

23 respuestas a esta pregunta

Recommended Posts

  • 0

Si, esa página me la enseñó.  El caso es que estoy mirando el siguiente artículo de Yoyo, que casualmente se puso la misma gráfica.  Como tengo instalado KaOS en el equipo igual hago los experimentos con esa distro, a ver que pasa.

Otra cosa que no se si puede influir, es el hecho de que en el manual de la placa avisa de una opción de la bios para activar o desactivar la opción de la gráfica integrada.  Quizás debiera desactivarla para que linux no se liara?

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Ahí me has pillado... acabo de probar acpi=off y .... se queda igual de "off" , en cuanto a loglevel, lo pongo a la misma altura que acpi o va en las lineas del kernel?

 

 

Bueno, por no esperar, lo puse después de la línea de kernel, y sigue todo igual.

Editado por Rohlling

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Teniendo en cuenta que e has pillado a mí también :sweat:

 

menuentry 'Debian GNU/Linux' --class debian --class gnu-linux --class gnu --class os {
	insmod gzio
	insmod part_gpt 
	insmod ext2
	set root='hd0,gpt2'
	echo	'Cargando Linux 3.13.6...'
	linux	/boot/vmlinuz-3.13.6 root=/dev/sda1 ro init=/bin/systemd quiet
	echo	'Cargando imagen de memoria inicial...'
	initrd	/boot/initrd.img-3.13.6
}
menuentry 'Debian GNU/Linux' --class debian --class gnu-linux --class gnu --class os {
	insmod gzio
	insmod part_gpt 
	insmod ext2
	set root='hd0,gpt2'
	echo	'Cargando Linux 3.13.6...'
	linux	/boot/vmlinuz-3.13.6 root=/dev/sda1 ro init=/bin/systemd acpi=off loglevel=7
	echo	'Cargando imagen de memoria inicial...'
	initrd	/boot/initrd.img-3.13.6
}

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Hemos pasado del waiting for.. populated a salirme unas cuantas líneas más:

 

input: PC Speaker as /devices/platform/pcspkr/input/input6

mei_me 0000:00:16.0: PCI->APIC IRQ transform: INT A -> IRQ 16

i801_smbus 0000:00:1f.3: PCI->APIC IRQ transform: INT C -> IRQ 18

ACPI Exception: AE_BAD_PARAMETER, Thread 920907792 could not acquire Mutex [0x1] (20131115/utmutex-285)

i801_smbus 0000:001f.3: SMBus using PCI Interrupt

-  3 líneas iguales a ACPI Exception....  -

iTCO_vendor_support: vendor-support=0

iTCO_wdt: Intel TCO WatchDog Timer Driver v1.10

iTCO_wdt: unable to reset NO_REBOOT flag, device disabled by hardware/BIOS

alg: No Test for __gcm-aes-aesni (__driver-gcm-aes-aesni)

[drm] Initialized drm 1.1.0 20060810

nvidia: module license 'NVIDIA' taints kernel.

Disabling lock debugging due to kernel taint

nvidia 0000:01:00.0: PCI->APIC IRQ transform: INT A -> IRQ 16

 

Después de leer esto, me da que pensar que quizás el problema está en la comunicación entre el kernel y la placa base.... :confused:

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Bueno, sigo con el dilema.  El sistema está instalado usando la gráfica de placa, es la única manera ya que con la dedicada no se por qué no carga el sistema.  Se me ocurrio utilizar nvidia-detect con el siguiente resultado:

 

Detected NVIDIA GPUs:
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF119 [GeForce GT 610] [10de:104a] (rev a1)
Your card is supported by the default drivers and legacy driver series 304.
It is recommended to install the
    nvidia-driver
package.
 

Tengo que decir que nvidia-driver está instalado.  Lo que pienso es que el módulo no se carga en el inicio y hay un conflicto en ese momento.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Es extraño porque aunque el módulo no cargara debería arrancar, mal, en modo VESA, pero por lo menos llegar a la terminal.

Nueva opción a probar irqpoll

 

Ok, probare a ver, supongo que va detrás de la línea de kernel

 

Y si está fisicamente rota? Podría ser?

 

No, no está rota, probado en "otro" sistema operativo y completamente funcional. 

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Ok, probare a ver, supongo que va detrás de la línea de kernel

Lo mismo que todas las anteriores :P 

 

No, no está rota, probado en "otro" sistema operativo y completamente funcional.

La gráfica como tal quizá no, pero el puerto PCI-e de la placa base podría ser.

Yo tuve un caso parecido con una Asrock  :sweat:

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Vale, lo he puesto para que cargara en modo a prueba de fallos, porque en modo normal no se ve nada, y el resultado de lo que he podido ver al final (antes de que se quede parado el sistema) es este:

 

ACPI Warning: 0x0000000000001828-0x000000000000182f SystemIO conflicts with Region \PMIO 1 (20131115/utaddres-251)
ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
ACPI Warning: .......(números, como antes).......  SystemIO conflicts with Region \GPRL 1 ...
ACPI Warning: .................................... SystemIO conflicts with Region \GPR_ 2.....
2 líneas más parecidas a las dos anteriores.
lpc_ich: Resource conflicts found affecting gpio_ich
nvidia: module license 'NVIDIA' taints kernel
Disabling lock debugging due to kernel taint
 

Estoy llegando a un punto que me siento ya hasta avergonzado de tanto preguntar, voy a buscar algún manual de opciones para poner en el grub, a ver si con alguna suena la flauta y veo con más exactitud cual es el problema, porque lo que lo que me ha dado a entender esto es que el firmware no es bueno y se queda tonto el kernel (y eso no le veo mucho sentido...)

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Voy a poner las últimas líneas que salen, creo que las 2 primeras no tienen nada que ver, pero por si acaso también van:

 

hda_intel:Disabling MSI
hda-intel 0000:01:00.1: Handle VGA-switcheroo audio client
i915 0000:00:02.0: enabling device (0006 -> 0007)
[drm] Memory usable by graphics device = 2048M
alg: No test for __gcm-aes-aesni (__driver-gcm-aes-aesni)
[drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[drm] Driver supports precise vblank timestamp query.
vgaarb: device changed decodes: PCI:0000:00:02.0,olddecodes=io+mem,decodes=none:owns=none

 

 

Un día @@Shiba87, cuando tengas tiempo, me explicas que es lo que estoy haciendo :D

 

Me acabo de acordar que lo de __gcm-aes-aesni lo he visto antes en algún momento.  Otro dato a apuntar es que de las distros que he podido ver la imagen del live sin problemas, fue KaOS, que no me dio ningún problema para instalar, sin embargo, no cargaba del todo desde el disco duro.  Juraría que me pareció leer alguna línea de error con los controladores libres de nvidia.  Sin embargo, están instalados los privativos.  Ya lo último que se me ocurre es compilar el kernel incluyendole los módulos de nvidia :pensar:

Editado por Rohlling

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Estamos... jugando :happy:

 

acpi=off  disable ACPI (Advanced Configuration and Power Interface)
 

irqpoll  When an interrupt is not handled search all handlers for it. Also check all handlers each timer interrupt. Intended to get systems with badly broken firmware running.
 

acpi_enforce_resources=lax Check for resource conflicts between native drivers and ACPI OperationRegions (SystemIO and SystemMemory only). IO ports and memory declared in ACPI might be used by the ACPI subsystem in arbitrary AML code and can interfere with legacy drivers. strict (default): access to resources claimed by ACPI is denied; legacy drivers trying to access reserved resources will fail to bind to device using them.
lax: access to resources claimed by ACPI is allowed;
 

 

https://www.kernel.org/doc/Documentation/kernel-parameters.txt

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Esa es una buena pregunta.  De momento no te sabría qué contestar.  Voy a buscar info de la placa.  Tal vez debería actualizar también la bios..  Si descubro algo, aviso.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Siguiendo el hilo de kakahuete con su problema de gráfica, he seguido los siguientes pasos:

 

rohlling@debian:~$ lspci -nn|grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [8086:0412] (rev 06)
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF119 [GeForce GT 610] [10de:104a] (rev a1)

rohlling@debian:~$ dmesg|grep VGA
[    0.000000] Console: colour VGA+ 80x25
[    5.829903] hda-intel 0000:01:00.1: Handle VGA-switcheroo audio client

rohlling@debian:~$ inxi -G

Graphics:  Card-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
           Card-2: NVIDIA GF119 [GeForce GT 610]
           Display Server: X.Org 1.15.0.901 drivers: intel (unloaded: fbdev,vesa) Resolution: 1360x768@59.8hz
           GLX Renderer: N/A GLX Version: N/A

 

Debian sabe que hay una gráfica, y la identifica, aparte de que sabe donde está, así que sospecho que hay alguna otra cosa que impide la carga correcta de linux.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

No sera nada del tipo vga=791 en parametro kernel? yo tube un problema con un 10.04 que era que no me funcionaba el acpi=off no me booteaba graficamente, pero si en safe mode.

 

hal hilo de la cosa instale un paquete al que llaman v86f o algo asi y el parametro era vga=791 sino no habia imagen.

 

Comento esto por si sirve de algo.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Ya me lo sugirió en su momento Shiba, pero no es eso.  Digamos que hasta pasado el grub, todo bien, después en la carga inicial se queda bloqueado.  Creo que es cuando detecta la nvidia, pero no se porqué no carga los controladores. 

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Bueno, demostración de lo torpe que soy.  Al deshabilitar la gráfica integrada, todo ha ido rodado.  Eso si, ahora tengo que decidir si libres o privativos.  De momento estoy probando con privativos y no acaban de usar la pantalla del todo (se me queda una banda negra en el lateral izquierdo), además de que las letras de los menús y títulos se han "enanizado" enórmements :D.

Compartir este post


Enlace al post
Compartir en otros sitios

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invitado
Responder esta pregunta...

×   Has incluido contenido con formato.   Eliminar formato

  Sólo se permiten 75 emoticonos como máximo.

×   Tu enlace ha sido insertado automáticamente.   Deshacer y mostrar como enlace

×   Su contenido anterior ha sido restaurado.   Limpiar editor

×   No puedes pegar imágenes directamente. Súbelas a algún hosting de imágenes y pega la dirección URL

Conéctate para seguir esto  

×
×
  • Crear Nuevo...