Ir al contenido

Recommended Posts

qpja.jpg

 

Trago amargo como el que más, la consecuencia más que probable si trasteamos en exceso con nuestro pobre ZTE Open compilando, modificando y poniendo a prueba Firefox OS hasta lo inimaginables es que, en algún momento, nuestro terminal acabe como un pisapapeles con pantalla táctil :sweat:

 

NOTA: Hablamos de un caso hipotético, cualquier parecido con la realidad es pura coincidencia :jumm:

 

Para ponernos en situación y asustar un poquito al personal, la propia ZTE tuvo un pequeño "lapsus" cuando hizo pública la actualización a Firefox OS 1.1, lo que provocó el Brickeo de algunos dispositivos que, tras terminar el proceso de instalación, no volvieron a arrancar. La "solución" propuesta por telefónica fue recurrir al servicio técnico para la sustitución del terminal por uno ya actualizado, algo engorroso y a la vez imposible de realizar para aquellos que no han obtenido el teléfono a través de telefónica o le han  hecho algún tipo de modificación que anule la garantía (liberación, cambio del SO original, actualizaciones no oficiales, etc), en esta situación estaremos sólos, desamparados y sin teléfono :(.

 

fgwc.png

 

La verdad es que llegar a brickear un ZTE Open bastante complicado, ya que siempre existen opciones para trabajar con él, pero se puede dar el caso de que todo salga mal.

 

Con nuestro ZTE Open Rooteado, la imagen del ClockworkMod instalada, nos disponemos a compilar una versión personalizada de Firefox OS pero.... durante el proceso algo sale mal y el teléfono no arranca, pero bueno, siempre hay opciones, así que nos decidimos por instalar una imagen oficial para devolver el teléfono a su estado original y empezar de nuevo con el flasheo. Sin embargo, puestos a que todo salga mal, la imagen oficial resulta ser precisamente la que nombramos antes y el flasheo resulta un fracaso.

Ahora el teléfono sigue sin arrancar, pero al realizar el flasheo fallido hemos perdido la posibilidad de acceder al teléfono como root, la administración remota ha sido deshabilitada, con lo cual ya no podemos valernos de ADB y el ClockWorkMod ha sido sustituido por la imagen Recovery de fábrica. Nos quedaría un último as bajo la manga, el modo FastBoot, el cual nos permitiría flashear una nueva imagen de Firefox OS directamente y se activa pulsando simultáneamente el botón de Encendido, subir  y bajar Volumen, es decir, todos los botones físicos del teléfono. Pero ¡Oh sorpresa! ZTE lo ha bloqueado y lo único que conseguimos es una pantalla negra y un piloto rojo encendido ¿Y ahora qué? :shock: .

 

Lo único que nos queda es el modo recovery, pero en la versión de fábrica sólo permite la instalación de imágenes muy concretas y firmadas, así que aunque lo intentemos, sin el ClockworkMod nos encontraremos con un error tras otro al tratar de flashear una nueva imagen de Firefox OS a través del menú recovery. Admitámoslo. ¡La hemos cagado! :icon_ouch:

 

3ddk.png

 

 

Es de madrugada, se nos han agotado las opciones, nuestra la visión se nubla, no quedan paredes sin marcas de cabezazos, nuestro pobre ZTE ha pasado a mejor vida y nosotros hemos sido sus ejecutores :llopa:

 

Pero ¿Y si hubiera una manera?¿Hacemos un último intento a la desesperada? Pues qué quieren que les diga, de perdidos al río ¿No? :P

 

La imagen que logrará saltarse las limitaciones del limitado Recovery de ZTE y traerá de nuevo a la vida nuestro terminal es la que nos proporcionan en http://firefox.ztems.com/

Es pequeña,antigua y muy limitada, pero nos servirá como punto de partida para recuperar toda la funcionalidad del teléfono. Evidentemente la que nos interesa es la que corresponde al modelo Open, no al Kiss, no nos vayamos a equivocar aquí porque entonces sí que estaremos perdidos :ohh:

 

udd8.jpg

 

La imagen se instala como cualquier otra, colocando el archivo Zip en la tarjeta de memoria, iniciando el teléfono en modo recovery (Botón de encendido + subir volumen) yendo al menú de actualización y seleccionando el zip a instalar, aunque tendremos un pequeño problema a la hora de copiar la imagen a la tarjeta del teléfono, ya que éste no funciona, vamos a necesitar otro lector de tarjetas Micro SD para poder hacerlo :sweat:

 

Eso sí, una vez recuperado el teléfono, mejor no perder tiempo en volver a recuperar todas las herramientas, ClockworkMod, rooteo, habilitar la depuración remota para acceder vía ADB...

Recordemos que esta vez nos hemos librado por los pelos, no tentemos a la suerte :lol: :lol:

Compartir este post


Enlace al post
Compartir en otros sitios

Hola Shiba.. yo molestando de nuevo..

 

Resulta que luego de instalar un ROM de TME con la versión 1.1 de FirefoxOS, el teléfono empezó a hacer cosas extrañas. El tema es, que por más que intenté no pude rootearlo, así que procedí a usar el ZIP de http://firefox.ztems.com/. Actualicé sin problemas, pero resulta que ahora cuando inicio el teléfono, luego de llegar al Zorro moviendo la cola se reinicia.

 

Por suerte, hay una milésima de segundo en la que tengo acceso vía ADB, y logré rootearlo, pero como comprenderás, no puedo trabajar con ADB si se reinicia constantemente, y no podré instalar el ClockwordMod. Mi pregunta es:

 

¿Sabes si puedo evitar que se reinicie? Evidentemente lo intenté con

adb wait-for-device ; adb shell stop b2g

Pero no funcionó..

Compartir este post


Enlace al post
Compartir en otros sitios

Mientras no sea para pedirme un préstamo, molesta lo que quieras, para eso está el foro :jojojo:

 

Creo que más o menos todos los que nos metemos a trastear con el "Open" (Bastante irónico con lo difícil que nos lo pone ZTE) vamos pasando por lo mismo. No creo que tardes mucho en hacer alguna locura, como compilar B2G por tu cuenta... :silba:

 

Así de entrada se me ocurre algo, que probablemente es algo que ni yo haría y es apurar al máximo ese tiempo que tienes con ADB para instalar directamente Clockworkmod, pero como es muy probable que te quedes a medias o ni siquiera llegues a empezar y ya que el flasheo es reciente, lo más recomendable sería empezar de nuevo y, antes de actualizar, rootear y meter ClockworkMod. ¿Que luego al actualizar sale todo bien? Pues perfecto ¿Que no? Tenemos CWM para trabajar, limpiar cache y lo que haga falta. Es un poco frustrante, pero todo sea por dar de una vez con la fórmula correcta :sweat:

Compartir este post


Enlace al post
Compartir en otros sitios

Mientras no sea para pedirme un préstamo, molesta lo que quieras, para eso está el foro :jojojo:

 

Creo que más o menos todos los que nos metemos a trastear con el "Open" (Bastante irónico con lo difícil que nos lo pone ZTE) vamos pasando por lo mismo. No creo que tardes mucho en hacer alguna locura, como compilar B2G por tu cuenta... :silba:

 

Así de entrada se me ocurre algo, que probablemente es algo que ni yo haría y es apurar al máximo ese tiempo que tienes con ADB para instalar directamente Clockworkmod, pero como es muy probable que te quedes a medias o ni siquiera llegues a empezar y ya que el flasheo es reciente, lo más recomendable sería empezar de nuevo y, antes de actualizar, rootear y meter ClockworkMod. ¿Que luego al actualizar sale todo bien? Pues perfecto ¿Que no? Tenemos CWM para trabajar, limpiar cache y lo que haga falta. Es un poco frustrante, pero todo sea por dar de una vez con la fórmula correcta :sweat:

 

El tema es que, el teléfono se reinicia constantemente, o sea, cuando empieza a cargar la animación del Zorro, tengo acceso a ADB por unas milésimas de segundos, pues se reinicia de nuevo. Ya tengo rooteado el teléfono, pero no puedo instalar CWM debido a lo que te comento.. :(

Compartir este post


Enlace al post
Compartir en otros sitios

Conozco ese mal, sólo que no escribo lo que pienso para no dar (malas) ideas :lol:

 

 

Teniendo la imagen de clockworkmod en la tarjeta sd (CWM.img)

 

adb adb wait-for-device; adb shell flash_image recovery /sdcard/CWM.img

O en caso de no aparecer como root habría que intercalar un "su",pero ya perderíamos más tiempo

 

 

En cualquier caso, si es por experimentar se podría intentar algo más, pero para tenerlo funcional lo antes posible y con menos quebraderos de cabeza, como dije antes y siendo prácticos, se tarda menos en volver a empezar que en tratar de recuperar esa actualización fallida :sweat:.

Compartir este post


Enlace al post
Compartir en otros sitios

Conozco ese mal, sólo que no escribo lo que pienso para no dar (malas) ideas :lol:

 

 

Teniendo la imagen de clockworkmod en la tarjeta sd (CWM.img)

adb adb wait-for-device; adb shell flash_image recovery /sdcard/CWM.img

O en caso de no aparecer como root habría que intercalar un "su",pero ya perderíamos más tiempo

 

 

En cualquier caso, si es por experimentar se podría intentar algo más, pero para tenerlo funcional lo antes posible y con menos quebraderos de cabeza, como dije antes y siendo prácticos, se tarda menos en volver a empezar que en tratar de recuperar esa actualización fallida :sweat:.

 

Una par de cosas:

 

Tengo la oportunidad de acceder al Fastboot, pero sucede esto:

fastboot flash recovery recovery-clockwork-6.0.3.3-
roamer2.img
sending 'recovery' (5712 KB)...
OKAY [  0.487s]
writing 'recovery'...
FAILED (status read failed (No such device))
finished. total time: 5.824s
 
Pues cuando intenta escribir se reinicia.
 
Ahora, cuando me dices "volver a empezar" a que te refieres?

Compartir este post


Enlace al post
Compartir en otros sitios

 

Mientras no sea para pedirme un préstamo, molesta lo que quieras, para eso está el foro :jojojo:

 

Creo que más o menos todos los que nos metemos a trastear con el "Open" (Bastante irónico con lo difícil que nos lo pone ZTE) vamos pasando por lo mismo. No creo que tardes mucho en hacer alguna locura, como compilar B2G por tu cuenta... :silba:

 

Así de entrada se me ocurre algo, que probablemente es algo que ni yo haría y es apurar al máximo ese tiempo que tienes con ADB para instalar directamente Clockworkmod, pero como es muy probable que te quedes a medias o ni siquiera llegues a empezar y ya que el flasheo es reciente, lo más recomendable sería empezar de nuevo y, antes de actualizar, rootear y meter ClockworkMod. ¿Que luego al actualizar sale todo bien? Pues perfecto ¿Que no? Tenemos CWM para trabajar, limpiar cache y lo que haga falta. Es un poco frustrante, pero todo sea por dar de una vez con la fórmula correcta :sweat:

 

El tema es que, el teléfono se reinicia constantemente, o sea, cuando empieza a cargar la animación del Zorro, tengo acceso a ADB por unas milésimas de segundos, pues se reinicia de nuevo. Ya tengo rooteado el teléfono, pero no puedo instalar CWM debido a lo que te comento.. :(

 

 

A mi me paso algo parecido con el, no queria contestar pues no tengo nada que aportar, me pillo en un momento muy malo y sinceramente este movil me dio mucho por saco ya que compre la version EU por eBay, los tutoriales que puso @@Shiba87 solo funciono el de rooteo, me daba todo correcto en el terminal, sin embargo con el adb nunca pude acceder al movil, paso por paso, incluso ni los menus que tenia mi movil eran iguales a las capturas que muestra Shiba ni teniendo la misma version aunque el en español y yo en ingles, tampoco pude cambiarle nunca el idioma, con la ultima actualizacion me paso exactamente lo que tu dices entraba en bucle con el logo de firefox, cuando parecia que ya cargaba volvia al reinicio y asi sucesivamente, me pudo la rabia y el ya no esta entre nosotros  :llora:

Compartir este post


Enlace al post
Compartir en otros sitios

Era de esperar que no resultara el flasheo, es muy poco tiempo antes del reinicio :icon_ouch:

 

Con empezar de nuevo me refiero a coger otra vez la imagen de http://firefox.ztems.com/, flashear y dejar el teléfono "de serie", limpio, como si no le hubieran metido mano nunca. 

El sentido más literal posible de "empezar de nuevo":sweat:

Compartir este post


Enlace al post
Compartir en otros sitios

Resulta que luego de instalar un ROM de TME con la versión 1.1 de FirefoxOS, el teléfono empezó a hacer cosas extrañas. El tema es, que por más que intenté no pude rootearlo, así que procedí a usar el ZIP de http://firefox.ztems.com/. Actualicé sin problemas, pero resulta que ahora cuando inicio el teléfono, luego de llegar al Zorro moviendo la cola se reinicia.

 

Pues definitivamente si ese era el paso de la salvación, mal estoy..

 

E: failed to Verify whole-file signature

 

elav, a mi me paso exactamente lo mismo que a ti. El movil venia con la version 1.1 de movistar españa (TME). Ante la imposibilidad de hacer root al cacharro pense en flashear el arquivo update.zip de http://firefox.zterms.com.

Al final lo hice y las consecuencias para el trasto fueron las mismas: se reinicia antes de empezar la animacion. Ademas el recovery ha cambiado (ahora pode android recovery 3e en vez de firefox os recovery) y no acepta ninguna

actualizacion de ZTE puesto que falla siempre con E: failed to Verify whole-file signature

 

Resulta que he indagado un poco y, por suerte para nosotros, el recovery de android (para los que instalamos el update.zip de la pagina arriba indicada) esta configurado para utilizar las claves publicas y privadas de prueba del AOSP (Android Open Source Project), lo que significa que cualquiera puede sincronizar las fuentes de google y firmar actualizaciones para este recovery  :lol: 

 

Para probarlo he ulizado la imagen "endiablada" de http://sl.edujose.org/, que es la version 1.0 y permite hacer root con el procedimiento descrito en http://pof.eslack.org, y la he firmado con las testkeys del AOSP.El

update-signed.zip resultante lo he colgado en http://ul.to/sg97g0qj para que podais probarlo. A mi me ha funcionado estupendamente y he recuperado el telefono  :D

 

Ademas resulta que es un procedimiento interesante, ya que permite hacer "downgrade" del telefono para poder rootearlo.

 

Yo personalmente, ya en la version 1.0 , flashee el CWM y me hice un update.zip con la version ZTE1.1-TME , cuando la aplique desde CWM el mismo me dijo que se habia perdido el root, y si queria recuperarlo.

Le di a "si" y ahora estoy en la version 1.1 española con root y recovery avanzado  :reves:

 

Espero que os sirva :), pero evidentemente NO DOY NINGUN TIPO DE GARANTIA  :blink: , aunque para aquellos con bootloop y la recovery de android no es que vayan a perder mucho :rip:

Editado por pazos

Compartir este post


Enlace al post
Compartir en otros sitios

Buenas,

 

Enhorabuena a [pazos]. Mal por parte de Mozilla. Algo asi lo deberian haber previsto. Y algo como lo que has hecho tu [pazos] tambien lo podian haber intentado. En mi caso me quede como [urkh].

 

Por otra parte, he probado a volver a "liarla" y veo que el metodo ZTEOpenAndroid -> firmware_de_pazos -> root -> CWM funciona en las veces que he probado. Incluso ya de tiron he probado a meterle una "nightly build" (1.4 pre-release de las ya compiladas) y funciona... bueno, he tenido algun problemilla al entrar (pantalla en blanco, ya solucionado [si alguien prueba que me avise]), pero funciona mas fluido. El WiFi me funciona, los contactos tambien, y me queda por probar el Bluetooth y la SIM (que la tengo en el otro).

 

Ahora a trastear con las fuentes. A ver si hay alguna forma de reducir el consumo de bateria...

 

Un saludo.

Compartir este post


Enlace al post
Compartir en otros sitios

Buenas,

 

No, insisto, Mozilla. La solucion es de "soft". Mozilla Foundation tiene acceso a ZTE, al codigo y a todo, pero no han sido capaces de darle solucion. Ya habia casos desde Agosto con la actualizacion version 1.1 (sin lo del "recovery android", pero enladrillados por los reinicios continuos y el "recovery" original dando errores de firma). Esto es algo que Mozilla tenia que haber previsto desde el principio: un mecanismo de emergencia para sacar los terminales de la "via ZTE" y pasarlos a la "via Mozilla".

 

Es lo que hay.

 

Como cosa curiosa, ahora que [pazos] ha descubierto la forma de pasar del "firmware Android" del Open, degradarolo, "root"-earlo y actualizarlo a los "builds" de Mozilla, la pagina del "firmware Android" ha cerrado. Curioso cuando menos.

Compartir este post


Enlace al post
Compartir en otros sitios

Gracias Pazos!!!!!

 

Le meti como 10 roms oficiales incluida la que siempre me funciono la 1.0 GB para solucionar brickeos de zte y nada...

 

Se ve que al meter la rom "endiablada", como dices, cambio las keys de verificacion del recovery a las de desarrollo.

 

Gracias, me estaba volviendo loco.

 

Saludos!

Compartir este post


Enlace al post
Compartir en otros sitios

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invitado
Responder en este tema...

×   Has incluido contenido con formato.   Eliminar formato

  Sólo se permiten 75 emoticonos como máximo.

×   Tu enlace ha sido insertado automáticamente.   Deshacer y mostrar como enlace

×   Su contenido anterior ha sido restaurado.   Limpiar editor

×   No puedes pegar imágenes directamente. Súbelas a algún hosting de imágenes y pega la dirección URL


×
×
  • Crear Nuevo...