Ir al contenido

Buscar en La Comunidad

Mostrando resultados por etiquetas 'apt-get'.

  • Buscar Por Etiquetas

    Añade etiquetas separadas por comas.
  • Buscar Por Autor

Tipo de Contenido


Foros

  • Contacto con el staff
    • Novedades / Anuncios del foro
    • Sugerencias
    • Problemas relacionados con el foro
  • Zona general de charla
    • Presentaciones
    • Charla
    • Zona de Humor, Curiosidades y Otros
    • Mascotas Vagos
    • Noticias del Mundo
    • Tecnología
    • Ayuda y consultas de carácter general
  • Zona GNU/Linux
    • Ayuda, consultas y soporte GNU/Linux
    • Distribuciones GNU/Linux
    • Repositorios. Software GNU/Linux
    • Personalización
    • Raspberry Pi
    • Arduino
    • Manuales / Tutoriales / Guías GNU/Linux
    • Programación
    • Noticias GNU/Linux
    • Hablando de GNU/Linux
  • Zona Gaming
    • Juegos GNU/Linux
    • Noticias Gamer
    • Charla Gamer
  • Zona Móvil
    • Ayuda y soporte para dispositivos móviles
    • Apps Móviles
    • Manuales / Tutoriales / Guías Móviles
    • Roms para dispositivos Móviles
    • Noticias sobre dispositivos Móviles
    • Hablando sobre dispositivos Móviles
  • Zona Mozilla
    • Ayuda, consultas y soporte Mozilla
    • Aplicaciones Mozilla
    • Roms Firefox OS
    • Manuales / Tutoriales / Guías Mozilla
    • Noticias Mozilla
    • Hablando de Mozilla
  • Microsoft
    • Papelera del Foro

Encontrar resultados en...

Encontrar resutados que...


Fecha de Creación

  • Start

    Fin


Última Actualización

  • Start

    Fin


Filtrar por numero de...

Joined

  • Start

    Fin


Grupo


Página Web


Diaspora


Pump


GNU Social


Google +


Twitter


Facebook


Xmpp


Skype


Steam


Desura


MediaGoblin


Youtube


Vimeo


Picasa


Flickr


Email


Lugar


Intereses

Encontramos 5 resultados

  1. Apt-fast es un script shell que permite la paralelización de descargas de paquetes deb, tanto con apt-get, apt o aptitude. Éste nos permite descargar varios paquetes simultáneamente, desde diferentes mirros estableciendo varias conexiones por cada uno, en lugar de descargarlos de uno en uno como ocurre por defecto. Esto tiene una ventaja para el usuario, ya que puede exprimir al máximo su conexión a Internet para descargar los paquetes deb mucho más deprisa, pero también tenemos que tener en cuenta el lado del servidor, ya que las descargas en paralelo, para quien las sirve, suponen trabajo extra y no son ni remotamente tan divertidas como para quien los descarga. En este sentido, además de no exagerar con el número de conexiones y descargas en paralelo, tendremos a bien definir varios mirrors en el archivo de configuración, para no sobrecargar uno sólo, sino hacer descargas de distintos paquetes desde diferentes servidores cada uno. PPA Existe un reporitorio PPA desde el que podemos descargar e instalar Apt-fast. Tan sencillo como add-apt-repository ppa:saiarcot895/myppa aptitude update aptitude install apt-fast Manualmente Pero como ya nos conocemos, vamos a indicar también cómo instalar el script manualmente desde github. Como dependencias tendremos los paquetes aria2 y, obviamente, git. El proceso es tan sencillo como clonar el repositorio github, copiar el binario del script a /usr/bin (con permisos de ejecución) y sus archivo de configuración a /etc aptitude install aria2 git git clone https://github.com/ilikenwf/apt-fast /tmp/apt-fast cd /tmp/apt-fast cp apt-fast /usr/bin chmod +x /usr/bin/apt-fast cp apt-fast.conf /etc Bash completion La opción de autocompletado bash es muy útil a la hora de trabajar con paquetes, así que nos conviene activar dicha opción antes de empezar a lidiar con apt-fast cp completions/bash/apt-fast /etc/bash_completion.d chown root:root /etc/bash_completion.d/apt-fast . /etc/bash_completion Zsh completion Igualmente, sin el lugar de bash nos valemos de zsh, la situación es la misma, pero el proceso ligeramente distinto. cp completions/zsh/_apt-fast /usr/share/zsh/functions/Completion/Debian chown root:root /usr/share/zsh/functions/Completion/Debian/_apt-fast source /usr/share/zsh/functions/Completion/Debian/_apt-fast Páginas Man Porque en algún momento puede que necesitemos consultar el manual cp ./man/apt-fast.8 /usr/share/man/man8 gzip -f9 /usr/share/man/man8/apt-fast.8 cp ./man/apt-fast.conf.5 /usr/share/man/man5 gzip -f9 /usr/share/man/man5/apt-fast.conf.5 Configuración Apt-fast cuenta con un asistente, que nos aparecerá tanto al instalar el paquete como al invocar la orden: dpkg-reconfigure apt-fast Pero ya que nos hemos estado ensuciando las manos desde el principio, voy a seguir con la configuración manual. El archivo de configuración de apt-fast está bien comentado, así que me limitaré a hablar de las opciones más relevantes en nuestro caso dentro de /etc/apt-fast.conf: Por defecto utilizará apt-get, pero los que ya me conocen saben que en mi caso siempre recomiendo aptitude en su lugar, así que: Definir mirrors El listado de mirrors es muy importante, como ya hemos dicho, así que nos tomaremos un momento para definirlos. No es necesario que los especifiquemos tal y como los tenemos en /etc/apt/sources.list, sólo necesitamos la dirección del mirror, ni ramas ni opciones ni nada por el estilo, tal y como se expresa en los ejemplos, simplemente una serie de direcciones separadas por comas: Número máximo de conexiones, definido por _MAXNUM. El valor por defecto es de 5, es decir, 5 descargas en paralelo, que es un valor bastante bueno, así que salvo que tengamos otros planes, podemos dejarlo así (¿Han visto cuantos mirros he definido antes? ) Máximo de conexiones por servidor. De nuevo el valor por defecto es más que suficiente Descargando e instalando paquetes Apt-fast no se diferencia de las herramientas utilizadas hasta ahora. De hecho, hemos definido la que utilizará por defecto, así que las opciones a utilizar serán las mismas que apt-get o aptitude, sólo que el comanda será apt-fast Repositorio github https://github.com/ilikenwf/apt-fast
  2. Buenas tardes, dicen que "Echando a perder se aprende", pues bien hoy he aprendido cómo recuperar mi sistema (Ubuntu 16.04) luego de echarlo a pique por "trastear" con el entorno gráfico. Reinicié mi equipo, con la sorpresa de no tener entorno gráfico, esta es la secuencia: Nuevo reinicio, busco "Opciones avanzadas para Ubuntu" Selecciono "... Linux 4.4.0-36-generic (recovery mode)" Paso a "consola root", trasteo algunos comandos..., y ahí vino la debacle, Ejecuté "apt-get autoremove", y este comando borró todo lo que pudo. Repito los pasos 1 y 2, intento "Continuar con el arranque normal" Salgo en modo texto, autentico mi usuario, y aplico la solución, a saber sudo dpkg --configure -a sudo apt-get -f install sudo apt-get update sudo apt-get dist-upgrade sudo apt-get install --reinstall ubuntu-desktop sudo init 6 ** sudo init 6 reinicia el equipo El equipo arrancó de manera normal, tuve que recuperar algunos paquetes previamente instalados, y ahora va de nuevo como la seda. Espero esta información sea de utilidad Nota: agradezco de antemano si el tema requiere alguna modificación de etiquetas o reubicación, estas sean hechas. Un saludo JPablos
  3. Al ejecutar un apt-get update me da este error al final: Descargados 335 kB en 9s (36,7 kB/s) Leyendo lista de paquetes... Hecho W: http://download.virtualbox.org/virtualbox/debian/dists/jessie/InRelease: Signature by key 7B0FAB3A13B907435925D9C954422A4B98AB5139 uses weak digest algorithm (SHA1) W: http://dl.google.com/linux/chrome/deb/dists/stable/Release.gpg: Signature by key 4CCA1EAF950CEE4AB83976DCA040830F7FAC5991 uses weak digest algorithm (SHA1) W: http://dl.google.com/linux/talkplugin/deb/dists/stable/Release.gpg:'>http://dl.google.com/linux/talkplugin/deb/dists/stable/Release.gpg: Signature by key 4CCA1EAF950CEE4AB83976DCA040830F7FAC5991 uses weak digest algorithm (SHA1) W: http://linux.dropbox.com/debian/dists/sid/Release.gpg: Signature by key 1C61A2656FB57B7E4DE0F4C1FC918B335044912E uses weak digest algorithm (SHA1) W: http://mega.nz/linux/MEGAsync/xUbuntu_15.04/./Release.gpg: Signature by key BF8B66E01192CBA2E72201294B4E7A9523ACD201 uses weak digest algorithm (SHA1) E: Fallo al obtener http://dl.google.com/linux/talkplugin/deb/dists/stable/Release No existe una entrada «Hash» en el archivo «Release» /var/lib/apt/lists/dl.google.com_linux_talkplugin_deb_dists_stable_Release, lo cual se considera suficientemente robusto para propósitos de seguridad E: No se han podido descargar algunos archivos de índice, se han omitido, o se han utilizado unos antiguos en su lugar. ¿Como puedo solucionarlo?
  4. Un comando que he encontrado para desinstalar las dependencias innecesarias después de ejecutar "apt-get build-dep" para compilar algún programa: sudo aptitude markauto $(apt-cache showsrc NOMBRE_PAQUETE | grep Build-Depends | perl -p -e 's/(?:[\[(].+?[\])]|Build-Depends:|,|\|)//g') Se sustituye NOMBRE_PAQUETE por el nombre del paquete que se haya compilado. Lo cierto es que el comando me parece un poco "largo", si alguien tiene alguna corrección o simplificación, o algún otro método, bienvenido sea. Un saludo
  5. Varias consultas: Primero, ¿por qué al ejecutar apt-get upgrade (como root, obviamente) hay algunos paquetes que no se actualizan automáticamente? Los que me suelen aparecer son estos: linux-generic-pae linux-headers-generic-pae linux-image-generic-pae Al principio me supuse que se bloqueaban porque eran paquetes especiales o importantes (no sé exactamente lo que son :pinch:, pero creo que será algo del kernel). Pero también me ocurre con otros como JDownloader y me suena que wine también alguna vez y para estos ya no se me ocurre ninguna explicación Y ya aprovecho a comentaros que he visto que por aquí algunos parece que usan más aptitude en vez de apt-get. ¿Diferencias? ¿Ventajas?
×
×
  • Crear Nuevo...