Ir al contenido
Shiba87

[Obsoleto] Script de instalación de Steam para Debian GNU/Linux

Recommended Posts

Bueno, decir que ya he conseguido hacer funcionar Steam en el portatil. Lo unico que hice fue desintalar los drivers de los repositorios e instalar los de la pagina de AMD y funciono a la primera. Esta tarde probare a hacer lo mismo con los de Nvidia en el sobremesa.

 

Un saludo :)

Compartir este post


Enlace al post
Compartir en otros sitios

AVISO: Con gran placer, declaro este tema y el script que aparece en él, totalmente OBSOLETOS. Tras el comunicado oficial del lanzamiento de la versión final de Steam GNU/Linux, el paquete deb de steam ha sido rehecho y todas las dependencias inútiles que exigían las versiones anteriores han desaparecido, ya no son necesarias, por lo que podemos instalar el paquetes steam.deb directamente o desde los repositorios de Valve sin ningún problema.

 

Las únicas dependencias necesarias para hacer funcionar steam a día de hoy son:

libc6, libgl1-mesa-dri, libgl1-mesa-glx, xterm | gnome-terminal, zenity
Sin exigir versiones experimentales de ningún paquete, sin nombres modificados para que llevan a conflictos..... por fin unas dependencias sensatas :P.

Compartir este post


Enlace al post
Compartir en otros sitios

Y una vez más, parece que siguen dando tumbos, ahora el paquete steam ha quedado descontinuado y ha aparecido un nuevo paquete steam-launcher que vuelve a introducir todas esas dependencias no deseadas, por lo que el nuevo script no sirve de mucho ahora mismo salvo para originar un buen conflicto de dependencias que no queremos.

 

He modificado el script antiguo para que apunte al nuevo paquete y lo instale siguiendo el anterior método de descargar, descomprimir y copiar.

 

 

NOTA He visto que en algunos lugares se hacen eco de una versión de Steam Amd64. Esto NO es cierto, antes de hacer el cambio a steam_launcher apareció en los repositorios de valve un paquete steam64 que no es lo que su nombre indica, es un paquete "vació" que lo único que hace es instalar el paquete steam.i386 en sistema de 64 bits.

Este paquete, al desaparecer steam.deb, también ha quedado fuera de juego.

Compartir este post


Enlace al post
Compartir en otros sitios

Se sigue actualizando steam a diario, parece que salieron precipitadamente de la Beta y que aun quedan muchos cambios por realizar, de todas formas tanto el cliente como los juegos funcionan perfectamente para GNU/Linux, los ultimos cambios han sido mas para la interfaz del cliente que para otra cosa :)

Compartir este post


Enlace al post
Compartir en otros sitios

Un último "detalle", que no está en el script porque es bastante chapucero :sweat:

 

Para evitar los mensajes avisando que faltan dependencias y demás:

rm /usr/bin/steamdeps
No afecta de manera alguna al funcionamiento de steam, el ejeutable se encarga simplemente de eso, de comprobar que tienes todas las dependencias que se piden

Compartir este post


Enlace al post
Compartir en otros sitios

Muy bien, del instalable directo de Debian no pude instalarlo, pero el script funciono (de momento ya veremos si cuando reinicie funciona algo :jojojo) :D

 

Edito:

 

captura1mf.jpg

 

 

 

 

Edito: Ahora ya ni me abre, ahora simplemente el error de falta steamui.so, he intentado lo de las librerias libGL.so pero no me ha salido bien o lo hago mal........

Compartir este post


Enlace al post
Compartir en otros sitios

Teniendo el de Debian, no uses el de *buntu, es mucho peor

 

Actualiza libc6 desde el repositorio unstable como decía en el otro hilo y ya deberías tenerlo

Sí claro, ya lo hice de hecho con el script y con el mismo procedimiento con el cuál lo hice cuándo me funcionó pero no me está procesando eso

Dice como si no conociera que es experimental, o mejor dicho, como si no tuviera ninguna repo experimental, y acabo de verificar el archivo y está la repo del otro post

Compartir este post


Enlace al post
Compartir en otros sitios

El script no sirve (a no ser que alguien se anime a rehacerlo).

El repo donde se encuentra libc6 no es el experimental es el UNSTABLE o Testing. Por mucho que busques en experimental no servirá de nada.

Actualizando libc6 desde unstable/testing estará todo hecho para el paquete oficial de Debian, para el *buntu faltarán más cosas.

Compartir este post


Enlace al post
Compartir en otros sitios

El script no sirve (a no ser que alguien se anime a rehacerlo).

El repo donde se encuentra libc6 no es el experimental es el UNSTABLE por mucho que busques en experimental no servirá de nada.

Actualizando libc6 desde unstable estará todo hecho para el paquete oficial de Debian, para el *buntu faltarán más cosas.

Ah listo amigo, lo probaré! me faltaba saber esa parte del unstable/experimental

Compartir este post


Enlace al post
Compartir en otros sitios

Ahora me sale ésto:

root@debiani3:/home/juan/Downloads# dpkg -i libc6_2.17-3_amd64.deb 
dpkg: regarding libc6_2.17-3_amd64.deb containing libc6:amd64:
 libc6:amd64 breaks locales (<< 2.17)
  locales (version 2.13-38) is present and installed.

dpkg: error processing libc6_2.17-3_amd64.deb (--install):
 installing libc6:amd64 would break locales, and
 deconfiguration is not permitted (--auto-deconfigure might help)
Errors were encountered while processing:
 libc6_2.17-3_amd64.deb

Compartir este post


Enlace al post
Compartir en otros sitios

Te vas a morir de asco :sweat:

 

OJO Chapuza, ojo y triple OJO con las dependencias

 

 

echo 'deb http://ftp.fr.debian.org/debian/ testing main contrib non-free' >> /etc/apt/sources.list.d/testing.list
aptitude update
aptitude install -t testing libc6 libc6:i386 multiarch-support
aptitude install -t experimental steam
rm /etc/apt/sources.list.d/testing.list

Compartir este post


Enlace al post
Compartir en otros sitios

 

Te vas a morir de asco :sweat:

 

OJO Chapuza, ojo y triple OJO con las dependencias

echo 'deb http://ftp.fr.debian.org/debian/ testing main contrib non-free' >> /etc/apt/sources.list.d/testing.list
aptitude update
aptitude install -t testing libc6 libc6:i386 multiarch-support
aptitude install -t experimental steam
rm /etc/apt/sources.list.d/testing.list

 

Ahora me dice que no existe -.- cuándo yo mismo la abrí y la modifiqué!

Compartir este post


Enlace al post
Compartir en otros sitios

 

¿Qué no existe?

El testing.list

 

Amigo ya pude, al menos ya me abre el login jajaja

Tengo un core i3, necesito algún paquete adicional para que me funcione todo correcto? (hablando de los gráficos, creo que son HD 3000)

 

 

Esa grafica es la misma de mi portatil, con ninguna distro he tenido problemas de aceleracion grafica, eso si no esperes grandes cosas de ella ya que es muy modestita :)

Compartir este post


Enlace al post
Compartir en otros sitios

Che lo segui al hilo y creo que ya esta desactualisado asi que pregunto.

¿como instalo steam en debian testing  64 bit?

El instalador de la pagina de steam me da error de dependencia jockey-common.

 

gracias desde ya

 

EDIT:

 

Segui el blog de shiba y logre instalarlo.

Editado por surfrock

Compartir este post


Enlace al post
Compartir en otros sitios

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invitado
Responder en este tema...

×   Has incluido contenido con formato.   Eliminar formato

  Sólo se permiten 75 emoticonos como máximo.

×   Tu enlace ha sido insertado automáticamente.   Deshacer y mostrar como enlace

×   Su contenido anterior ha sido restaurado.   Limpiar editor

×   No puedes pegar imágenes directamente. Súbelas a algún hosting de imágenes y pega la dirección URL


×
×
  • Crear Nuevo...