Ir al contenido
  • 0
Conéctate para seguir esto  
Fransis

problema con un paquete...ni palante ni patras

Pregunta

hola a todos, pues como dice el titutlo, tengo un problema con un paquete que parece que se le atraganto a linux mint. estamos hablando de liquorix,  y es que en una de las ultimas versiones que me llego, este parece que no termino de instalar, pero dpkg no me deja hacer nada, aptitude o apt tampoco, ni eliminarlo, ni reinstalarlo, nada...

el problema, es que se ve afectado todo el sistema, ya que no me deja actualizar nada mas, ni instalar nada nuevo...

os pego mis ultimos avances...

 

bartop@bartop:~$ sudo aptitude purge linux-headers-4.19.0-13.1-liquorix-amd64 
Se ELIMINARÁN los siguientes paquetes:            
  linux-headers-4.18.0-15.1-liquorix-amd64{u} 
  linux-headers-4.18.0-16.2-liquorix-amd64{u} 
  linux-headers-4.19.0-13.1-liquorix-amd64{p} 
  linux-modules-extra-4.15.0-38-generic{u} 
  linux-modules-extra-4.15.0-42-generic{u} 
0 paquetes actualizados, 0 nuevos instalados, 5 para eliminar y 89 sin actualizar.
Necesito descargar 0 B de archivos. Después de desempaquetar se liberarán 448 MB.
¿Quiere continuar? [Y/n/?] y
dpkg: error al procesar el paquete linux-headers-4.19.0-13.1-liquorix-amd64 (--remove):
 el paquete está en un estado muy malo e inconsistente - debe reinstalarlo
 antes de intentar desinstalarlo.
(Leyendo la base de datos ... 495762 ficheros o directorios instalados actualmente.)
Desinstalando linux-headers-4.18.0-15.1-liquorix-amd64 (4.18-18ubuntu1~bionic) ...
Desinstalando linux-headers-4.18.0-16.2-liquorix-amd64 (4.18-20ubuntu1~bionic) ...
Desinstalando linux-modules-extra-4.15.0-38-generic (4.15.0-38.41) ...
Desinstalando linux-modules-extra-4.15.0-42-generic (4.15.0-42.45) ...
Se encontraron errores al procesar:
 linux-headers-4.19.0-13.1-liquorix-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
                                                  
Estado actual: 1231 (-2) nuevos.
bartop@bartop:~$ sudo aptitude upgrade
Resolviendo las dependencias...                   
Se instalarán los siguiente paquetes NUEVOS:
  linux-headers-4.19.0-15.1-liquorix-amd64{a} 
  linux-image-4.19.0-15.1-liquorix-amd64{a} 
Se actualizarán los siguientes paquetes:
  adobe-flashplugin chromium-codecs-ffmpeg-extra dirmngr e2fslibs e2fsprogs 
  firefox firefox-locale-en firefox-locale-es gir1.2-gnomebluetooth-1.0 
  gir1.2-javascriptcoregtk-4.0 gir1.2-webkit2-4.0 gnome-bluetooth gnupg 
  gnupg-l10n gnupg-utils gpg gpg-agent gpg-wks-client gpg-wks-server 
  gpgconf gpgsm gpgv ibverbs-providers initramfs-tools initramfs-tools-bin 
  initramfs-tools-core krb5-locales libarchive13 libcaca-dev libcaca0 
  libcom-err2 libegl-mesa0 libegl1-mesa libegl1-mesa-dev libexiv2-14 
  libext2fs2 libgbm1 libgl1-mesa-dev libgl1-mesa-dri libgl1-mesa-glx 
  libglapi-mesa libgles2-mesa libgles2-mesa-dev libglx-mesa0 
  libgnome-bluetooth13 libgssapi-krb5-2 libgweather-3-15 libgweather-common 
  libibverbs-dev libibverbs1 libjavascriptcoregtk-4.0-18 libk5crypto3 
  libkrb5-3 libkrb5support0 libnss-myhostname libnss-systemd libnss3 
  libpam-systemd librdmacm1 libsmbclient libss2 libsystemd0 libudev-dev 
  libudev1 libwayland-egl1-mesa libwbclient0 libwebkit2gtk-4.0-37 
  libxatracker2 linux-firmware linux-headers-liquorix-amd64 
  linux-image-liquorix-amd64 linux-libc-dev mesa-common-dev mint-mirrors 
  mintbackup netplan.io nplan psmisc python-samba samba samba-common 
  samba-common-bin samba-libs systemd systemd-sysv udev usbmuxd 
Se RECOMIENDAN los siguientes paquetes, pero NO se instalarán:
  adobe-flash-properties-gtk adobe-flash-properties-kde e2fsprogs-l10n 
  gnome-control-center samba-dsdb-modules samba-vfs-modules 
  unity-control-center xul-ext-ubufox 
87 paquetes actualizados, 2 nuevos instalados, 0 para eliminar y 2 sin actualizar.
E: No se puede encontrar una fuente para descargar la versión «4.19-8ubuntu1~bionic» de «linux-headers-4.19.0-13.1-liquorix-amd64:amd64»
Después de desempaquetar se usarán 363 MB.
¿Quiere continuar? [Y/n/?] y
E: No se puede encontrar una fuente para descargar la versión «4.19-8ubuntu1~bionic» de «linux-headers-4.19.0-13.1-liquorix-amd64:amd64»
E: Error interno: no se pudo generar la lista de paquetes a descargar
E: Quizá las listas de paquetes están desactualizadas, intente «aptitude update» (o equivalente); de otra forma algunos paquetes o versiones no están disponibles desde la fuente de repositorio actual
bartop@bartop:~$ 

haber si me podeis hechar una mano, pinta a que tendra una solucion muy sencilla pero no doy con ella, ya os digo, reinstalar no sirve de nada, purgar tampoco....

Gracias

Compartir este post


Enlace al post
Compartir en otros sitios

7 respuestas a esta pregunta

Recommended Posts

  • 0

Ocasionalmente cuando he tenido problemas similares al tuyo con algún paquete lo he solucionado eliminando manualmente una parte de los ficheros que instala dicho paquete.

En tu caso la consola no menciona ningún fichero en especial, así que tiene pinta de ser algo diferente.

 

He buscado en los repositorios de linux mint y ubuntu por el nombre "liquorix" y no he encontrado nada, así pues lo único que se me ocurre ahora mismo es que busques el paquete en algún repositorio externo como launchpad y lo instales manualmente de forma individual, o si aún conservas el paquete .deb en tu disco duro que trates de reinstalarlo o que consultes que ficheros crea para eliminarlos manualmente.

 

Ojo, eso de eliminar manualmente ya sabrás que no es muy recomendable, en mi caso los paquetes no eran muy importantes para el sistema y no pasó nada, pero si se trata de algo relacionado con el kernel... puede no ser buena idea.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0
Ocasionalmente cuando he tenido problemas similares al tuyo con algún paquete lo he solucionado eliminando manualmente una parte de los ficheros que instala dicho paquete.
En tu caso la consola no menciona ningún fichero en especial, así que tiene pinta de ser algo diferente.
 
He buscado en los repositorios de linux mint y ubuntu por el nombre "liquorix" y no he encontrado nada, así pues lo único que se me ocurre ahora mismo es que busques el paquete en algún repositorio externo como launchpad y lo instales manualmente de forma individual, o si aún conservas el paquete .deb en tu disco duro que trates de reinstalarlo o que consultes que ficheros crea para eliminarlos manualmente.
 
Ojo, eso de eliminar manualmente ya sabrás que no es muy recomendable, en mi caso los paquetes no eran muy importantes para el sistema y no pasó nada, pero si se trata de algo relacionado con el kernel... puede no ser buena idea.
Gracias nible.
Si, ese paquete liquorix es un kernel personalizado, y proviene de su propio repositorio el cual tengo añadido, en el cual si esta ese kernel y el siguiente, osea esos paquetes están.
Pero por mas que trato de desinstalar o actualizar, no me deja hacer nada de nada, y ahí me quedo siempre...
Un saludo y gracias

Enviado desde mi MI 8 mediante Tapatalk

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Prueba con el comando purge remove ya que la referencia que te esta dando es de que al hacer purge te quiere instalar otro paquete de sustitucion y el cual no hay en el enlaze que este buscando.

 

Combina los comandos purge remove a ver si lo hace o bien combinando con el -f (force).

sudo apt-get remove --purge paquete

 

O bien intenta con el gestor de paquetes alternativo dpkg → sudo dpkg --remove --force-all paquete.

https://help.ubuntu.com/community/RemoveOldKernels

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0
hace 11 horas, portaro dijo:

Prueba con el comando purge remove ya que la referencia que te esta dando es de que al hacer purge te quiere instalar otro paquete de sustitucion y el cual no hay en el enlaze que este buscando.

 

Combina los comandos purge remove a ver si lo hace o bien combinando con el -f (force).

sudo apt-get remove --purge paquete 

 

O bien intenta con el gestor de paquetes alternativo dpkg → sudo dpkg --remove --force-all paquete.

https://help.ubuntu.com/community/RemoveOldKernels

 

Genial, muchas gracias. funcionando con el sudo dpkg --remove --force-all, me dio el mismo aviso de que el paquete se encontraba en mal estado y necesitaba reinstalarlo pero no lo encontraba, aun asi lo pudo remover correctamente, reconstruir la base de datos despues y ya me vuelven a funcionar los repositorios!!

muchas gracias

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Genial que te funcione amigo eso se debe a la opción --force que me parecio que te haria el buen trabajo pero no te dije informacion que te puede ser util de futuro - hay que tener cuidado al hacer esta opcion con errores de estos ya que te puede quebrar el sistema si por alguna razon no tienes kernel alternativo o bien te empieza a dar remocion de paqueteria desktop, asi mismo si pide upgrade de boot y grub y no te lo hace automatico.

 

Más que nada es informacion util para otros que vean este post para no hacerlo sin leer el terminal y los cambios que hara.

En tu caso no te dije nada porque me puse a leer tus alteraciones y se cernia solo sobre el linux-image que querias remover por lo tanto no daria problemas a terceros paquetes y si no tubieras otro kernel te saldria mensaje de que no hay linux image alternative.

 

Un saludo y a disfrutar de tu sistema que como vez siempre se puede arreglar un problema.

Compartir este post


Enlace al post
Compartir en otros sitios

Registra una cuenta o conéctate para comentar

Debes ser un miembro de la comunidad para dejar un comentario

Crear una cuenta

Regístrate en nuestra comunidad. ¡Es fácil!

Registrar una cuenta nueva

Iniciar Sesión

¿Ya tienes cuenta? Conéctate aquí.

Iniciar Sesión
Conéctate para seguir esto  

×