Ir al contenido
  • 0
pacoeloyo

Cambio de tarjeta gráfica y duda con los controladores.

Pregunta

Muy buenas familia, mi ordenador después de 9 años a comenzado a fallar " la gráfica esta muriendo", lleva todas las piezas de origen. Tengo un sistema dual, windows 7 y mint 18.03, en windows el ordenador ya ni siquiera funciona y si lo hace salen miles de puntos de colores en la pantalla y al poco tiempo falla y se bloquea, en mint va bien y solo hay algún que otro bloqueo en juegos "he vuelto a los juegos " y en youtube. Mi gráfica es una gforce 9800 gt, le voy a poner una gforce 1030, mi duda es ¿que hago con los driver? en este momento voy con los oficiales privativos 340.104 ¿los desinstalo, dejo los libres, y por ultimo pongo la gráfica nueva y pongo de nuevo los oficiales? supongo que los oficiales ya no serán los 340.104 en synaptic los últimos que me aparecen son los "NVIDIA binary driver - versión 384.130" estos tienen soporte para la GeForce GT 1030 https://www.nvidia.com/Download/driverResults.aspx/132524/en-us

Un saludo

Compartir este post


Enlace al post
Compartir en otros sitios

30 respuestas a esta pregunta

Recommended Posts

  • 0

Creo que no necesitas desinstalar los drivers más bien necesitas poner la nueva grafica y en caso que no haya imagen lo que harias creo que es reiniciar tirar de sesion en modo seguro o sin los drivers activos - nomodeset - parametro a kernel creo que funcionaria. 

 

No se si es necesario pero si dejaras los drivers libres instalados nouveau por ejemplo creo que la compatibilidad entre graficas y su imagen siendo diferentes seria mejor pero esto más que nada es una idea ya que como es conocido los libres son código mantenido por la comunidad y abierto y probablemente sean más adaptables a distintas versiones de hardware y módulos a kernel. Pero eso con el nomodeset creo que no tendras muchos problemas ya escojas uno o otro tipo de driver.

 

Hecho eso es tirar de instalar los nuevos drivers para esa grafica puedes escoger buscar en synaptic o otro programa similar en los repositorios y en esa busqueda puede que te salgan los proprietarios junto a los libres y escoges. Puedes tambien buscar en la pagina oficial para bajar los proprietarios y instalar solo tienes que ver para que version de kernel son y si el tuyo que estas usando esta en ese rango de versiones soportadas.

 

Un saludo campeón.

Editado por portaro

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0
hace 4 horas, chujalt dijo:

Saludos

 

Antes de instalar los drivers privativos de nvidia mira a ver si estań para 32 bits. Los últimos de la rama 304, los que yo necesito, sólo están para 64 bits.

 

Saludos

estoy con una arquitectura x86_64 ,lo mas seguro que instale la versión 384.130, esta en los repositorios de mint 18.03

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Con Nouveau no pude jugar ningún título de Steam y tampoco tuve buen rendimiento en juegos (en líneas generales). Te recomiendo el privativo (por ahora) 390 que se baja desde Nvidia o el 384 vía tus PPAs.

Tené en cuenta que el soporte OpenSource en AMD es muy superior, personalmente elegiría una RX 550 (superior que 1030) o 560 de 2GB. Andan genial :D

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Ya he pedido la 1030 https://www.pccomponentes.com/gigabyte-geforce-gt-1030-2gb-gddr5-lp

La tarjeta debía de cumplir dos requisitos si o si, perfil bajo y bajo consumo, máximo 30 w, porque si con ella el ordenador no se queda bien tendré que comprar uno y sera de segunda mano, he visto bastantes con 2 años de garantía core i 5 de 4º generación a unos 200 o 240€ , mi tope es ese y casi todos son de perfil bajo y con una fuente de 300 w, sobretodo los hp 8300 y los HP ELITEDESK 800 G1, por eso debe de ser tan especifica. la gráfica llega mañana, quitare los driver que lleva ahora y dejare los libres, instalo la gráfica y pongo los 384 de los repositorios.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

He actualizado al kernel 4.15, he dejado los driver libres pues los driver nvidia 384 no soportan mi gráfica, es una 9800 gt y los 384 soportan las gtx pero no las GT, he instalado la gráfica nueva, una vez arranca el Grub inicia el sistema pero se queda la pantalla en negro y de hay no pasa, no en modo recuperación avanza. Alguna idea? 

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Por unos días paramos el tema, mi monitor es de conexión vga y con la gráfica pedí también un adaptador hdmi a vga, y este no funciona nada bien. Tengo que buscar otro adaptador, pero buscaré en mi zona y buscaré lo dos que lleva la gráfica, uno dvi-d activo a vga y otro hdmi a vga.

Enviado desde mi SM-J320FN mediante Tapatalk

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Saludos

 

Si aun conservas kernels de la rama antigua arranca con ellos, con la nueva rama (4.15) los drivers de nvidia no funcionan. Eso me ha pasado a mi, conservaba uno de la 4.13 y funcionan bien.

 

Mira AQUI

 

Es el driver que yo necesito, en RELEASE HIGHLIGHTS pone "Improved compatibility with recent Linux kernels."

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Me he perdido algo ... veo que tenias problemas con el login grafico - desde el textual tendrias que logear y quebrar las X en los Ubuntu se tiene que hacer previo uso del comando lightdm service stop - solo despues de esto te para las X  desde ese punto haces un sudo mv xorg conf y lo reaces con sudo X -configure o dpkg-reconfigure xserver-xorg y lo metes en /etc  - sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup →

https://askubuntu.com/questions/159663/how-to-reset-the-xorg-xserver

https://askubuntu.com/questions/4662/where-is-the-x-org-config-file-how-do-i-configure-x-there

https://askubuntu.com/questions/4662/where-is-the-x-org-config-file-how-do-i-configure-x-there

Pero claro si el tema esta en que no te estan funcionando los drivers lo que haria era configurar hacia esa otra grafica excepto si haces un purge remove de los drivers anteriores y haces x configure despues de haber insertado la nueva grafica ... tendrias que pasar a los libre o sea purge remove nvidia .... y instalar los nouveau. Recordando que puedes bootear via modo seguro o con el parametro a kernel nomodeset que desactiva el modesetting para eso booteas y en el grub editas la linea de boot del grub referente al kernel poniendo nomodeset al final.

http://www.kernel.org/doc/Documentation/kernel-parameters.txt

https://help.ubuntu.com/community/BootOptions

https://sobrelinux.info/questions/1283/what-do-the-nomodeset-quiet-and-splash-kernel-parameters-mean

 

Si el problema persiste o sea los drivers nvidia disponibles en el repositorio o bien los bajados desde nvidia via su sitio web no te funcionan tendras que mirar la version de kernel especifica como bien dice  @chujalt que requieren esos drivers nuevos de esa nueva grafica.

 

Y una cosa más sobre el vga y el monitor, la grafica no trae en su caja un adaptador vga? Es que yo e compre una que traia de serie la salida hdmi pero en su caja venia el conector vga pero lo tube que colocar yo o sea traia el conector para enchufarlo en la grafica y unos tornillos para atornillar al punto de salida vga.

 

 

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Te comento lo que me pasa a mi. Tengo el Kernel 4.15 y los drivers 390.77. Al iniciar la PC me deja la pantalla en negro (creo que inicia GRUB), pero si la reinicio:

- Carga el menú de GRUB

- Cargo mi SO desde la primer opción

- Me arroja el error "PKCS#7 Signature not signed with a trusted key"

- Algunos "errores" (así lo interpreté) de Nvidia

- Entra en Modo de Emergencia:

--- Me dice "Control+D para continuar" (cosa que no se puede hacer)

--- Enter para ingresar como Root

 

Lo que pude hacer por ahora, es ir al Kernel 4.15 pero en modo de recuperación. Inicio la red desde las opciones de allí y arranca sin más el SO... ¿es un chiste? xD

Así que voy a probar desinstalando el driver de Nvidia y poniendo Nouveau, en mi caso no sé si solucionará el problema porque al escribir journalctl -xb como root (comando que arroja info sobre el porqué del "Emergency Mode") me arroja errores relacionadas a mi BIOS y el Secure Boot (yo lo tengo en UEFI+Legacy, como toda la vida).

En fin, ¡ahora pruebo de desinstalar el driver y digo que tal!

 

Mientras tanto, espero tu noticia de los conectores :D

@portaro las placas de video actuales (AMD RX 400 Series y Nvidia GTX 1000 Series en adelante) no tienen salidas analógicas como VGA o DVI-I, así que si o si el adaptador HDMI a VGA es el más barato y eficiente si el monitor es VGA :D

Más arriba insistí con comprar una AMD por el buen soporte de drivers Open Source, que son súmamente eficientes y estables... pero bueno, ya el OP había pedido la GT 1030 jajaja

¡Éxitos!

 

EDIT: En mi caso, instalar Nouveau no hizo diferencia. Voy a instalar los Mainline Kernels 4.18.14 Signed ya que estoy de paso jeje, dudo que resuelva algo pero ya que estamos, pruebo lo último :D

 

También probaré de actualizar la BIOS cuándo tenga tiempo (o volver a la versión anterior), para ir probando cositas. Eso si, me parece que esto empezó a suceder luego de actualizar Xubuntu 18.04 (empiezo a pensar que fue un error pasarse de Debian 9.5 jajaja) :P

 

No crearé un hilo nuevo porque creo que puedo solucionar esto. Nomás aporto más información al caso, por si sirve!!

Editado por The_Code

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Muy buenas, el adaptador hdmi a vga lo tengo desde hace unos dias "bueno una semana", de echo llevo ya unas horas al borderland 2 ¿cuantas señor shiba? :jajaja: he probado en modo live tres sistemas gnu linux en todos de error, mint 18.03, mint 19 y SolydXK en todos me da error  nouveau, en mint solo inicia en moda safe mode y en SolydXK  si arranca y lo mismo me deja instalar, pero lo ultimo que quiero es formatear el ordenador, con  nouveau.noaccel=1 ,  nomodeset y con vga=791 no va, mi sistema no arranca,y queda parado y no me deja hacer nada. 

Editado por pacoeloyo

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0
On 12/10/2018 at 18:43, chujalt dijo:

Saludos

 

Si aun conservas kernels de la rama antigua arranca con ellos, con la nueva rama (4.15) los drivers de nvidia no funcionan. Eso me ha pasado a mi, conservaba uno de la 4.13 y funcionan bien.

 

Mira AQUI

 

Es el driver que yo necesito, en RELEASE HIGHLIGHTS pone "Improved compatibility with recent Linux kernels."

si cambio de los 4.15 a el 4.10 de da el mismo error en nouveau 0000:01:00.0: DRM: failed to create kernel channel, -22

Editado por pacoeloyo

Compartir este post


Enlace al post
Compartir en otros sitios

Registra una cuenta o conéctate para comentar

Debes ser un miembro de la comunidad para dejar un comentario

Crear una cuenta

Regístrate en nuestra comunidad. ¡Es fácil!

Registrar una cuenta nueva

Iniciar Sesión

¿Ya tienes cuenta? Conéctate aquí.

Iniciar Sesión

×