Ir al contenido
Conéctate para seguir esto  
The_Code

[Tutorial] VSync efectivo en Xorg

Recommended Posts

Al menos a mi, al instalar una distribución basada en GNU/Linux con Xorg, siempre experimentaba "tearing"; es decir, ese fenómeno feo que produce un desfasaje en la imagen (como se muestra a continuación con el Dying Light).

 

08KeMux.jpg

Lo mas notable: El edificio alto "partido" en dos por culpa del Tearing

 

Spoiler

Aclaro que esta solución parece ser eficaz solo con AMD, según leí en los comentarios de Tearing Test @ 29.97 fps. Alguien podría confirmar si esta solución también funciona con Nvidia e Intel? En mi netbook tengo una Intel GMA3150 pero no tuve tearing nunca (con el mismo Xubuntu 16.04.3LTS que tengo en mi PC de escritorio, solo que en la net tengo versión de 32 Bits).

 

 

Lo peor es que este efecto sucede incluso con el Vsync activado en los juegos, y puede manifestarse, ademas, en videos de Youtube o películas. Entonces: como activar Vsync en el SO? Simple, abrir /etc/X11/xorg.conf y bajo la linea Section "Device" agregan:

Option "TearFree" "true"

En mi caso, el archivo xorg.conf quedo así:

Section "Device"
    Identifier "AMD"
    Driver "radeon"
        Option "DRI" "3"
        Option "TearFree" "true"
EndSection

Listo! Reinician Xorg (pueden cerrar sesión y volver a loguearse) y ya pueden ver los cambios. Este video de youtube lo deja claro... si no se corta, ya estamos!

 

Editado por The_Code

Compartir este post


Enlace al post
Compartir en otros sitios

Cómo andan? Ayer, luego de una pequeña adaptación en mi gabinete (ver foto debajo), metí una MSI 1070Ti Gaming X.

 

4RI1Nwu.jpg

 

Quiero avisar que si instalan esta placa con el último driver disponible (al menos en Ubuntu) "nvidia-384" no tendrán soporte para la 1070Ti, así que busqué en la web "Nvidia propietary drivers PPA" y agregué una PPA muy útil, porque tiene la versión 394 con soporte para esta placa de video (que es más reciente que las 1060 9Gbps / 1080 11Gbps incluso) :D

Luego de cambiar la placa, xorg.conf estaba vacío así que ejecuté la creación automática de la configuración, así:

 

nvidia-xconfig

 

Luego me fui hasta Section "Screen" y coloqué esta línea:

    Option "metamodes" "nvidia-auto-select +0+0 { ForceCompositionPipeline = On$

Reinicié Xorg (easy way: salir de la sesión y volver) y listo.

Para más info: http://www.thelinuxrain.com/articles/got-tearing-with-proprietary-nvidia-try-this

Compartir este post


Enlace al post
Compartir en otros sitios

Gracias por compartir esta información the vode,

Yo tengo una gtx960 nvidia  y, siempre me da algun problemilla con en tearing (de los c****jes).En antergos con gnome un amor pero, en KDE con opensuse no pude quitarlo.Haber si cuando tenga mas tiempo lo vuelvo a intentar 

Compartir este post


Enlace al post
Compartir en otros sitios

Registra una cuenta o conéctate para comentar

Debes ser un miembro de la comunidad para dejar un comentario

Crear una cuenta

Regístrate en nuestra comunidad. ¡Es fácil!

Registrar una cuenta nueva

Iniciar Sesión

¿Ya tienes cuenta? Conéctate aquí.

Iniciar Sesión
Conéctate para seguir esto  

×