Ir al contenido
  • 0
Conéctate para seguir esto  
portaro

Test al Shiba - firmware rtl8812au y kernel 3.13

Pregunta

Estoy intentando instalar un pen wireless en un pc con sistema ya muy antiguo es un 14.04 topado a tope con más software que ya no se como organizarlo pero tampoco quiero perder todas las configs que ya tengo asi que no me gustaria reinstalar sistema si pudiera ir dandole con la panza para el futuro.

 

Pero tengo un problema minusculo y es que hace unos 10 años me compre una Pen wireless SMC pero hace como 4 años se me partio y le hice un amaño -

SFUcenfOgyJk.jpg

 

pero ahora he comprado esta otra  pero me esta dando problemas para instalar en el kernel

[1996][joao:/home/joao]$ uname -r
3.13.0-49-generic

 

Me esta dando este problema →

 

[1996][joao:/home/joao]$ uname -r
3.13.0-49-generic
[1997][joao:/home/joao]$ cd /home/joao/penwireless/rtl8812AU
[1998][joao:/home/joao/penwireless/rtl8812AU]$ make
make ARCH=i386 CROSS_COMPILE= -C /lib/modules/3.13.0-49-generic/build M=/home/joao/penwireless/rtl8812AU  modules
make[1]: Entering directory `/usr/src/linux-headers-3.13.0-49-generic'
  CC [M]  /home/joao/penwireless/rtl8812AU/os_dep/linux/os_intfs.o
/home/joao/penwireless/rtl8812AU/os_dep/linux/os_intfs.c:809:2: error: initialization from incompatible pointer type [-Werror]
  .ndo_select_queue = rtw_select_queue,
  ^
/home/joao/penwireless/rtl8812AU/os_dep/linux/os_intfs.c:809:2: error: (near initialization for ‘rtw_netdev_ops.ndo_select_queue’) [-Werror]
cc1: all warnings being treated as errors
make[2]: *** [/home/joao/penwireless/rtl8812AU/os_dep/linux/os_intfs.o] Error 1
make[1]: *** [_module_/home/joao/penwireless/rtl8812AU] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.13.0-49-generic'
make: *** [modules] Error 2
[1999][joao:/home/joao/penwireless/rtl8812AU]$

 

El driver es este→

 

https://github.com/abperiasamy/rtl8812AU_8821AU_linux

 

No tengo ni idea que puede ser pero sera el tema kernel ya viejo, pero tengo un otro problema si uso otro kernel más nuevo pues los drivers de NVIDIA petan y no dan.

El sistema ya tendra unos 4 años asi que esta atiborrado de cosas las cuales ya no se cuales necesito y cuales no asi que me da muchas dudas si debo o no formatear y listo andando con otro.

 

(este mismo driver en mi pc nuevo si que funciona).

 

Queda el test al Shiba a ver si también me solventa este problema diciendo , p*** m*** ubuntu jajaj, pero siempre me ayuda que ni yo se como me solventa todos los problemas que tengo.

La pregunta no es urgente ya que apenasle doy uso a este pc pero a veces lo uso para imprimir cosas o escuchar mp3 , cosas pocas .

Editado por portaro

Compartir este post


Enlace al post
Compartir en otros sitios

6 respuestas a esta pregunta

Recommended Posts

  • 0

Jejej , si test a pacoeloyo es cosa de tiempo.

Pero eso del test es si no se que hacer y siempre es bueno tener más que un erudito en estas cosas.

 

 Saludos amigos y mil gracias por vuestras ayudas y vuestro buen humor .

Compartir este post


Enlace al post
Compartir en otros sitios

Registra una cuenta o conéctate para comentar

Debes ser un miembro de la comunidad para dejar un comentario

Crear una cuenta

Regístrate en nuestra comunidad. ¡Es fácil!

Registrar una cuenta nueva

Iniciar Sesión

¿Ya tienes cuenta? Conéctate aquí.

Iniciar Sesión
Conéctate para seguir esto  

×