Jump to content
  • 0

Me quedo sin espacio en /tmp estando el la misma partición que /


drn97
 Share

Question

Buenas,

acabo de instalar Antergos en mi nuevo equipo. He dedicado 2 particiones para Antergos: una para la raiz (/) y otra para swap.

Iba a instalar Android Studio desde AUR y me acaba soltando un error de que no hay espacio suficiente. Voy a intentar bajarlo desde la web de Android Studio y Firefox me lanza otro error de que no hay espacio.

Hago un df -h y sale esto:

I9H8uG4.png

 

¿Como es posible que si en / solo tengo ocupado el 8% /tmp esté al 100%? Es que hasta tuve que reiniciar para poder usar el navegador.

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

En distribuciones basadas en Arch, es muy común que exista un script de inicio tmp.mount, que si no me equivoco, por defecto monta los temporales en RAM.

 

De hecho, que esté especificado como tmpfs es un claro indicativo de ello.

En resumen, no te estás quedando sin espacio en la partición del disco, sino que estás ocupando toda la memoria RAM con temporales.

 

Tendrás que modificar o deshabilitar el script, especificar otro punto/modo de montaje en /etc/fstab, o limitar el espacio que destinas en RAM para temporales para asegurarte que no llega a ese extremo de nuevo

systemctl mask tmp.mount

 

https://wiki.archlinux.org/index.php/tmpfs#Disable_automatic_mount

Link to comment
Share on other sites

  • 0
hace 2 horas, Shiba87 dijo:

En distribuciones basadas en Arch, es muy común que exista un script de inicio tmp.mount, que si no me equivoco, por defecto monta los temporales en RAM.

 

De hecho, que esté especificado como tmpfs es un claro indicativo de ello.

En resumen, no te estás quedando sin espacio en la partición del disco, sino que estás ocupando toda la memoria RAM con temporales.

 

Tendrás que modificar o deshabilitar el script, especificar otro punto/modo de montaje en /etc/fstab, o limitar el espacio que destinas en RAM para temporales para asegurarte que no llega a ese extremo de nuevo


systemctl mask tmp.mount

 

https://wiki.archlinux.org/index.php/tmpfs#Disable_automatic_mount

¡Anda! Pues desconocía esa característica.

He deshabilitado el script ejecutando el comando y después he reiniciado y ya no tengo problemas.

Muchas gracias Shiba87.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...