Ir al contenido
  • 0
jmsanzd

El gestor de sesión de xfce apaga el sistema muy lento

Pregunta

SOLUCIONADO

 

Hola a todos.

 

Desde es lunes pasado, y sin tocar nada de la configuración, el botón de terminar sesión en Xfce me funciona muy lento: desde que le doy a apagar (o reiniciar, cerrar sesión..., lo que sea) hasta que empieza a trabajar le cuesta más de un minuto. Si apago desde la terminal, el apagado es instantáneo.

 

He intentado mirar los logs, pero no he detectado nada extraordinario (tampoco es que entienda mucho de ellos).

 

Tengo instalado debian testing de 64 bits, con xfce. Como gestor de sesión (por si tiene algo que ver) uso ligthdm.

 

Un saludo a todos.

 

O.T.: Desde que habéis retocado el foro en estos últimos días, su apariencia ha mejorado mucho. Muchas gracias a los administradores por su trabajo.

 

 

Editado por jmsanzd
SOLUCIONADO

Compartir este post


Enlace al post
Compartir en otros sitios

14 respuestas a esta pregunta

Recommended Posts

  • 0

A bote pronto lo relaciono con un bug de xfce4-session

 

No he encontrado ninguna pista del por qué, salvo un problena relacionado con los controladores gráficos, pero sólo en el caso de AMD y alguna Intel y, en teoría, cambiando a aceleración EXA debería evitar el bloqueo de Xfce al cerrar sesión

 

Basta añadir

Option "AccelMethod" "EXA"

En el archivo /etc/X11/xorg.conf, dentro de la sección Devices

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0
Hace 1 hora, jmsanzd dijo:

Hola a todos.

Desde es lunes pasado, y sin tocar nada de la configuración, el botón de terminar sesión en Xfce me funciona muy lento: desde que le doy a apagar (o reiniciar, cerrar sesión..., lo que sea) hasta que empieza a trabajar le cuesta más de un minuto. Si apago desde la terminal, el apagado es instantáneo.

 

He intentado mirar los logs, pero no he detectado nada extraordinario (tampoco es que entienda mucho de ellos).

 

Tengo instalado debian testing de 64 bits, con xfce. Como gestor de sesión (por si tiene algo que ver) uso ligthdm.

 

Un saludo a todos.

 

O.T.: Desde que habéis retocado el foro en estos últimos días, su apariencia ha mejorado mucho. Muchas gracias a los administradores por su trabajo.

 

 

 

También podrías poner los registros aquí a ver si alguien ve algo.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Gracias a los dos por vuestras respuestas.

 

Shiba, he intentado cambiar ese archivo que me comentas, y no existe. Lo que tengo en mi sitema es una carpeta (/etc/X11/xorg.conf.d), con un archivo dentro (20-intel.conf) que tiene las cosas que tú indicas. He modificado lo que tú me pides ahí, y no he conseguido ningún cambio. He terminado dejando las cosas como estaban al principio, por si acaso.

 

mijailbellum, por favor, dime qué logs son los que te gustaría que pusiera. Ya te digo que no controlo mucho ese tema, por lo que puedo mandar cualquier cosa.

 

Un saludo.

 

PD.- Edito: Acabo de recordar que esa carpeta y ese archivo los creé para eliminar el rasgado de pantalla... No sé si tendrá queé ver algo... En cualquier caso, eso lo hice hace más de dos semanas, y los problemas empezaron este lunes.

Editado por jmsanzd
añadir datos

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Hola, Shiba

 

He probado intoduciendo la orden que me indicas, y nada. El resultado es el mismo. Se cierra la sesión después de un minuto más o menos.

 

Por otra parte, he generado un archivo de configuarción de Xorg (ya que no lo tenía). Tampoco he notado ningún cambio.Si lo consideras necesario, te lo adjunto.

 

Por último, ahora, al abrir la sesión, se me abren varias aplicaciones sin yo pedirlo. Debían estar abiertas cuando cuando he insertado la orden de cierre. No sé cóm evitar que se me abran...

 

Gracias por tu interés. Un saludo.

Editado por jmsanzd
añadir datos.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Te ha guardado la última sesión seguramente.

 

Por terminar de probar, vamos a intentar forzarlo un poco más a ver si...

 xfce4-session-logout --fast

SI resulta, va a ser algún problema de configuración de Xfce. en ese caso se puede probar con una configuración limpia (quizá un usuarios de prueba) a ver si viene de ahí el problema

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Para saber exactamente que pasa cuando apagas el equipo puedes hacer lo que dice aquí.

 

Cita

If normal reboot or poweroff work, but take a suspiciously long time, then
boot with the debug options:


systemd.log_level=debug systemd.log_target=kmsg log_buf_len=1M printk.devkmsg=on enforcing=0

save the following script as /usr/lib/systemd/system-shutdown/debug.sh and make it executable:


#!/bin/sh
mount -o remount,rw /
dmesg > /shutdown-log.txt
mount -o remount,ro /

reboot

 

Look for timeouts logged in the resulting file shutdown-log.txt and/or attach it to a bugreport.
Shutdown Never Finishes.

 

 

Mi imagino que debe ser añadido a /etc/default/grub en la parte de GRUB_CMDLINE_LINUX_DEFAULT="quiet" dentro de las comillas, voy a probar y te comento.

 

Por cierto ¿No te sale ningún mensaje cuando se está apagando y se bloquea, que sale una cuenta hacia delante y tal?

 

Editado por mijailbellum

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Gracias, mijailbellum.

 

No, no me aparece nada en rojo.De hecho, puedo seguir trabajando con la pantalla de mi ordenador.. Cuando digo que el gestor va muy lento, es que durante algo más de un minuto después de pedir el cierre de sesión o el apagado, la pantalla principal sigue activa. Puedo abrir archivos desde el escritorio, navegar (si tengo abierto el firefox), etc. Lo que no me deja es abrir nuevas aplicaciones. Es decir, puedo trabajar con lo que estaba abierto, pero no puedo abrir nuevas aplicaciones. Al cabo de algo más de un minuto, el ordenador se cierra.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Estamos un paso antes del apagado, no hemos salido aún de XFCE cuando ocurre el problema.

Algunas soluciones "tontas" apuntan a desactivar la opción "preguntar antes de salir" en el menú de opciones de XFCE, dentro de Inicio y sesión (Traducido al vuelo, así que no aseguro que oficialmente esos sean los nombres que aparezcan :sweat: )

 

Probar con un usuario SIN configuraciones previas guardadas en su home también podría confirmarnos si las cosas van o no en ese sentido

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Hola, Shiba.

 

He creado un nuevo usuario, y, en él, el gestor de sesión funciona correctamente.

 

Quizás sería cuestión de copiar la configuración del diálogo de cierre de sesión y pegarlo en el de mi usuario habitual. La cuestión que no sé dónde se guarda esa configuración.

 

Gracias por todo. Un saludo.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

SOLUCIONADO

 

Se me ha ocurrido que a lo mejor, alguna aplicación del panel bloqueaba el gestor de sesión. Efectivament, era el Inicio Rápido de Libreoffice. Lo he eliminado, y todo funciona correctamente.

 

Ya de paso, he comprobado que en LibreOffice 5.4 no aparece esta opción. ¿alguien sabe algo al respecto?

 

Muchas gracias a todos por vuestro interés y ayuda. Un saludo.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

La verdad es que nunca he entendido el inicio rápido y la que nos ha liado en un momento por una tontería :sweat:

 

Y sí, en Libreoffice 5.4 ya no existe. Está en las notas de lanzamiento. Ya no habrá más "inicio rápido"

The Linux Quickstarter is deprecated and will be removed in the next release

https://wiki.documentfoundation.org/ReleaseNotes/5.4#General

 

Se propuso anteriormente como "misfeature" a eliminar, precisamente por no aportar nada y propiciar cuelgues extraños

https://wiki.documentfoundation.org/Proposals_for_removing_features#The_so-called_QuickStarter

Compartir este post


Enlace al post
Compartir en otros sitios

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invitado
Responder esta pregunta...

×   Has incluido contenido con formato.   Eliminar formato

  Sólo se permiten 75 emoticonos como máximo.

×   Tu enlace ha sido insertado automáticamente.   Deshacer y mostrar como enlace

×   Su contenido anterior ha sido restaurado.   Limpiar editor

×   No puedes pegar imágenes directamente. Súbelas a algún hosting de imágenes y pega la dirección URL


×
×
  • Crear Nuevo...