• 0
Conéctate para seguir esto  
Seguidores 0
EMILIO

Hue+ de NZXT

Pregunta

Hola foro, hace poco me regalaron el Hue+ de NZXT. Pues bien... no hay software del fabricante para linux, esta el CAM para linux... pero encontre un software libre para este llamado Hue_plus que es un programa basado en python y no oficial

 

https://github.com/kusti8/hue-plus

 

Pues bien,  el probema que tengo es que no doy con la tecla por varios motivos.

 

1.- requiere de la ultima version de python: python3 (que ya tengo instalado) solucion: sudo apt-get install python3

2.- tambien requiere para instalarlo el pip3, que segun he descubierto (gracias a Shiba) es como si dijeramos un complemento dentro de python3 (solucionado tambien) solucion: sudo apt-get install python3-pip

 

y por ultimo y no resuelto ahora me pide pyqt5, alguien me puede orientar como tener ese paquete que me falta ??

Rohlling le gusta esto

Compartir este post


Enlace al post
Compartir en otros sitios

6 respuestas a esta pregunta

  • 0

Vale... al parecer hay algo roto o no instalado, usando Xubuntu 14.04 a ver como consigo estos paquetes ahora... una pista !!

 

Downloading/unpacking pyserial (from hue-plus)
  Downloading pyserial-3.3-py2.py3-none-any.whl (189kB): 189kB downloaded
Downloading/unpacking pyqt5 (from hue-plus)
  Could not find any downloads that satisfy the requirement pyqt5 (from hue-plus)
Cleaning up...
No distributions at all found for pyqt5 (from hue-plus)
Storing debug log for failure in /tmp/tmp4j0b3dj6

 

a ver nuevo error !! requerimientos para pyqt5 no se si sera la distro o tendre que añadir otro repositorio.

 

 

Rohlling y pacoeloyo le gusta esto

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Con estos dos comandos:

$ wget https://bootstrap.pypa.io/get-pip.py
$ sudo python3 get-pip.py 

 

he conseguido instalar pyqt5 y ahora se me queda aqui: y dice que es problema de la version...

 

emilio@emilio-System-Product-Name:~$ sudo pip3 install hue_plus
[sudo] password for emilio:
The directory '/home/emilio/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
The directory '/home/emilio/.cache/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
Collecting hue_plus
  Downloading hue_plus-1.1.8.tar.gz
Collecting pyserial (from hue_plus)
  Downloading pyserial-3.3-py2.py3-none-any.whl (189kB)
    100% |████████████████████████████████| 194kB 2.0MB/s
Collecting pyqt5 (from hue_plus)
  Downloading PyQt5-5.8-5.8.0-cp34.cp35.cp36.cp37-abi3-manylinux1_x86_64.whl (96.1MB)
    100% |████████████████████████████████| 96.1MB 8.8kB/s
Requirement already satisfied: pyaudio in /usr/lib/python3/dist-packages (from hue_plus)
Collecting appdirs (from hue_plus)
  Downloading appdirs-1.4.3-py2.py3-none-any.whl
Collecting sip>=4.19.1 (from pyqt5->hue_plus)
  Could not find a version that satisfies the requirement sip>=4.19.1 (from pyqt5->hue_plus) (from versions: )
No matching distribution found for sip>=4.19.1 (from pyqt5->hue_plus)
emilio@emilio-System-Product-Name:~$


---------

 

Otro pasito mas... ahora a ver como se puede solucionar lo del sip 4.19.1...

 

Editado por EMILIO
Rohlling y pacoeloyo le gusta esto

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Eso tambien lo hize y me sale esto...

 

emilio@emilio-System-Product-Name:~$ sudo pip3 install sip
[sudo] password for emilio:
The directory '/home/emilio/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
The directory '/home/emilio/.cache/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
Collecting sip
  Could not find a version that satisfies the requirement sip (from versions: )
No matching distribution found for sip

 

Rohlling y pacoeloyo le gusta esto

Compartir este post


Enlace al post
Compartir en otros sitios

Registra una cuenta o conéctate para comentar

Debes ser un miembro de la comunidad para dejar un comentario

Crear una cuenta

Regístrate en nuestra comunidad. ¡Es fácil!


Registrar una cuenta nueva

Iniciar Sesión

¿Ya tienes cuenta? Conéctate aquí.


Iniciar Sesión
Conéctate para seguir esto  
Seguidores 0