Conéctate para seguir esto  
Seguidores 0
Shiba87

Utilizar plugins NPAPI en Firefox 52 o más reciente [Tip]

1 post en este tema

Mhl9aqe.png

 

Mozilla sigue trabajando a destajo en su navegador web y una de las novedades más destacadas que encontramos a partir de la versión 52 del Panda Rojo son relativas a mejorar la seguridad y entre ellas está la eliminación todos los plugins antiguos NPAPI (Netscape Plugin API), precisamente por lo inseguros que han demostrado ser y también porque muchos de ellos están a estas alturas descontinuados (Y el resto como si lo estuvieran). Hablamos del plugin de Java, Silverlight, Acrobat, Unity, etc. El único que aún sigue siendo posible activar es flash y siempre bajo el constante escrutinio de Mozilla, que nos lo desactivará automáticamente en el preciso instante que se detecte el más mínimo problema con él.

 

Sin embargo y por desgracia, aún existen muchos portales y servicios web que parece que no han entendido aún que estamos en 2017 y nos exigen la utilización de uno de estos plugins.

En mi caso lo he sufrido con Hangouts, porque hasta Google, tan comprometido con los estándares para unas cosas, no lo es tanto para otras y se deja fragmentos de código añejo por ahí perdido...

 

Evidentemente lo más sensato sería hacer caso a Mozilla porque la decisión no ha sido tomada a la ligera, estos plugins son una fuente de problemas constante, pero cuando no queda más remedio, podemos valernos de un pequeño "truco" para volver a activar los plugins. Este workaround se asienta precisamente en la compatibilidad que aún mantienen con Flash, ya que para poder utilizar este plugin NPAPI, hace falta que el navegador aún siga siendo en cierto grado compatible, aunque luego se hayan impuesto limitaciones para que no se ejecuten.

 

Para saltarnos la limitación, nos vamos a la configuración avanzada del navegador abriendo about:config

 

Debemos crear una nueva entrada lógica Sí/No (boolean)

plugin.load_flash_only

Y la pondremos como false

 

O4Vl4DZ.jpg?1

 

Esto permitirá que podamos utilizar otros plugins inseguros y descontinuados además de flash. Eso sí vuelvo a insistir en que siempre con cabeza y como medida de último recurso :sweat:

 

Otro apunte importante es que se trata de una medida temporal, no sólo porque es un sinsentido seguir manteniendo este tipo de plugins en nuestro navegador de forma continuada, sino porque Mozilla ya ha anunciado que flash no durará mucho más y antes de la próxima versión con soporte extendido (ESR), es decir Firefox 59, el tan odiado plugin de Adobe habrá desaparecido y con él todo rastro del soporte NPAPI.

Eduardo, Mgbu, GWToni y 4 otros le gusta esto

Compartir este post


Enlace al post
Compartir en otros sitios

Registra una cuenta o conéctate para comentar

Debes ser un miembro de la comunidad para dejar un comentario

Crear una cuenta

Regístrate en nuestra comunidad. ¡Es fácil!


Registrar una cuenta nueva

Iniciar Sesión

¿Ya tienes cuenta? Conéctate aquí.


Iniciar Sesión
Conéctate para seguir esto  
Seguidores 0