Jump to content
  • 0

Problema con sonido en rasberry pi 2


MartinL
 Share
Followers 0

Question

 

 

Hola y buenas,

 

 

 

 

 

Soy nuevo en este apasionante mundo y estoy empezando, si he he equivocado de subforo pido disculpas por adelantado.

 

 

 

 

 

Me ha surguido un problema que no se muy bien por donde atacar. Tiene que ser un tema de configuracion pero no doy con ello.

 

 

 

 

 

he montado en una tarjeta el sistema noods que me venia con la raspberry y he procedido a instalar Raspbian y openElecpi2. 

 

 

 

 

 

en raspbian me toge todo ok pero no suena (conexion HDMI), incluso me dice que la tarjeta de sonido es "bcm2835 Alsa".

 

 

 

 

 

no se oye nada. descargar tonos de llamada gratis para teléfono: Descargartonos.info

 

 

 

 

 

sin embargo si arranco por openelec tanto el menu suena como las peliculas que pongo por lo que la conexion esta bien, no hay ni problema en la tele ni en el cable ni en la raspberry.

 

 

 

 

 

Esto me dice que algo no configuro bien, aunque la verdad es todo muy automatico, no he tenido que hacer casi nada.

 

 

 

 

 

Asi mismo tambien he instalado en otra sd retropie 3.4 siguiendo tutoriales de youtube y ya tengo es sistema funcionando, incluso con un mando usb funcionando pero con el mismo problema, no se oye y aqui he probado con las diferentes configuraciones de sonido. 

 

 

Algo se meescapa y no se por donde seguir.

 

 

 

 

 

Alguna idea????

 

Edited by MartinL
Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

La raspberrypi tiene una programa de configuración, escribe en un emulador de terminal sudo raspi-config y verás el programa.

 

Una vez ahí debes seleccionar advanced options/audio y ahí selecciona por donde debe salir el audio, por defecto esta en auto, puedes elegir entre HDMI y Jack, aunque en el modo auto debería salir el sonido bien por HDMI si está conectado, por probar no pasa nada.

 

Si sigues sin tener audio debes configurar el archivo /boot/config.txt desde el terminal sudo nano /boot/config.txt y especificar hdmi_drive=2 el número 2 especifica salida HDMI, si pones un 1 es por jack y un 0 es el modo automático.

 

- Siempre que escribas sudo en el emulador de terminal antes de una orden especificas hacerlo como "administrador" por ello te pedirá la contraseña del mismo para hacer cualquier cosa.

 

- Para guardar el archivo de texto con nano (GNU Nano) pulsa Ctrl+O te pide confirmar el nombre de archivo, pulsas Intro y para salir pulsa Ctrl+X.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share
×
×
  • Create New...