• 0
Conéctate para seguir esto  
Seguidores 0
portaro

Ayuda GNU/Linux
Activar el render GPU con nvidia gt 710 con cuda en blender?

Pregunta

:)  Pregunta tonta alguien sabe como se hace para que Blender de una vez por todas recoconozca la GPU Nvidia y haga el render por ella ? , ya he leido media web he instalado cudas de distintas versiones que son GB que se baja, no hay manera no se que hacer más.

 

 

joao@A-F-K31DA-K31DAG-K20DA:~$ glxinfo | grep OpenGL
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: Graphics Device/PCIe/SSE2
OpenGL core profile version string: 4.3.0 NVIDIA 340.101
OpenGL core profile shading language version string: 4.30 NVIDIA via Cg compiler
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.4.0 NVIDIA 340.101
OpenGL shading language version string: 4.40 NVIDIA via Cg compiler
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:
joao@A-F-K31DA-K31DAG-K20DA:~$

Editado por portaro
Rohlling le gusta esto

Compartir este post


Enlace al post
Compartir en otros sitios

12 respuestas a esta pregunta

  • 0

Creo que lo he solucionado y era problema de las versiones de drivers ya que en mi caso me reconoce la grafica con el paquete gráfico nvidia-346.

 

goSKqmYrB77o.png

pacoeloyo y Rohlling le gusta esto

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

No tiene gran misterio. Vas a user preferences, en la pestaña system y en la parte de compute device, marcas CUDA

 

LDOrhU2.jpg

 

Si los controladores gráficos son recientes, que parece que así es, no hay que hacer nada más. No necesitas instalar el SDK de CUDA ni nada por el estilo, es totalmente Plug&Play

Rohlling, pacoeloyo y portaro le gusta esto

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Pero no me sale eso ya he intentado de todo ahora mismo acabo de cargarme las configuraciones de los drivers nvidia con otro experimento más.

 

La cosa es que a mi en esa imagen que tu pones simplemente me sale el cpu nada más no tengo opcion ninguna más, ya le ponga el cuda que le ponga me sale eso solo, creo que la cosa sera ver si por un acaso instalado varias opciones de nvidia-xxx me da aluna ayuda, ya intente el nvidia 340 , nvidia 331 y nada ahora probare el nvidia-343 via xorg-edgers ppa a ver si hace algo.

Rohlling y pacoeloyo le gusta esto

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Pues he rebooteado y los 343 no dan nada →

joao@A-F-K31DA-K31DAG-K20DA:~$ glxinfo | grep OpenGL
Error: couldn't find RGB GLX visual or fbconfig
Error: couldn't find RGB GLX visual or fbconfig
joao@A-F-K31DA-K31DAG-K20DA:~$

 

oy a volver a los 340 que me da que son los mejores.
 

Rohlling y pacoeloyo le gusta esto

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Vamos a asegurarnos

Ya que lo que no queremos es volvernos locos, hazlo de manera limpia, sin añadidos ni archivos bajados de vete a saber dónde:

aptitude install nvidia-cuda-toolkit
Y compruébalo

nvcc -V
La versión de los controladores no es tan reciente como debería, pero tampoco tan antigua como no funcionar, así que no es tan importante. Si el controlador funciona y las librerías CUDA están en su sitio, es todo lo que necesitas.
Rohlling y portaro le gusta esto

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Ya lo habia instalado y no dio nada ahora lo volvi a probar y tampoco no me da la opcion , te hare un video y lo pondre aqui para que veas sobre el comando aqui pongo la salida →

 

 

 

 

 

 

joao@A-F-K31DA-K31DAG-K20DA:~$ nvcc -V
nvcc: NVIDIA ® Cuda compiler driver
Copyright © 2005-2013 NVIDIA Corporation
Built on Wed_Jul_17_18:36:13_PDT_2013
Cuda compilation tools, release 5.5, V5.5.0
joao@A-F-K31DA-K31DAG-K20DA:~$
 

Editado por portaro
Rohlling le gusta esto

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Voy a intentar esto → https://blenderartists.org/forum/showthread.php?348478-GTX-860M-no-GPU-render-option-GPU-not-detected , ya que el paquete cuda toolkit 6.5 no me aparece por ningun lado.

 

Ya por divagar un poco recuerdo la R3 va con 256 MB la nvidia con 2GB ahora mirad la siguiente foto →

 

dVDE9g082ZuW.png

 

uZkmQLSe8KEi.png

 

Mola no la primera foto es de la nvidia con el juego ese la segunda de la r3 y va la r3 y sale mejor si lo cuentas no te creen, y si os fijais bien la tierra con la nvidia sale azul ademas la grafica detectada en la foto de nvidia me sale la nvidia 8800 , vaya lio se hace esto.

Editado por portaro
Rohlling y pacoeloyo le gusta esto

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Wine no es un buen referente PARA ABSOLUTAMENTE NADA, así que no tiene ningún valor.

 

Y no estés dando palos de ciego y céntrate en lo que estás :sweat:. No te va a servir instalar una versión desfasada y sin soporte del SDK de CUDA, especialmente si luego los controladores gráficos no van "a juego".

Si quieres hacerlo manualmente, vete a la página oficial de Nvidia y descárgate, tanto la última versión del controlador gráfico disponible para tu tarjeta, como la última versión del SDK de CUDA

 

Otra cuestión importante sería también contar con una versión reciente de Blender y para las 3 cosas, la distribución representa un lastre importante, así que... te tocará hacerlo todo a mano :icon_ouch:

Rohlling, portaro y pacoeloyo le gusta esto

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Hombre el cuda 8.0  ya lo instale yo el repo y el instalador .deb de esa misma página lo baje , sobre blender tengo la version 2.78b pase de la 2.69.

 

La tarjeta especificamente era para esto de blender pero ya no se que hacer más instale el cuda 6.5 y tampoco funciona (alguien decia por aqui →https://blenderartists.org/forum/showthread.php?348478-GTX-860M-no-GPU-render-option-GPU-not-detected que era la version que funciona y por probar que no quede )  asi que ya se me terminaron los cartuchos.

Rohlling y pacoeloyo le gusta esto

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

La versión que funcionaba en una respuesta de 2014 era la última que existía en ese momento :sweat:

 

Hay una tercera opción. No es tan buena, pero si funciona, algo es algo:

 

aptitude install nvidia-opencl-dev

 

Y ejecuta blender en modo OpenCL

 

CYCLES_OPENCL_SPLIT_KERNEL_TEST=1 blender
pacoeloyo, Rohlling y portaro le gusta esto

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Pues asi andamos, a mi pensar imagine que podria ser que el driver que tengo hiciera esa funcion con esa version de cuda especifica asi que lo intente.

Pero no , nada de lo que ya he intentado me da solucion no se que le pasa.

 

En foros Ubuntu tampoco me dan mucha info asi que tocara buscar más.

Rohlling y pacoeloyo le gusta esto

Compartir este post


Enlace al post
Compartir en otros sitios

Registra una cuenta o conéctate para comentar

Debes ser un miembro de la comunidad para dejar un comentario

Crear una cuenta

Regístrate en nuestra comunidad. ¡Es fácil!


Registrar una cuenta nueva

Iniciar Sesión

¿Ya tienes cuenta? Conéctate aquí.


Iniciar Sesión
Conéctate para seguir esto  
Seguidores 0