Ir al contenido
Conéctate para seguir esto  
alguien

Acabo de contratar por un mes un servidor dedicado de Soyoustart

Recommended Posts

So you Start es como una marca blanca de OVH que oferta servidores dedicados económicos: https://www.soyoustart.com/es/servidores-essential/

 

Espero sacarle partido durante este mes, y preveo que voy a dar un poco la lata con preguntas tontas. :confused:

 

En estos momentos se está instalando el sistema operativo, de entre la gama de imágenes que ofrece la empresa, he elegido Proxmox VE 4.4, una distro para virtualización basada en Debian 8: https://www.proxmox.com/en/

 

Mi idea es probar a crear maquinas virtuales con direcciones IP fail-over de OVH, y experimentar en ellas distintas distros gnu/linux. Ya tengo montado un servidor Proxmox local, mas o menos se manejarme con este sistema de virtualización. El poder tenerlo online en un dedicada de gama media, es un lujo que me voy a permitir sólo durante este mes.

Compartir este post


Enlace al post
Compartir en otros sitios

Si en las particiones de windows ya le tenia cogido el tranquillo, con los volumenes lógicos de linux LVM, me hago mucho lio. Dentro de las distintas configuarciones de hadware que tiene soyoustar, me he ido a una de las mas económicas con tres discos SSD de algo menos de 200 GB cada uno. PROXMOX usa una particion LVM para alojar las maquinas virtuales en /var/lib/vz

Para añadir el segundo disco duro al volumen logico LVM data, he seguido este tip

 

-Primero he creado con fdisk una partición primaria tipo LVM en el segundo disco con fdisk, y a continuación estos pasos:

 

  1. extender el volumen lógico con:         lvextend /dev/mapper/pve-data /dev/sdb1
  2. comprobar con:            fsck -nv /dev/mapper/pve-data
  3. cambiar el tamaño con:            resize2fs -F /dev/mapper/pve-data

Lo que no entiendo es que en ningun momento me pide que formatee /dev/sdb1 pero funciona, se ha sumado al vomen logico montado en el  el primer disco, todo el espacio disponible del segundo SSD, pero no entiendo como ha hecho eso 'resize2fs -F' sin especificar el tamaño ni nada. Sobre la bandera -F no encuentro una explicación que satisfaga mi curiosidad. Supongo que al no especificar un numero de megas, ha usado todo el espacio disponible y lo ha formateado en ext3 que es el formato que tiene el volumen logico montado en /var/lib/vz

Editado por pprico

Compartir este post


Enlace al post
Compartir en otros sitios

Hola Rohlling, los discos los entregan en blanco sin tabla de particiones ni formato. A la hora de instalar el sistema operativo puedes elegir instalarlo solo en el primer dico o usar todos los discos en RAID, yo he escogido la primera ocpción, y el SSD 2 y el 3 estaban sin formato.

 

Entonces que puede ocurrir al no haberlo formateado, tendré que desvincularlo del volumen lógico y volver a repetir los pasos?

# lsblk -fm

NAME         FSTYPE      MOUNTPOINT  NAME           SIZE

sda                                  sda          149,1G
├─sda1       ext3        /           ├─sda1          40G
├─sda2       swap        [SWAP]      ├─sda2        1023M
├─sda3                               ├─sda3           1K
└─sda5       LVM2_member             └─sda5         108G
  └─pve-data ext3        /var/lib/vz   └─pve-data 253,1G
sdb                                  sdb          149,1G
└─sdb1       LVM2_member             └─sdb1       149,1G
  └─pve-data ext3        /var/lib/vz   └─pve-data 253,1G



como ves la partición sdb1 montada en /var/lib/vz, dice que tiene un sistema de archivos ext3, y te puedo asegurar que no he dado ninguna orden de formateo

¿cómo puedo verificar si ese espacio esta formateado y disponible?

Editado por pprico

Compartir este post


Enlace al post
Compartir en otros sitios

Has probado con lvdisplay? que info te sale ?

Edito: he repasado mis apuntes, y puede no estár formateado el volúmen. Pero el comando que te he dicho antes, creo que debería de mostrarte la info.  Si no fuese así, tendrías que formatear el volumen con el siguiente código:

mkfs.ext4 /dev/volumencreado 

quien dice ext4, puede ser el sistema que quieras...

Editado por Rohlling

Compartir este post


Enlace al post
Compartir en otros sitios

Ya no va a ser necesario, te lo agradezco igualmente, porque esta mañana a primera hora he reinstalado Proxmox, la segunda unidad la he limpiado y vuelto a crear una tabla de particiones normal, y la he añadido montada en una carpeta. Con los Volumenes esos no me entiendo.

 

Anoche di con este tutorial: LVM para torpes

http://blog.inittab.org/administracion-sistemas/lvm-para-torpes-i/

 

Es lo que necesitaba, jajaja, lo ire leyendo a ratos

Compartir este post


Enlace al post
Compartir en otros sitios

Saludos compis, refloto este tema para no duplicar temas sobre la misma cuestión.

Hace solo tres días he vuelto a contratar por un mes otro servidor dedicado de la marca blanca de OHV, me llamó la atención una gama de dedicados que no conocía, "Servidores de almacenamiento", los llaman. Para testar y trastear, uno de mis pasatiempos favoritos, he contratado el más económico, (12 € + IVA), que tiene 2 GB de RAM, y un procesador ARM  Cortex A9 ARMv7

 

Es la primera vez que tengo noticias de esta arquitectura ARM, así por encima parece que es otro tipo de microprocesador distinto a los intel y AMD x32 o x64, tiene otra forma de manejar las instrucciones y son los que normalmente se usan en los dispositivos móviles.

 

OVH en los servidores Intel y AMD x64, pone a disposición un gran numero de imágenes linux para instalar en los servidores, en estos ARM solamente tiene tres:

  1. Debian 8 Armhf Jessie (32bits)
  2. OpenMediaVault
  3. Ubuntu Server Armhf 16.04 "Xenial Xerus" (32bits)

El 2 no se que es, he probado Debian y Ubuntu, y parece que Ubuntu es el que menos problemas me está dando.

El tema de los repositorios es que a esta arquitectura Armhf no le valen los de las distribuciones normales, en Ubuntu por ejemplo son estos:

 

deb http://ports.ubuntu.com/ubuntu-ports xenial main universe
deb http://last.public.ovh.hdaas.snap.mirrors.ovh.net/ubuntu/ xenial main

 

Cualquier otro repositorio de los que normalmente se usan, los rechaza

 

Llevo encontradas ya varias dificultades y mensajes de error y warnings varios que no me suelo encontrar con la arquitectura amd64

Ahora mismo estoy tratando de instalar fail2ban, y no me deja, quizás sea tema de repositorios, no tengo ni idea, no encuentro nada en google que me resuelva el problema

 

La salida que da al ejecutar en root "aptitude install fail2ban" es esta:

 

dpkg: error processing package fail2ban (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up python3-pyinotify (0.9.6-0fakesync1) ...
Setting up python3-systemd (231-2build1) ...
Setting up whois (5.2.11) ...
Processing triggers for systemd (229-4ubuntu4) ...
Errors were encountered while processing:
 fail2ban
E: Sub-process /usr/bin/dpkg returned an error code (1)
Failed to perform requested operation on package.  Trying to recover:
Setting up fail2ban (0.9.3-1) ...
Job for fail2ban.service failed because the control process exited with error code. See "systemctl status fail2ban.service" and "journalctl -xe" for details.
invoke-rc.d: initscript fail2ban, action "start" failed.
dpkg: error processing package fail2ban (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 fail2ban

 

He pegado solo las ultimas líneas, donde aparece el error "subprocess installed post-installation script returned error exit status 1"

 

Seguiré buscando en Google a ver que encuentro, si alguien mas inteligente que yo (la mayoría :triste:) tiene alguna idea, será bien recibida :sombrero:

 

[Perdón por el tocho]

Compartir este post


Enlace al post
Compartir en otros sitios

Por mas que googleo no doy con la solución al arranque en el inicio de fail2ban,

¿sabe alguien una alternativa a fail2ban?

 

Edito: me ahorraría también mucho tiempo si alguien pudiera decirme como hacer un test de rendimiento general del servidor. Tanto por línea de comando por escritorio, he instalado un escritorio sin extras de xfce4 al que me conecto con x2go server. Me gustaría hacer un test por consola y otro para ver cuantos recursos me consume el escritorio.

Editado por pprico

Compartir este post


Enlace al post
Compartir en otros sitios

¿Puede ser sshguard  una buena alternativa a fail2ban?

Lo he instalado y de momento no me da mensajes de error como fail2ban.

 

EDITO: aparentemente no se muestra ningun warning ni mensaje de error, pero es ejecutar el comando

service sshguard status

 Y aparece esto:

service sshguard status
● sshguard.service - SSHGuard
   Loaded: loaded (/lib/systemd/system/sshguard.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Thu 2017-06-01 16:48:10 CEST; 8s ago
  Process: 6554 ExecStopPost=/usr/lib/sshguard/firewall disable (code=exited, status=0/SUCCESS)
  Process: 6550 ExecStart=/usr/sbin/sshguard -i /run/sshguard.pid -w $WHITELIST $LOGFILES $ARGS (code=exited, status=1/FAILURE)
  Process: 6544 ExecStartPre=/usr/lib/sshguard/firewall enable (code=exited, status=0/SUCCESS)
 Main PID: 6550 (code=exited, status=1/FAILURE)

Jun 01 16:48:09 ns3745266.ip-213-32-1.eu systemd[1]: Starting SSHGuard...
Jun 01 16:48:09 ns3745266.ip-213-32-1.eu systemd[1]: Started SSHGuard.
Jun 01 16:48:09 ns3745266.ip-213-32-1.eu sshguard[6550]: Unable to poll from '/var/log/auth.log'!
Jun 01 16:48:09 ns3745266.ip-213-32-1.eu systemd[1]: sshguard.service: Main process exited, code=exited, status=1/FAILURE
Jun 01 16:48:10 ns3745266.ip-213-32-1.eu systemd[1]: sshguard.service: Unit entered failed state.
Jun 01 16:48:10 ns3745266.ip-213-32-1.eu systemd[1]: sshguard.service: Failed with result 'exit-code'.

 

Active: failed (Result: exit-code) since Thu 2017-06-01 16:48:10 CEST; 8s ago
  Process: 6550 ExecStart=/usr/sbin/sshguard -i /run/sshguard.pid -w $WHITELIST $LOGFILES $ARGS (code=exited, status=1/FAILURE)

 

Como para dejar un servidor sin protección contra ataques de fuerza bruta, los intentos de logueo como root fallidos son continuos.

Sobre todo si dejas el puerto SSH por defecto, el 22

Editado por pprico

Compartir este post


Enlace al post
Compartir en otros sitios

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invitado
Responder en este tema...

×   Has incluido contenido con formato.   Eliminar formato

  Sólo se permiten 75 emoticonos como máximo.

×   Tu enlace ha sido insertado automáticamente.   Deshacer y mostrar como enlace

×   Su contenido anterior ha sido restaurado.   Limpiar editor

×   No puedes pegar imágenes directamente. Súbelas a algún hosting de imágenes y pega la dirección URL

Conéctate para seguir esto  

×
×
  • Crear Nuevo...