• 0
jmsanzd

Ayuda GNU/Linux
Bluetooth no funciona en Debian Testing

Pregunta

Hola a todos.

 

Sigo a vueltas con el bluetooth. No consigo ni enviar ni recibir conteido con mi ordenador. Utilizo debian stretch (testing) con xfce. He probado un montón de cosas, pero nada. Tengo instalados los paquetes básicos (bluez, bluetooth, blueman) y sus dependencias.

 

Quizás lo más importante sea lo que aparece cuando tecleo /etc/init.d/bluetooth status. Aparece como dispositivo conectado y funcionando, pero más adelante aparecen unas líneas en rojo:

 

jmsanzd2@debian:~$ /etc/init.d/bluetooth status
● bluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
   Active: active (running) since Tue 2017-01-03 16:58:43 CET; 15min ago
     Docs: man:bluetoothd(8)
 Main PID: 19179 (bluetoothd)
   Status: "Running"
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/bluetooth.service
           └─19179 /usr/lib/bluetooth/bluetoothd

ene 03 16:58:43 debian systemd[1]: Starting Bluetooth service...
ene 03 16:58:43 debian bluetoothd[19179]: Bluetooth daemon 5.43
ene 03 16:58:43 debian systemd[1]: Started Bluetooth service.
ene 03 16:58:43 debian bluetoothd[19179]: Starting SDP server
ene 03 16:58:43 debian bluetoothd[19179]: Bluetooth management interface 1.1…zed
ene 03 16:58:52 debian bluetoothd[19179]: Failed to obtain handles for "Service Changed" characteristic
ene 03 16:58:52 debian bluetoothd[19179]: Sap driver initialization failed.
ene 03 16:58:52 debian bluetoothd[19179]: sap-server: Operation not permitted (1)
ene 03 16:58:52 debian bluetoothd[19179]: Endpoint registered: sender=:1.39 …rce
ene 03 16:58:52 debian bluetoothd[19179]: Endpoint registered: sender=:1.39 …ink
Hint: Some lines were ellipsized, use -l to show in full.
 

El resto de mensajes habituales no dice nada: NI dmesg | grep -i bluetooth, ni hcitool dev, ni otros comandos dan ningún problema.

 

Sé que es una tontería, pero me suele gustar que todo el sistema vaya bien :) . Quizás para mi lo más complicado para que todo funcione en mi equipo sea precisamente el bluetooth. En meses anteriores trabajaba bien, pero ha debido llegar alguna actualización y se fastidió todo.

 

Muchas gracias a todos, y feliz año.


 

 

Rohlling, pacoeloyo y portaro le gusta esto

Compartir este post


Enlace al post
Compartir en otros sitios

9 respuestas a esta pregunta

  • 0

¿Qué modelo es?

 

lsusb

¿rfkill arroja alguna luz?

 

rfkill list

 

Si fuera el caso de querer matar moscas a cañonazos...

 

/usr/lib/bluetooth/bluetoothd --noplugin=sap
Pero vamos, que estaríamos centrándonos en uno de los síntomas, no en el problema :sweat:
portaro, Rohlling, jmsanzd y 1 otro le gusta esto

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Hola, Shiba.

 

Gracias por responder. Te indico los comandos que me pides:

 

jmsanzd2@debian:~$ lsusb
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 005: ID 064e:812e Suyin Corp.
Bus 001 Device 004: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 007: ID 0cf3:e004 Atheros Communications, Inc.
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 046d:c52f Logitech, Inc. Unifying Receiver
Bus 003 Device 002: ID 1a40:0101 Terminus Technology Inc. Hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

 

root@debian:/home/jmsanzd2# rfkill list
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
3: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
 

Poniendo el 3º comando aparece:

 

root@debian:/home/jmsanzd2# /usr/lib/bluetooth/bluetoothd --noplugin=sap
D-Bus setup failed: Name already in use

 

Me da la impresión de que este último comando no ha funcionado...

 

Un saludo.
 

 

 

pacoeloyo, portaro y Rohlling le gusta esto

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Si no me equivoco, el Bluetoothes un Atheros AR3012.

No creo que sea la causa y quizá ya los tengas, pero como en Debian el firmware no-libre se empaqueta por separado, lo primero es lo primero:

 

aptitude install firmware-atheros
 

De resto, según rfkill no está bloqueado de ninguna manera y el servicio/demonio bluetoothd está en uso aunque no nos deje hacer cambios al vuelo.

Si no es cosa del firmware, que a priori no lo parece, otra opción es editar directamente el archivo /etc/systemd/system/bluetooth.target.wants/bluetooth.service, modificando la línea ExecStart para añadir al final la opción --noplugin=sap

O, si no me equivoco y esperemos que no se me vaya el dedo en ningún sitio:

 

sed -i 's_ExecStart=/usr/lib/bluetooth/bluetoothd_ExecStart=/usr/lib/bluetooth/bluetoothd --noplugin=sap_g' /etc/systemd/system/bluetooth.target.wants/bluetooth.service

Reiniciar el servicio, reiniciar directamente y nos desharíamos del problema con SAP (Si es que ése es el problema)

jmsanzd, pacoeloyo y Rohlling le gusta esto

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Hols, Shiba.

 

He modificado la línea que me indicas, el bluetooth sigue sin funcionar.

 

Introduciendo el mismo comando de arriba, la salida es la siguiente:

 

jmsanzd2@debian:~$ /etc/init.d/bluetooth status
● bluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
   Active: active (running) since Wed 2017-01-04 09:56:39 CET; 8min ago
     Docs: man:bluetoothd(8)
 Main PID: 557 (bluetoothd)
   Status: "Running"
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/bluetooth.service
           └─557 /usr/lib/bluetooth/bluetoothd

ene 04 09:56:39 debian bluetoothd[557]: Starting SDP server
ene 04 09:56:39 debian bluetoothd[557]: Bluetooth management interface 1.13 initialized
ene 04 09:56:39 debian bluetoothd[557]: Failed to obtain handles for "Service Changed" characteristic
ene 04 09:56:39 debian bluetoothd[557]: Sap driver initialization failed.
ene 04 09:56:39 debian bluetoothd[557]: sap-server: Operation not permitted (1)
ene 04 09:56:46 debian bluetoothd[557]: Endpoint registered: sender=:1.39 path=/MediaEndpoint/A2DPSource
ene 04 09:56:46 debian bluetoothd[557]: Endpoint registered: sender=:1.39 path=/MediaEndpoint/A2DPSink
ene 04 09:58:59 debian bluetoothd[557]: connect error: Connection refused (111)
ene 04 09:58:59 debian bluetoothd[557]: a2dp-source profile connect failed for 68:14:01:70:E6:D8: Device or resource busy
ene 04 09:59:01 debian bluetoothd[557]: connect error: Connection refused (111)

 

Sí, tengo el firmware instalado. Ya comenté que me fucionó en otros momentos, pero ahora no lo hace :(

 

Gracias por todo.


 

pacoeloyo y Rohlling le gusta esto

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Hola, creo que encontré la solución:

 

 

Nota: Lee con atención el hilo antes de instalar o hacer nada.

 

https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1542743

 

Saludos

pacoeloyo, jmsanzd y Rohlling le gusta esto

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Hola.

 

Gracias, hectorsales. He instalado el paquete que me recomiendas (te he hecho caso, me miré el enlace primero), pero tampoco me funciona. Entre lo de shiba y tu solución había consieguido que mi orden /etc/init.d/bluetooth status no diera errores.

 

Además, trasteando con el sistema, creo que me he cargado el archivo /etc/systemd/system/bluetooth.target.wants/bluetooth.service (o sea, el que me dijo shiba que editara :muro:). Por favor, ¿alguien me puede pasar el contenido de ese archivo correcto? Me es igual que sea el original o uno corregido... para sustituir el mío.

 

Gracias a todos. Un saludo.

Rohlling le gusta esto

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Yo con el bluetooth ya me rendí. Una cosa interesante es que cuando inicio en Mint, y luego reinicio a Debian sí me funciona. Pero si prendo directamente en Debian no

 

Link al tema, fijate los ultimos mensajes que tienen bastante info

 

http://gnulinuxvagos.es/topic/5355-hacer-funcionar-bluetooth-ath3k/

Rohlling y Shiba87 le gusta esto

Compartir este post


Enlace al post
Compartir en otros sitios

Registra una cuenta o conéctate para comentar

Debes ser un miembro de la comunidad para dejar un comentario

Crear una cuenta

Regístrate en nuestra comunidad. ¡Es fácil!


Registrar una cuenta nueva

Iniciar Sesión

¿Ya tienes cuenta? Conéctate aquí.


Iniciar Sesión