Jump to content

(Solucionado) "apt-get autoremove" !Borró todo¡


JPablos
 Share
Followers 0

Recommended Posts

Buenas tardes, dicen que "Echando a perder se aprende", pues bien hoy he aprendido cómo recuperar mi sistema (Ubuntu 16.04) luego de echarlo a pique por "trastear" con el entorno gráfico.

 

Reinicié mi equipo, con la sorpresa de no tener entorno gráfico, esta es la secuencia:

 

  1. Nuevo reinicio, busco "Opciones avanzadas para Ubuntu"
  2. Selecciono "... Linux 4.4.0-36-generic (recovery mode)"
  3. Paso a "consola root", trasteo algunos comandos..., y ahí vino la debacle,
  4. Ejecuté "apt-get autoremove", y este comando borró todo lo que pudo.
  5. Repito los pasos 1 y 2, intento "Continuar con el arranque normal"
  6. Salgo en modo texto, autentico mi usuario, y aplico la solución, a saber
sudo dpkg --configure -a
sudo apt-get -f install
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install --reinstall ubuntu-desktop
sudo init 6

** sudo init 6 reinicia el equipo

 

El equipo arrancó de manera normal, tuve que recuperar algunos paquetes previamente instalados, y ahora va de nuevo como la seda.

 

Espero esta información sea de utilidad

 

Nota: agradezco de antemano si el tema requiere alguna modificación de etiquetas o reubicación, estas sean hechas.

 

Un saludo

 

JPablos 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share
×
×
  • Create New...