Ir al contenido
Gnu/Linux Vagos
Conéctate para seguir esto  
JPablos

(Solucionado) "apt-get autoremove" !Borró todo¡

Recommended Posts

Buenas tardes, dicen que "Echando a perder se aprende", pues bien hoy he aprendido cómo recuperar mi sistema (Ubuntu 16.04) luego de echarlo a pique por "trastear" con el entorno gráfico.

 

Reinicié mi equipo, con la sorpresa de no tener entorno gráfico, esta es la secuencia:

 

  1. Nuevo reinicio, busco "Opciones avanzadas para Ubuntu"
  2. Selecciono "... Linux 4.4.0-36-generic (recovery mode)"
  3. Paso a "consola root", trasteo algunos comandos..., y ahí vino la debacle,
  4. Ejecuté "apt-get autoremove", y este comando borró todo lo que pudo.
  5. Repito los pasos 1 y 2, intento "Continuar con el arranque normal"
  6. Salgo en modo texto, autentico mi usuario, y aplico la solución, a saber
sudo dpkg --configure -a
sudo apt-get -f install
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install --reinstall ubuntu-desktop
sudo init 6

** sudo init 6 reinicia el equipo

 

El equipo arrancó de manera normal, tuve que recuperar algunos paquetes previamente instalados, y ahora va de nuevo como la seda.

 

Espero esta información sea de utilidad

 

Nota: agradezco de antemano si el tema requiere alguna modificación de etiquetas o reubicación, estas sean hechas.

 

Un saludo

 

JPablos 

Compartir este post


Enlace al post
Compartir en otros sitios

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invitado
Responder en este tema...

×   Has incluido contenido con formato.   Eliminar formato

  Sólo se permiten 75 emoticonos como máximo.

×   Tu enlace ha sido insertado automáticamente.   Deshacer y mostrar como enlace

×   Su contenido anterior ha sido restaurado.   Limpiar editor

×   No puedes pegar imágenes directamente. Súbelas a algún hosting de imágenes y pega la dirección URL

Conéctate para seguir esto  

×
×
  • Crear Nuevo...