Jump to content
  • 0

nuevo en arch linux!


cesarguere
 Share

Question

Buenas a todos! este es mi primer post en esta pagina. La consulta es de algo que segurisimo es muy sencillo pero no se como resolverlo.

Acabo de instalar arch linux, ya teniendo opensuse y windows en otras particiones. Todo funciona excelente, en mi escritorio gnome que termino de instalar.

Pero tengo 2 problemas que son bastante molestos.

El primero es que con la instalacion base de arch, monto cualquier pendrive con nautilus pero no puedo escribirlos!! ya probe con chmod 777 e intente leer otras paginas antes de preguntar pero ya no se que hacer y sospecho que es algun archivo de configuracion de sistema que no lo conozco.

El segundo problema es que desde que instale arch, no puedo bootear opensuse con el grub2 que se instalo. Con opensuse 42.1, que tambien tiene grub2, no tenia problemas. Pero ahora cuando selecciono opensuse en el menu grub, me dice que no se encuentra el archivo del kernel linux. Revise todas las rutas y el archivo existe con el nombre indicado en grub pero no lo reconoce. Pienso que el problema esta en que la instalacion de opensuse esta hecha en un sistema de archivos btrfs. (arch lo instale en ext4)

 

Cualquier informacion la agradezco inmensamente!!

 

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

En vista de los sucedido, creo que te saldrá más rentable dejar que OpenSuse sea el que se encargue de administrar Grub.

 

Puedes hacerlo sin necesidad de iniciarlo, con una jaula chroot

 

 

 

mount /dev/sdXY /punto/montaje
Siendo sdXY la partición donde se encuentra instalado opensuse y el /punto/montaje cualquier directorio que usaremos para montarlo

 

 

 

mount --bind /dev  /punto/montaje/dev

mount --bind /sys /punto/montaje/sys

mount -t proc none /punto/montaje/proc

Jaula chroot

 

 

chroot /punto/montaje

Y a restaurar grub

 

 

grub-install /dev/sdX

os-prober

update-grub

 

Con quien tienes que lidiar para el montaje de dispositivos extraíbles es con Udisks

Link to comment
Share on other sites

  • 0

 

El primero es que con la instalacion base de arch, monto cualquier pendrive con nautilus pero no puedo escribirlos!! ya probe con chmod 777 e intente leer otras paginas antes de preguntar pero ya no se que hacer y sospecho que es algun archivo de configuracion de sistema que no lo conozco.

 

 

Cualquier informacion la agradezco inmensamente!!

¿Tienes instalado el paquete ntfs-3g?

Link to comment
Share on other sites

  • 0

Les agradezco mucho las respuestas!! 

 

En vista de los sucedido, creo que te saldrá más rentable dejar que OpenSuse sea el que se encargue de administrar Grub.

 

Puedes hacerlo sin necesidad de iniciarlo, con una jaula chroot

 

 

 

mount /dev/sdXY /punto/montaje
Siendo sdXY la partición donde se encuentra instalado opensuse y el /punto/montaje cualquier directorio que usaremos para montarlo

 

 

 

mount --bind /dev  /punto/montaje/dev

mount --bind /sys /punto/montaje/sys

mount -t proc none /punto/montaje/proc

Jaula chroot

 

 

chroot /punto/montaje

Y a restaurar grub

 

 

grub-install /dev/sdX

os-prober

update-grub

 

Con quien tienes que lidiar para el montaje de dispositivos extraíbles es con Udisks

Estas totalmente en lo cierto!! me habia olvidado de esa opcion para entrar en opensuse. Lo conveniente va a ser que use el grub de opensuse.

Con lo del pendrive se me soluciono. Tuve que reinstalar arch porque intente instalar los drivers de amd y no pude recuperar X. Con la reinstalacion ahora puedo escribir en el maldito pendrive!!

 

 

 

 

El primero es que con la instalacion base de arch, monto cualquier pendrive con nautilus pero no puedo escribirlos!! ya probe con chmod 777 e intente leer otras paginas antes de preguntar pero ya no se que hacer y sospecho que es algun archivo de configuracion de sistema que no lo conozco.

 

 

Cualquier informacion la agradezco inmensamente!!

¿Tienes instalado el paquete ntfs-3g?

 

 

Si, tenia instalado ntfs-3g. Sin dudas que, como dice shiba87, tiene que ver con "udev". Estuve mirando algunas wiki pero era bastante complicado de entender. Por suerte, tuve que reinstalar, y se arreglo!!!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...