Jump to content

GNU/Linux Vagos necesita Betatesters para la versión final


Shiba87
 Share
Followers 1

Recommended Posts

logoamq.png
letrash.png



Hoy voy a abusar un poquito de los poderes de Admin y no lo pongo como ayuda, sino como anuncio del foro, con un par....de razones de peso para hacerlo :silba:


Como algunos ya sabrán, la distribución GNU/Linux que empezamos en el extinto Vagos ha sido "rediseñada" y se encuentra muy próxima a ver la luz la versión final de GNU/Linux vagos 4.1.

Ahora mismo se encuentra "congelada" y en la recta final, la última imagen es la clara candidata a ser la versión final, pero queda una parte en la que hace falta cierta colaboración y es el testeo.
Sólo siendo probada y observada por muchos ojos es como salen los errores y los fallos que no se han visto hasta ahora.

No es necesario casarse con la distribución, ni pasarse horas y horas para luego entregar un informe detallado, sólo darle un poco de uso y fijarse en todo aquello que puede ser mejorado o que presenta algún problema, aunque sea una probadita al live, una ratito, o desde virtualbox, no importa, lo importante es que sea puesta a prueba antes de dar el visto bueno a la versión final.

La última RC la podrán encontrar, como no, el la sección de distribuciones basadas en Debian

http://gnulinuxvagos.es/topic/539-gnulinux-vagos-42-librex86-64espanol/

Gracias y SalUnix

Edited by pacoeloyo
Link to post
Share on other sites

La descargare y la probare! y si me gusta la dejare en mi pc..... :sleep: :sleep:

 

Bonita rima :lol:

Para quedársela como "principal" mejor esperar un poco a la versión final. Como prueba sí, es de lo que trata esto :P

Link to post
Share on other sites
  • 2 weeks later...

Probando la ultima RC 4.2 prerelease segun veo que la has llamado tu :D

 

Instalada como "Live" en vez de como "Normal"

 

Al intentar actualizar:

 

 

Postear Imagen

 

 

Postear Imagen

 

 

Viendo esto le hago un:

 nano /etc/apt/sources.list

 

Postear Imagen

 

 

 

Y ya por simple morbo y curiosidad intento instalar cualquier cosa:

 

 

 

Postear Imagen

 

 

 

P.D: No se si este sera el hilo para los reportes o creamos otro aparte :)

Link to post
Share on other sites

Como se suele decir, vayamos por partes.

 

La 2ª captura está bien, el repositorio cathbard (inxi) es de los últimos que metí y es tal cual, así de feo.

 

De resto puedo deducir que mientras estabas instalando te saltaste la parte de configurar repositorios ¿Eh pillín? :jojojo:

 

Esa es una de las cosas que también funcionan ahora aparte de la creación de usuarios, si no se configura se quedan los repos vacíos :P.

 

 

En realidad tengo un dilema con eso y es que me gustaría que cada cual eligiera lo que quiere en cuanto a repos, país, añadir nonfree, no añadir nonfree....

Pero también hay otros repos que sí me gustaría "forzar", cosa que ya veo que funciona, pues el repositorio de inxi sí está, aunque te saltaras ese paso de la instalación, faltaría añadir los otros a excepción del de Opera, que lo tengo que no sé si sí o si no al ser privativo.

 

Hay un script "oculto" que tendrás deshabilitado con "la fórmula antigua", puedes ejecutarlo con

service 20.script start
Eso debería modificar todos los repositorios y, con un poco de buena suerte (puede que mala en tu caso :sweat:), tirar el entorno gráfico abajo, instalar los últimos de nVidia automáticamente, configurar el xorg.conf y volverlo a levantar, aunque dudo bastante de esto último.

 

Lo más que me interesa de esta "Pre" es el /etc/network/interfaces, que debería estar tal cual lo configuraste en la instalación y no como aparecía antes, linux 3.6.6, el tema de los repos forzados/no forzados, que veo que sí funciona aunque sólo metiera uno :P ..... no me acuerdo si llegué a cambiar el logo de lightdm, creo que sí y que el instalador haga todo lo que dice hacer, que parece que también es así.

 

El ratón a medias no tengo idea de lo que puede ser, la personalización de aspecto y yo no nos llevamos :sweat:

Link to post
Share on other sites

A ver vamos a comentar por partes tambien:

 

Los repos que yo veo ahi ( /etc/apt/sources.list) son de un Debian Testing recien instalado y limpito, lo recuerdo todavia de cuando instale este y le modifique algunos repos a mi gusto, tambien le elminine las primeras dos lineas para que no me saliera todo eso del principio del update, por mi parte he instalado la distro como hago siempre, nunca habia fallado esto de los repos, en la anterior RC que ya estaba solucionado la creacion de usuarios no fallo, el unico cambio que hice fue el que hablamos de hacerlo en "Live" en vez de en "Normal".

 

Tambien como tu, veo que eso de los repos es algo personal y cada cual tiene sus preferencias asi que hablando por mi, con los testing y con los experimental para tener el iceweasel siempre a la ultima para mi sobraria.

 

Esta instalada en el portatil y este no tiene grafica nvidia no veo por que deberia tener mala suerte al ejecutar ese script.

 

Seguimos con el /etc/network/interfaces en la anterior RC me di cuenta de que no funcionaba, sin embargo al intentar editar el archivo vi que si estaba editado con las dos almohadillas que lo hacen funcionar (curioso pero cierto) simplemente al cerrar el terminal con la edicion no echa y ponerse a gestionar las redes wifi, en esta RC yo creo que ha sido al instalarla en "Live" al ir a editar el /etc/network/interfaces ya ves como sale, que no esta editado con esas dichosas almohadillas, como en anteriores veces editarlo y a funcionar se ha dicho.

 

Gnome3 shell no aparece ni en el Live ni en la instalacion como definido y sale el Gnome3 por defecto en lugar del Gnomis Dark que es el tema para el shell de la distro, lo del raton tambien coincido contigo es algo rarisimo que se haya quedado a medias, eso si que funciona en el Live (sin instalar) perfectamente, instalado ya da igual en "Normal" que en "Live" cuando estan encima de algo que tiene accion si funciona si no esta con la predefinida de Gnome3 (Adwaita Cursor me parece)

 

Hasta aqui puedo leer....... :)

Link to post
Share on other sites

Hola buenas se agradeceria algun voluntari@ para contrastar informaciones, sobre GNU/Linux Vagos 4.2 que va ya camino de la version final, la distro funciona perfectamente pero hay algunos aspectos que hay que pulir todavia un poco y harian falta mas opiniones y reportes de algun error que se vea.

 

Muchas gracias ;)

Link to post
Share on other sites

Hago doble post pero bueno para dar una buena noticia, al instalar y llegar a la opcion Usar Replica en Red, con las RC nunca lo habia usado esto ya que se le añadian directamente los repos que shiba les habia puesto, pero bueno esto cambio al ser ya util el usuario que creamos al instalar la distro.

 

Bueno al darle que si a Usar Replica en Red nos va a dar a escoger de donde queremos que descargue los paquetes (Pais) y si preferimos usar paquetes solo libres o tambien los no libres (Free o Non-free), con esto solucionamos el problema que habia anteriormente de tener el sources.list vacio.

 

Capturas:

 

 

Postear Imagen

 

 

Postear Imagen

 

La famosa carpeta skel, si que aparecio ahora.......

 

Y probando a instalar el mismo programa que antes el gtkpod pongo el final para que se vea que tambien un fallito que teniamos en mente (initframs-tools) tampoco aparece :D

 

 

Postear Imagen

Link to post
Share on other sites

Por ahora, parece que salvo ese puntero que fnuciona a medias, algo relacionado con mi amado y adorado Gnome 3 que no tengo ni idea a qué es debido, está todo en su sitio salvo lo que tengo por aquí ya corregido que aún no he subido.

 

Para la versión final hay varios cambios importantes, un es éste, que cada uno elija los repositorios en función de su país y decida si quiere o no incluir repositorios no libres. Otros repositorios que trae como "extra" la distribución estarán ya de serie, tales como Inxi, jdownloader, jitsi, wine y el más polémico Opera, que salvo Jdownloader e Inxi no estarán instalados, sólo están ahí por si los llegamos a necesitar.

 

Firefox 17 fue lanzado ayer, así que llega justo a tiempo para incluir Iceweasel 17 ESR (soporte extendido) en la distro, no sé si será el caso de Icedove, viendo a la velocidad que lo actualizan no lo creo, pero siendo una versión ESR quizá se den algo más de prisa.

 

Libreoffice 3.6.4 y Linux 3.6.6 vendrían a completar la lista en cuanto a nuevas versiones de paquetes.

 

Los scripts de inicio ahora son totalmente nuevos y se encargan de 3 cuestiones principales, el 1º de hacer que los repositorios que hemos elegido apunten siempre a testing, no a wheezy o jessie, para que nos mantengamos siempre en la misma rama.

El 2º se encarga de limpiar algunos paquetes propios del sistema live que ya no son útiles con la distribución instalada.

 

El 3º es una experimento que lleva gestándose desde GNU/Linux vagos 1.0 y es la autoinstalación de los controladores de Nvidia (en equipos con nvidia, no en el resto), en esta ocasión llevándolo un poco más lejos al instalarse los últimos disponibles, que ahora mismo son los de la serie R310, todo ello utilizando únicamente los repositorios de Debian, por lo que se seguirían actualizando solos.

Link to post
Share on other sites

Por mi parte también pienso lo mismo, salvo el puntero y el network/interfaces todo correcto, también hay que decir que el problema de la gestión de redes es cosa de Debian no de la RC, tuve el mismo problema al instalar Debian por primera vez en el portátil, de todas formas la siguiente ira al sobremesa que tiene gráfica nvidia y asi probamos ese script :D

Link to post
Share on other sites

A mi esta y la anterior no puedo instalarlas, me da fallo al detectar y montar el CD-ROM y no me deja continuar....

La quiero instalar con un pen por USB volcada con UNetbootin.

 

Yo con el puntero creo la carpeta default en /usr/share/icons y copio y pego el contenido del icono y se ve en todo el sistema.

 

Pulse-Glass -> cursors, cursor.theme, index.theme

default -------> cursors, cursor.theme, index.theme

 

Reiniciar....

Edited by magi
Link to post
Share on other sites

El tema de la conexión es cosa del network-manager. Con otro gestor de redes u otro entorno, casi seguramente no habría ningún problema.

 


 

Casualidades de la vida, justo estaba probando a hacer eso con el puntero del ratón :jojojo:

 

Lo que cuentas se había comentado y a partir de la RC7, incluí la opción de arranque "cdrom-detect/try-usb=true"

Asegúrate que al pasar la iso al pen, en la línea de arranque correspondientes a la instalación, se respeta esa opción, de lo contrario, inclúyela a mano y después arranca el instalador.

Parece ser o bien alguna versión concreta de Unetbootin o un problema que tiene éste al pasar la imagen, dado que sólo les pasa a algunas personas :pensar:

Link to post
Share on other sites

Esta puesto cdrom-detect/try-usb=true

 


default menu.c32

prompt 0

menu title UNetbootin

timeout 100

label unetbootindefault

menu label Default

kernel /ubnkern

append initrd=/ubninit boot=live config quiet init=/bin/systemd live-config.locales=es_ES.UTF-8

label ubnentry0

menu label Live GNU/Linux Vagos 4.2 (Linux 3.6)

kernel /live/vmlinuz

append initrd=/live/initrd.img boot=live config quiet init=/bin/systemd live-config.locales=es_ES.UTF-8

label ubnentry1

menu label Live GNU/Linux Vagos 4.2 (Modo Seguro)

kernel /live/vmlinuz

append initrd=/live/initrd.img boot=live config noapic noapm nodma nomce nolapic nomodeset nosmp vga=normal init=/bin/systemd live-config.locales=es_ES.UTF-8

label ubnentry2

menu label Instalador Live (Linux 3.2)

kernel /live/vmlinuz2

append initrd=/live/initrd.img2 boot=live config quiet init=/bin/systemd cdrom-detect/try-usb=true live-config.locales=es_ES.UTF-8

label ubnentry3

menu label Instalador Live (Modo Seguro)

kernel /live/vmlinuz2

append initrd=/live/initrd.img2 boot=live config noapic noapm nodma nomce nolapic nomodeset nosmp vga=normal init=/bin/systemd cdrom-detect/try-usb=true live-config.locales=es_ES.UTF-8

label ubnentry4

menu label Instalador Completo (Modo Texto)

kernel /install/vmlinuz

append initrd=/install/initrd.gz priority=low vga=normal cdrom-detect/try-usb=true

label ubnentry5

menu label Instalador Completo (Modo Grafico)

kernel /install/gtk/vmlinuz

append initrd=/install/gtk/initrd.gz priority=low video=vesa:ywrap,mtrr vga=788 cdrom-detect/try-usb=true

label ubnentry6

menu label Modo Rescate

kernel /install/gtk/vmlinuz

append initrd=/install/gtk/initrd.gz rescue/enable=true video=vesa:ywrap,mtrr vga=788 quiet

 

Edited by magi
Link to post
Share on other sites

Pues..........sólo me queda pensar que es justo lo contrario y que ha sido un error ponerla por defecto, sería cuestión de probar justo lo contrario a lo que dije antes, eliminar esa opción y dejar que el instalador se busque la vida por sí mismo :lol:

Link to post
Share on other sites

Prueba lo más sencillo a mi me dio resultado, la primera imagen unetbootin tampoco me la reconoció al instalar lo que hice fue eliminar la partición del pen volverla a crear y formatear a fat32.

Luego vuelve a crear el líve, a mi ya te digo me funcionó y ya he creado unos cuantos más :D

Link to post
Share on other sites

Pues mira, ahora que lo has mencionado, se me ha :idea: .

 

El archivo que identifica el disco de instalación como tal, Unetbootin lo incluye en el Pendrive dentro de una carpeta oculta llamada .disk, esa carpeta contiene varios archivos, uno de ellos es el archivo info, donde está el nombre de la distribución. Ese archivo es el que se comprueba al iniciar el instalador, si no está ahí o el nombre que contiene no coincide, da el error del que hablamos y....... casualmente nos encontramos con que ya no es GNU/Linux 4.1 sino 4.2 y que el instalador no es el mismo de antes, así que por ahí también podría venir el problema, que Unetbootin no llegue a sustituir eso y siga con la versión antigua.

Link to post
Share on other sites

No me funciona, siempre que vuelco una iso con UNetbootin elimino los archivos ocultos y los no ocultos no hace falta formatear el pen...

El archivo info trae GNU/Linux Vagos 4.2 - Official Snapshot amd64 LIVE/INSTALL Binary 20121108-12:39

 

 

En instalador completo (modo texto) y (modo gráfico) pasa esto.

Postear Imagen

 

En instalador live (linux 3.2) y (modo seguro) pasa esto.

Postear Imagen

Postear Imagen

 

En default la 1 opción de UNetbootin

Postear Imagen

 

 

 

Con ImageWriter pone image not found.

 

Quitando la opción cdrom-detect/try-usb=true no va

 

Esto me paso antes pero no me acuerdo en que versión fue.

Edited by magi
Link to post
Share on other sites

Conozco la historia a bonijas le pasaba exactamente lo mismo, a mi me paso lo mismo tambien e hice lo que te apunte arriba, eliminar la particion del pen, crear otra nueva con formato MBR y de nuevo formatear a fat32 (Yo lo hago con la Utilidad de Discos, Gparted tambien lo hace pero para algo tan simple utilizo la primera)

 

Paso de no reconocerme el cd montado a reconocerlo y permitirme instalarlo perfectamente, de echo esto me paso con la anterior rc y aquella la instale y con esta ya no tuve el problema de que no la reconociera al montarla con UnetBootin fue todo a la primera :)

Link to post
Share on other sites

Solucionado, ya lo reconoce, lo he formatedo en FAT32 desde windows y con UNetbootin he volcado la iso desde linux....

Ni con utilidad de disco, ni gparted ni por terminal podia formatearlo, que raro, el pen es nuevo.

Ya lo instalare cuando pueda.

 

Postear Imagen

 

Edited by magi
Link to post
Share on other sites

Bueno que maravilla en dos días haber podido resolver los problemas que nos tenían un tiempo para acá preocupados, ademas la distro no me canso de decirlo que es rapidísima en arrancar y funciona muy muy bien, aquí en este sobremesa tendra su partición que seguramente por cosas de la vida se vuelva KDE, evolución y tal y tal...... :jojojo:

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share
×
×
  • Create New...