Ir al contenido
  • 0
mijailbellum

Cambiar resolución de pantalla en laptop

Pregunta

Buenas a todos, tengo un problema al intentar modificar la resolució de mi pantalla, quiero poner 1280x720 ya que tiene la misma relación que mi resolución actual 1366x768 pero un con unos cuantos menos pixeles, es una prueba de rendimiento, configuré el xorg así.

Section "Device"

    Identifier     "Device0"
    Driver         "intel"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
    Monitor "Configured Monitor"
        SubSection "Display"
            Modes "1280x720"
            Virtual 1280 720
            Depth 24
        EndSubSection
    Identifier "Display0"
    Device "Device0"
EndSection

Es uan configuración casi básica con alguna cosa que encontré por ahí, antes solo tenía puesto la sección "device", el caso es que me sigue mostrando la resolución 1366x768 y al configurarla a través de las opciones de Gnome no me deja elegir esta tampoco, solo 1360x768, 1024x768 y 800x600 que no tienen la misma relación que mi pantalla 16:9¿Alguien sabe como se hace exactamente esto? Al menos que me deje seleccionar esa opción en el menú de configuración de pantalla para poder volver a la original rápidamente según sea necesario.

 

Saludos.

 

PD: Me faltó mencionar que uso Debian Testing con Gnome 3, mi gráfica es una Intel HD 4600 y tengo un laptop con monitor  de 14"

Editado por mijailbellum

Compartir este post


Enlace al post
Compartir en otros sitios

19 respuestas a esta pregunta

Recommended Posts

  • 0

A ver si no me lío:

xrandr

Te saldrá la pantalla conectada y las posibles resoluciones entre las que no estará la que necesitas.

 

creas un nuevo modeline para 1280 x 720

cvt 1280 720

Saldrá algo así

 

 

Modeline "1280x720_60.00"   74.50  1280 1344 1472 1664  720 723 728 748 -hsync +vsync

Puedes ajustar también la tasa de refresco si quieres añadiendo el valor en hertzios al final

cvt 1280 720 60

Con el resultado, omitiendo el término modeline, creas una nueva opción de resolución.

xrandr --newmode "1280x720_60.00"   74.50  1280 1344 1472 1664  720 723 728 748 -hsync +vsync

Y para ir más allá, toca asignarlo a la pantalla en cuestión, cuyo nombre te habrá salido en la segunda línea del xrandr, por ejemplo DVI-I-0

xrandr --addmode DVI-I-0 1280x720_60.00

Como alternativa, también podría generar el modeline con gtf o el mismo cvt y luego añadirlo al Xorg.conf

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Gracias por la respuesta pero no me funciona, creo el nuevo modo y me aparece para seleccionar pero al seleccionarlo me dice que si quiero dejarlo asi le digo que si y vuelve a lo mismo 1366x768 en cambio los modos que vienen por defecto si me deja seleccionarlos y permanecen, lo hcie como me dijiste, no lo añadi al xorg, no se como se hace eso exactamente.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Sólo hay que copiar y pegar tal cual la línea que devuelve ctv (o gtf) dentro de la sección monitor del xorg.conf

 

 

Section "Monitor"

Identifier "monitor1"

VendorName "Generic"

ModelName "Flat Panel 1400x1050"

HorizSync 31.5-90

VertRefresh 59-75

 

Modeline "1280x720_60.00"   74.50  1280 1344 1472 1664  720 723 728 748 -hsync +vsync

 

 

EndSection

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Al parecer nunca te respondí, hoy quise volver a usar esto y tenía la configuración guardada en el disco duro, dejo por aquí como tuve que dejarlo todo para que me funcionara, dentro de /etc/X11/xorg.conf

 

Section "Monitor"

    Identifier "Configured Monitor"
    HorizSync 31.5-90
    VertRefresh 59-75
    Modeline "1280x720_60.00"   74.50  1280 1344 1472 1664  720 723 728 748 -hsync +vsync

EndSection

Es básicamente lo mismo que pusiste pero con otro identificador y sin especificar el resto de cosas, porque de la otra forma no me servía, espero que le sea útil a alguien.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0
On 4/24/2017 at 11:54, mijailbellum dijo:

Al parecer nunca te respondí, hoy quise volver a usar esto y tenía la configuración guardada en el disco duro, dejo por aquí como tuve que dejarlo todo para que me funcionara, dentro de /etc/X11/xorg.conf

 


Section "Monitor"

    Identifier "Configured Monitor"
    HorizSync 31.5-90
    VertRefresh 59-75
    Modeline "1280x720_60.00"   74.50  1280 1344 1472 1664  720 723 728 748 -hsync +vsync

EndSection

Es básicamente lo mismo que pusiste pero con otro identificador y sin especificar el resto de cosas, porque de la otra forma no me servía, espero que le sea útil a alguien.

 

Vaya pues a mi no me funciona, en primer lugar en mi sistema no existe el archivo /etc/X11/xorg.conf

Lo he creado con esas lineas,  poniendo en Modeline lo que me devuelve el comando ctv, para la resolucion que yo necesito, la de 1600x900

y nada, no funciona

 

Los valores

    HorizSync 31.5-90
    VertRefresh 59-75

 

¿como se obtienen? ¿o son siempre esos pra el refresco de 60?

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

lo que si me funciona es ejecutar estos comandos en terminal

 


xrandr --newmode "1600x900_60.00"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync
xrandr --addmode HDMI-1 1600x900_60.00
xrandr --output HDMI-1 --mode 1600x900_60.00

 

como podría hacer para que se ejecuten en cada inicio de sesion?

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

@alguien ¿Cuándo ejecutas eso te crea algún archivo en la carpeta /etc/X11? en teoría todo es opcional, pon solo las líneas que necesitas que el sistema debería arreglarlo todo por defecto si no me equivoco.

 

Tu sigue los pasos que menciona Shiba, pero acorde a tus necesidades y pon aquí exactamente lo que haces para ayudarte mejor.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0
hace 5 horas, mijailbellum dijo:

@alguien ¿Cuándo ejecutas eso te crea algún archivo en la carpeta /etc/X11? en teoría todo es opcional, pon solo las líneas que necesitas que el sistema debería arreglarlo todo por defecto si no me equivoco.

 

Tu sigue los pasos que menciona Shiba, pero acorde a tus necesidades y pon aquí exactamente lo que haces para ayudarte mejor.

 

Cuando yo ejecuto en la terminal los comandos:

 

xrandr --newmode "1600x900_60.00"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync
xrandr --addmode HDMI-1 1600x900_60.00
xrandr --output HDMI-1 --mode 1600x900_60.00

 

me cambia a la resolucion que yo quiero, de 1600x900

y ademas me crea una entrada de esa resolucion  en la interfaz grafica de configuracion de pantalla de xfce4, pero no se mantienen en la siguiente sesión.

 

Lo que quiero es que se mantenga en las siguientes sesiones, ¿no hay alguna manera de que un script bash con esos comandos se ejecute en cada sesion?

 

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Y no, cuando ejecuto esos comandos en un script que me tengo creado para no teclearlos cada vez, no me crea ningun archivo en /etc/X11/

No se si lo hará en otro sitio

 

mi contenido de /etc/X11/ es

ls -lha /etc/X11/
total 92K
drwxr-xr-x  10 root root 4,0K feb 12 00:59 ./
drwxr-xr-x 167 root root  12K feb  8 13:23 ../
drwxr-xr-x   2 root root 4,0K ene 19 13:46 Xreset.d/
drwxr-xr-x   2 root root 4,0K ene 19 13:46 Xresources/
drwxr-xr-x   2 root root 4,0K ene 19 22:00 Xsession.d/
drwxr-xr-x   2 root root 4,0K ene 19 17:47 app-defaults/
drwxr-xr-x   6 root root 4,0K ene 19 15:02 fonts/
drwxr-xr-x   2 root root 4,0K ene 19 15:02 xinit/
drwxr-xr-x   2 root root 4,0K jul 18  2017 xkb/
drwxr-xr-x   2 root root 4,0K ene 19 15:02 xsm/
-rwxr-xr-x   1 root root  709 nov 23  2016 Xreset
-rwxr-xr-x   1 root root 3,5K nov 23  2016 Xsession
-rw-r--r--   1 root root  265 nov 23  2016 Xsession.options
-rw-r--r--   1 root root   13 dic  5  2016 XvMCConfig
-rw-r--r--   1 root root  630 ene 19 15:03 Xwrapper.config
-rw-r--r--   1 root root   18 ene 19 15:03 default-display-manager
lrwxrwxrwx   1 root root   14 nov 24  2016 openbox -> ../xdg/openbox/
-rw-r--r--   1 root root  17K nov 23  2016 rgb.txt

 

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Ya expliqué antes lo que hago, pues crear el archivo /etc/X11/xorg.conf con el contenido que puse antes

 

Section "Monitor"

    Identifier "Configured Monitor"
    HorizSync 31.5-90
    VertRefresh 59-75
    Modeline "1600x900_60.00"  119.00  1600 1696 1864 2128  900 901 904 932  -HSync +Vsync

EndSection

 

la lina Modeline con los valores que me da el comando

cvt 1600 900 60

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Bueno ya conseguí por fin tener la resolucion de pantalla que necesito de 1600x900 sin tener que ejecutar cada vez el scrip que me he creado en cada sesión.

 

El archivo /etc/X11/xorg.conf que no existe en mi Debian 9, no me sirve de nada crearlo yo manualmente, con los valores que me da cvt o gtf (en mi caso da los mismos valores), y el comando xrandr

 

El scrip que me habia creado, funcionandome a la perfección ejecutando manualmente en la consola, en cada inicio de sesión:

 

#!/bin/sh
xrandr --newmode "1600x900_60.00" 118.25 1600 1696 1856 2112 900 903 908 934 -hsync +vsync
xrandr --addmode HDMI-1 "1600x900_60.00"
xrandr --output HDMI-1 --mode "1600x900_60.00"

 

Y lo que he tenido que hacer para que se ejecute automáticamente en cada inicio: ir al menú inicio del escritorio xfce4, configuración ==> Sesión e Inicio ==> pestaña "Autoarranque de aplicaciones"

 

Click en en añadir y darle la ruta del script, así de fácil (ahora que lo se, claro).

 

 

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

La misma pregunta que hice aquí la hice también en DebianFacile, y mira que soy vago, pero vago de vago, no de linuxvago, me pidió un moderador que antes de poner la etiqueta de tema resuelto hiciera una síntesis de los pasos que había dado. Dije que luego iria y todavía no he ido.

 

Lo que pasa que he siguido probando cosas. Yo no tenia instalados los drivers privativos de Nvidia, y los instalé a ver que pasaba con

 

apt install linux-headers-$(uname -r)

apt-get install -t stretch-backports nvidia-driver

 

Lo que me he encontrado es que el comando que me iba perfecto anteriormente, desde que he instalado esto ya no va. Da un error al ejecutar

 

xrandr --newmode "1600x900_60.00" 118.25 1600 1696 1856 2112 900 903 908 934 -hsync +vsync

 

Y ya me quedé sin la resolución que a mi me gusta de 1600x900

 

Desinstalar el privativo de nvidia en otra ocasión lo intenté y fue un desastre que tuve que reinstalar todo el sistema Debian de nuevo.

 

Así que, a tirar de tamaños de letra grandes.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0
hace 43 minutos, alguien dijo:

La misma pregunta que hice aquí la hice también en DebianFacile, y mira que soy vago, pero vago de vago, no de linuxvago, me pidió un moderador que antes de poner la etiqueta de tema resuelto hiciera una síntesis de los pasos que había dado. Dije que luego iria y todavía no he ido.

 

Lo que pasa que he siguido probando cosas. Yo no tenia instalados los drivers privativos de Nvidia, y los instalé a ver que pasaba con

 


apt install linux-headers-$(uname -r)

apt-get install -t stretch-backports nvidia-driver

 

Lo que me he encontrado es que el comando que me iba perfecto anteriormente, desde que he instalado esto ya no va. Da un error al ejecutar

 


xrandr --newmode "1600x900_60.00" 118.25 1600 1696 1856 2112 900 903 908 934 -hsync +vsync

 

Y ya me quedé sin la resolución que a mi me gusta de 1600x900

 

Desinstalar el privativo de nvidia en otra ocasión lo intenté y fue un desastre que tuve que reinstalar todo el sistema Debian de nuevo.

 

Así que, a tirar de tamaños de letra grandes.

 

Es que debes poner información siempre, como ahora mismo ¿Qué error daba? jajajaja debes pensar que hay millones de causas posibles para un problema en esto y la gente que te lee desde casa no tiene ni idea de lo que tienes instalado, donde, etc.. y muchos otros factores.

 

Prueba a hacer lo que te dije del tema que yo abrí, pero en el xorg.conf pon solo lo que necesitas.

 

Section "Monitor"

    Modeline "1600x900_60.00"  119.00  1600 1696 1864 2128  900 901 904 932  -HSync +Vsync

EndSection

Y por le amor de Dios, pon todo los pasos que des y todos los mensajes que te muestre el sistema.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0
hace 4 horas, mijailbellum dijo:

 

Es que debes poner información siempre, como ahora mismo ¿Qué error daba? jajajaja debes pensar que hay millones de causas posibles para un problema en esto y la gente que te lee desde casa no tiene ni idea de lo que tienes instalado, donde, etc.. y muchos otros factores.

 

Prueba a hacer lo que te dije del tema que yo abrí, pero en el xorg.conf pon solo lo que necesitas.

 


Section "Monitor"

    Modeline "1600x900_60.00"  119.00  1600 1696 1864 2128  900 901 904 932  -HSync +Vsync

EndSection

Y por le amor de Dios, pon todo los pasos que des y todos los mensajes que te muestre el sistema.

 

"Y por le amor de Dios, pon todo los pasos que des y todos los mensajes que te muestre el sistema."

 

Los pasos dados ya lo he explicado, y tambien he dicho más arriba que no tengo archivo xorg.conf, y que si lo creo manualmente siguiendo al pié de la letra tus indicaciones y las de Shiba, no me hace nada. Me voy a repetir más que unas maracas de Machín.

 

El mensaje de error no lo puse antes porque estaba en windows, ahora lo pongo.

 

Repito que antes de instalar los drivers privativos de Nvidia, todo iba perfecto, pero ahora da un error en el tercer paso

ejecuto en root:

 

gtf 1600 600 60

que me devuelve este valor

# 1600x600 @ 60.00 Hz (GTF) hsync: 37.32 kHz; pclk: 76.43 MHz
  Modeline "1600x600_60.00"  76.43  1600 1664 1824 2048  600 601 604 622  -HSync +Vsync

Según Shiba y según tu, pegar la linea

Modeline "1600x600_60.00"  76.43  1600 1664 1824 2048  600 601 604 622  -HSync +Vsync

en el xorg.conf dentro de la sección "Monitor" ya me deberia inicar en cada sistema con dicha resolucion, pero no es asi, repito que no tengo archivo xorg.cong y aunque lo cree manualmente con dicho parametro no hace nada.

 

Sigo pues con el siguiente paso, ejecutar en root los siguientes tres comandos, uno despues de otro, y en el ultimo se cambia a la resolución deseada, pero no se mantiene  en la siguiente sesión, como el metodo del archivo xorg.conf no me funciona me creo un scrip bash con estos tres comandos, y le doy instrucciones para que el script se ejecute al inicio.

 

No sabia como hacer para ejecutar el script al inicio que es otra pregunta que formule y nadie me respondió, pero la culpa es mia porque no me se explicar.

xrandr --newmode "1600x900_60.00"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync
xrandr --addmode HDMI-0 1600x900_60.00
xrandr --output HDMI-0 --mode 1600x900_60.00

Como conseguir que un script con estos tres comandos se ejecutara al inicio de mi sesion de usuario, lo explique mas arriba, a traves de la utilidad grafica de xfce4 "Menu de aplicaciones" --> "Configuración" --> "Sesión e Inicio" --> pestaña Arranque de aplicaciones, y boton añadir.

 

Hasta aqui exito rotundo, cada vez que inicio sesion ya tengo la resolución de pantalla de 1600x900

 

Espero que se entienda esta vez, mejor no lo se explicar.

 

Segundo experimento:

 

Instalo los drivers privativos de Nvidia segun un tuto que he encontrado en la red, con estos dos comandos:

 

apt install linux-headers-$(uname -r)
apt-get install -t stretch-backports nvidia-driver

 

También lo expliqué antes. Y Nvidia se instala sin problemas. Pero sigue sin mostrar la resolucion que deseo.

El script que hice para que se ejecutara al inicio, lo quito por el mismo metodo ya explicado solo que en vez de darle al boton añadir, lo señalo y le doy a quitar.

 

Ejecuto los mismos pasos de antes

 

pero este comando: xrandr --addmode HDMI-0 1600x900_60.00

me da el siguiente error:

X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  35
  Current serial number in output stream:  36

 

Pegar este mensaje de error era lo único que me faltaba por poner en el hilo.

Y esto (repito) despues de lo privativos de Nvidia, antes no, antes iba todo como una seda.

 

Ya si los que lean este tema desde casa no entienden, yo lo siento pero no me se explicar mejor. Y no pasa nada, yo me apaño ya como estoy, gracias por la ayuda y nos vemos en el siguiente tema.

 

 

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Si es para utilizar los contoladores privativos, lo más útil sería dejar que fueran estos mismos los que administraran el archivo xorg.conf, que es muy extraño que no esté ahí después de haber instalado los controladores:

aptitude install nvidia-xconfig
nvidia-xconfig --composite --no-logo

Se podría definir los metamodes también directamente, da muchísimo juego, pero tampoco es que se ahorre mucho a insertar la línea después

 

 

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Se me ha olvidado un paso que fue el primero de todos, ejecutar en root: xrandr

 

que me devuelve la siguiente información:

 

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 16384 x 16384
VGA-0 disconnected (normal left inverted right x axis y axis)
DVI-D-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 160mm x 90mm
   1920x1080     60.00*+  59.94    50.00    29.97    25.00    23.97    60.05    60.00    50.04  
   1360x768      60.02  
   1280x1024     60.02  
   1280x720      60.96    60.00    59.94    50.00  
   1152x864      75.00  
   1024x768      60.00  
   800x600       60.32  
   720x576       50.00  
   720x480       59.94  
   640x480       59.94    59.93  

 

Lo siento, lo obvié antes porque creí que no seria necesario, esta información confirma lo que ya expuse al principio, que no cuento con la resolución de 1600x900

 

En windows si, mismo pc, mismo monitor y va muy bien con la resolución de 1600x900 que puedo elegir desde el panel de control de los drivers Nvidia, no así en Debian gnu/linux.

 

Salud y saludos.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0
On 15/2/2018 at 23:10, Shiba87 dijo:

Si es para utilizar los contoladores privativos, lo más útil sería dejar que fueran estos mismos los que administraran el archivo xorg.conf, que es muy extraño que no esté ahí después de haber instalado los controladores:


aptitude install nvidia-xconfig
nvidia-xconfig --composite --no-logo

Se podría definir los metamodes también directamente, da muchísimo juego, pero tampoco es que se ahorre mucho a insertar la línea después

 

 

 

 

Será muy extraño, no lo niego, pero no está el archivo en su sitio despues de instalar los drivers privativos.

 

No es por usar los drivers privativos de Nvidia, es por probarlo todo, con Debian 8 no me queda mas remedio que instalar los privativos porque no me reconoce el monitor, y se queda la pantalla en negro. En debian 9 si tira palante sin privativos.

 

Por cierto al instalar nvidia-xonfig y ejecutar en root "nvidia-xonfig" si crea el xorg.conf en mi carpeta de usuario, en mi home, con en el nombre xorg.conf.new

Lo probé segun un tuto que encontré ayer, moviendo ese archivo a su carpeta /etc/X11 renombrado a xorg.conf

 

http://www.ubuntu-guia.com/2010/07/crear-xorgconf-ubuntu-1004.html

 

luego pego la linea

 

Modeline "1600x900_60.00"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync

 

En la seccion de monitor, pero no hace nada. No funciona. Ni muestra mensajes de error ni nada de nada, no hay opcion de resolución de pantalla de 1600x900, y eso es todo.

 

Gracias por el interes

 

EDITO: esta es la seccion Monitor del archivo xorg.cong que crea el comando

nvidia-xconfig --composite --no-logo

 

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
    Modeline "1600x900_60.00"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync
EndSection

 

La última linea es la que he añadido, pero reinicio y no hace nada,

 

 

Editado por alguien

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Por último, el resultado del comando xrandr despues de reiniciar con esa linea añadida al xorg.cong

 

xrandr
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 16384 x 16384
VGA-0 disconnected (normal left inverted right x axis y axis)
DVI-D-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 160mm x 90mm
   1920x1080     60.00*+  59.94    50.00    29.97    25.00    23.97    60.05    60.00    50.04  
   1360x768      60.02  
   1280x1024     60.02  
   1280x720      60.96    60.00    59.94    50.00  
   1152x864      75.00  
   1024x768      60.00  
   800x600       60.32  
   720x576       50.00  
   720x480       59.94  
   640x480       59.94    59.93

 

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Lo he vuelto a repetir según estos comandos que me aportas shiva,

el comando nvidia-xconfig --composite --no-logo

crea un nuevo archivo xorg.conf en su carpeta /etc/X11

pero sigue sin surtir efecto al añadir la linea

 

aptitude install nvidia-xconfig
nvidia-xconfig --composite --no-logo

Compartir este post


Enlace al post
Compartir en otros sitios

Registra una cuenta o conéctate para comentar

Debes ser un miembro de la comunidad para dejar un comentario

Crear una cuenta

Regístrate en nuestra comunidad. ¡Es fácil!

Registrar una cuenta nueva

Iniciar Sesión

¿Ya tienes cuenta? Conéctate aquí.

Iniciar Sesión

×