Conéctate para seguir esto  
Seguidores 0
Shiba87

Libre
Facturascripts [Esp][x86 / x86_64] Facturación y contabilidad

6 posts en este tema

rkfiSkw.png

 

 

FacturaScripts aúna lo mejor de un software de las aplicaciones de facturación y de contabilidad en un mismo software consiguiendo una herramienta realmente sencilla.

Conforme haces los albaranes o las facturas de compra, das de alta el proveedor y añades los productos al catálogo. En el mismo proceso se calculan los precios de coste, también puedes asignar los precios de venta al momento. Y lo mismo con los albaranes o facturas de venta para que puedas centrarte sólo en tu negocio.

 
Facturascripts cuenta también con un amplio catálogo de plugins que permiten adaptar el software a nuestras necesidades o integrarlo con plataformas de ecommerce como PrestaShop o Woocommerce.
 

Además es muy fácil importar tus datos desde otros programas. Si usas Eneboo, es tan fácil como conectar a la misma base de datos y seguir trabajando con FacturaScripts. Si usas otros programas como FactuSol, puedes importar tus datos fácilmente con el plugin import_export_csv.

 

Y por último hay que hablar del futuro. No solamente es importante tener un buen programa de facturación y contabilidad hoy, también es importante que evolucione para que siga siendo bueno mañana. Y en eso destaca la comunidad de FacturaScripts, donde puedes resolver tus dudas, informar de errores y hacer sugerencias para nuevas versiones. Es sin duda un gran nexo de unión entre los usuarios, partners y programadores, que impulsan a FacturaScripts hacia un futuro prometedor.

  • Facturación y contabilidad en un mismo software.
  • Formularios sencillos con las opciones imprescindibles.
  • Accede desde cualquier sitio y con cualquier PC, tablet o smartphone.
  • Software libre: desarrollo colaborativo, seguro, máxima personalización.
  • Actualizaciones constantes.

 

Capturas

 

xBfaYOT.png

 

Vídeo

 

 

 

 

Descarga

 

Para poder ejecutar FacturaScripts solamente necesitamos Apache, PHP 5.3 o superior y MySQL o PostgreSQL.

 

MySQL:

 

Si deseamos usar MySQL, en una distribución Debian sólo habría que instalar los paquetes correspondientes

aptitude install php5 php5-cli php5-mysql php5-memcache mysql-server memcached

Crear una base de datos, por ejemplo: facturascripts.

mysql -h servidor -u root -p
CREATE DATABASE facturascripts;

PostgreSQL:

 

Si deseamos usar PostgreSQL, en una distribución Debian sólo habría que instalar los paquetes correspondientes

aptitude install php5 php5-cli php5-pgsql php5-memcache postgresql-server memcached

Configurar PostgreSQL

 

http://www.guia-ubuntu.com/index.php?title=PostgreSQL
Crear una base de datos, por ejemplo: facturascripts.

su - postgres createdb facturascripts

FacturaScripts:

 

Ahora sí, descargar la última versión de FacturaScripts
Copiar los archivos a la carpeta del apache /var/www
Modificar los permisos de la carpeta tmp, que es donde se añaden los archivos temporales:

chown -R www-data /var/www/facturascripts*/tmp

Acceder a FacturaScriptsdesde  http://localhost/facturascripts-0.9
Al acceder por primera vez, si todo ha ido bien, se crea un usuario admin cuya contraseña también es "admin", ponemos esta contraseña y entramos (No olvidar cambiarla inmediatamente).

 

Cron:

 

FacturaScripts necesita de un proceso cron para ciertas cosas. Así que deberías añadir un script en /etc/cron.hourly/ tal que así:

#!/bin/sh
cd /var/www/facturascripts
php cron.php
chown -R www-data tmp

https://www.facturascripts.com/comm3/index.php?page=community_item&id=370

 

Web

https://www.facturascripts.com/

https://github.com/NeoRazorX/facturascripts_2015

Rohlling, artiza, pacoeloyo y 5 otros le gusta esto

Compartir este post


Enlace al post
Compartir en otros sitios

Pues por alguna razón que no intuyo, no me va.

 

Cunado escribo desde la terminal:

 

mysql -h servidor -u root -p

 

La respuesta es:

 

ERROR 2005 (HY000): Unknown MySQL server host 'servidor' (0)

 

 

¿Alguna idea?

 

Creo que para acceder a mysql debes hacerlo con este comando:

mysql --user=root mysql -p

Te preguntará la password que le diste a tu usuario 'root'

 

Debería aparecerte una salida similar a esta:

Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 50
Server version: 5.5.44-0+deb8u1 (Debian)

Copyright (c) 2000, 2015, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

mysql>

A partir de ahí, el comando para crear tu base de datos:

mysql> CREATE DATABASE facturascripts;
pachel, Rohlling, Shiba87 y 1 otro le gusta esto

Compartir este post


Enlace al post
Compartir en otros sitios

 

Pues por alguna razón que no intuyo, no me va.

 

Cunado escribo desde la terminal:

 

mysql -h servidor -u root -p

 

La respuesta es:

 

ERROR 2005 (HY000): Unknown MySQL server host 'servidor' (0)

 

 

¿Alguna idea?

 

Creo que para acceder a mysql debes hacerlo con este comando:

mysql --user=root mysql -p

Te preguntará la password que le diste a tu usuario 'root'

 

Debería aparecerte una salida similar a esta:

Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 50
Server version: 5.5.44-0+deb8u1 (Debian)

Copyright (c) 2000, 2015, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

mysql>

A partir de ahí, el comando para crear tu base de datos:

mysql> CREATE DATABASE facturascripts;

Parece que funciona. Lo único que  si le pongo mi contraseña de root, me sale un mensaje de:

 

ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)

 

Si simplemente le doy a INTRO, entra y puedo crear la base de datos

Editado por pachel
Rohlling y pacoeloyo le gusta esto

Compartir este post


Enlace al post
Compartir en otros sitios

Registra una cuenta o conéctate para comentar

Debes ser un miembro de la comunidad para dejar un comentario

Crear una cuenta

Regístrate en nuestra comunidad. ¡Es fácil!


Registrar una cuenta nueva

Iniciar Sesión

¿Ya tienes cuenta? Conéctate aquí.


Iniciar Sesión
Conéctate para seguir esto  
Seguidores 0