Ir al contenido
  • 0
DubaRS

Eliminar programas. Soy novato

Pregunta

Hola a todos.

 

Soy novato en este mundo y espero que no os molesteis si hago preguntas muy tontas y obvias para vosotros.

 

He empezado en este mundo de la mano de Puppy Linux y sus variantes (Pupjibaro).

Voy a instalar este sistema en un equipo viejo (512MB) de casi 20años, que tienen mis padres en su casa. Tiene instalado el Windows XP y va muuuyy despacio (hasta desesperar), por eso no lo utilizan.

 

Como algunos programas que trae esta distribuicion, no los van a utilizar, pues los quiero quitar y que se quede todo lo más limpio y minimalista que se pueda.

¿Cuando elimino un programa se eliminan también los paquetes asociados y sus dependencias?

 

¿Cual es la mejor forma de eliminar un programa? ¿Por el administrador de paquetes?

 

Gracias por vuestra ayuda y recordar que soy novato y no entiendo del todo bien vuestra lengua ;). Pero estoy en ello :).

Compartir este post


Enlace al post
Compartir en otros sitios

28 respuestas a esta pregunta

Recommended Posts

  • 0

Uy la terminal, es como cuando te echas novi@ por primera vez, sabes lo que quieres conseguir pero no sabes por donde meter mano :D.

 

Me tengo que ir aprendiendo poco a poco ese codigo que tanto os gusta ;).

 

De momento lo haré graficamente y la consola lo dejo para cuando sepa, que soy muy manazas y todavía tengo mucho virus Windows (todo grafico) en el cuerpo.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Uy la terminal, es como cuando te echas novi@ por primera vez, sabes lo que quieres conseguir pero no sabes por donde meter mano :D.

 

..............

 

Me encanta, una comparacion muy ilustrativa :jajaja:

 

La mejor opcion para eliminar un programa es la que te dijo @@elmoyer, no es tan complicado añadirle el programa a eliminar al comando que te dio :ok:

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Uy la terminal, es como cuando te echas novi@ por primera vez, sabes lo que quieres conseguir pero no sabes por donde meter mano :D.

 

 

Pasado un tiempo es como la amiga que te llama para hacerte todo tipo de warreridas y acabas buscando el kamasutra para practicar todas las posturas :cejas:

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

 

Uy la terminal, es como cuando te echas novi@ por primera vez, sabes lo que quieres conseguir pero no sabes por donde meter mano :D.

Es la mejor definición que he leído sobre la terminal en el tiempo que estoy con gnu linux :jajaja: :jajaja:

Y para eliminar programas simplemente como te han dicho los compañeros, lo puedes hacer desde el gestor de paquetes o desde la terminal.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Bueno la verdad es que cuando le das un click a alguna opcion por ejemplo en synaptic " remoción total del paquete" se estara implementando la comunicación de un comando pero en modo grafico.

 

La terminal te va a ayudar un monton, ya lo veras.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Necesito una ayudita con una duda de novatillo que tengo.

 

Resulta que parece ser que tengo instalado el Gimp 2.6.12 y el 2.8.2 precise (este ultimo será para la Puppy linux que uso), eso me sale en el gestor de paquetes. Cuando abro Gimp se habre la 2.8.2 pero no sale todo en español, le faltan algunas cosas por traducir.

 

La versión 2.8.2 precise me la baje de una web de Puppy Linux, pero no venia en los repositorios que administra mi gestor de paquetes (tampoco he actualizado este).

 

¿Si hago un sudo apt-get --purge autoremove Gimp, me borra todo (las dos versiones)?

¿Si borro todo habrá otros programas que dejen de funcionar?

¿Es mejor siempre instalar los programas que salgan en el gestor de paquetes o se pueden bajar de las web de la comunidad de la distro?

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

mmm, creo que tienes un berenjenal de poca broma si no sabes manejarte con las paqueterías....

Recuerda, soy novato, soy propenso a los berenjenales .

 

Mi idea es desinstalar Gimp pero no se si afectará a otras aplicaciones. Para luego instalar de nuevo la que venga en los repositorios.

 

Os recuerdo que vengo de Windows, donde desinstalas una aplicación y dejan de funcionar otras tres .

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Tienes aptitude instalado? es un programa que funciona también como comando de terminal.  Suele resolver mejor las dependencias.  Con un aptitude purge gimp en principio limpiaría, pero según parece tienes 2 gimps instalados.  Prueba primero con el gestor gráfico a ver que pasa.  Elimina los archivos principales, seguramente limpiará las dependencias que no sirvan.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Ojo que con gimp se te pueden ir librerías GTK importantes dependiendo del entorno que lleve el puppy ese...y de quien lidie con esas dependencias y en ese caso yo también opinó que aptitudes será tu mejor aplicacion/comando

Salu2

Editado por Fransis

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

"Ojú, tu no sabes ande tas metío, killo" :jajaja:

 

Bueno ahora en serio, calma y buena letra, verás como le pillas el truki, ánimo apañero :ok:

 

Ya me voy dando cuenta donde me he metido  .

 

Me iba yo encontrando mejor con la consola, he ido mirando por internet los comandos que mas se usan y probando para aprendermelos, nos ibamos entendiendo. Hasta que he querido desinstalar el Gimp y al poner esto,"sudo apt-get --purge autoremove gimp", me he llevado el primer guantazo, "bash: apt-get: no se encontró la orden".

Oooño, si apt-get es el comando para instalar o desintalar cualquier cosa (Programas, actualizar, etc...) ¿no? Me he quedao planchao total. A ver si la metafora que he hecho de comparar la consola con una primera novia, va a ser mas real de lo que creía, vaya corte me ha pegao.

 

Yo pensaba que todas las distros de GNU/Linux usaban el mismo lenguaje (codigo de comandos), pero a lo mejor no es así. No se si dependerá de la consola que tengas, la de esta versión de Puppy Linux 5.7.1 (Pupjibaro 1.0.4) es la ROXTerm 1.22.2, no se si será por el Kernel que utilice, 3.2.48 en esta distro, yo solo se que no se nada.

 

Como no me funcionó por la consola desinstalé el Gimp 2.8.2 por el gestor de paquetes. Como hay una ventana donde te indica los paquetes que he instalado pues con pulsar en el Gimp se abre una ventana dandote la opción de desintalar, que es la que elegí. Pero hay paquetes o dependencias que no se desinstalaron, porque lo fuí a instalar de nuevo, haciendo una busqueda en el gestor de paquetes y cuando lo encuentro me pone que ya está instalado "(Already Installed)". Pincho para instalar y me cuenta que se va a instalar pero que ya están las dependencias instaladas :blink: .

Sabeis lo que es estar perdido ¿no? pues yo estoy lo siguiente :confused: .

 

Solo os tengo a vosotros para aclararme un poco, porque buscando por internet de momento no saco nada en claro.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

 Bueno,  yo no soy precisamente el más entendido, pero expongo un concepto, y si estoy equivocado que me corrijan.

 

 En windows, un programa lleva metido todo lo necesario, "dependencias incluídas", cuando lo instalas te crea un directorio con toda la morralla junta, si instalas otro programa, te hace lo mismo, con lo cual repites "archivos" y el registro se resiente.

 En GNU/Linux las dependencias se comparten, hay directorios específicos para ellas, y Gimp puede compartir ciertas librerías con otros paquetes (programas), por lo que, en ciertos casos, no es imprescindible borrar todo.

 

Si tienes dos versiones de Gimp instaladas, desde el gestor deberías "atinar" a eliminar una de ellas. Pero bueno, mejor te explican los compañeros mas avanzados en estas lides que yo :hmmm:

 

Pd- Al menos te avisa de que las va a eliminar, en Slackware no te dice nada, y luego te dejan de funcionar otras aplicaciones justo cuando mas las necesitas :roc::icon_ouch:  :D


¡Ah! y para usar apt-get, tienes que ser root, o te logueas con "su" o pones sudo apt-get.... creo que te pasa algo de eso. (Edito, fallo mio en esto, Eduardo lo explica mucho mejor justo aquí debajo)

Editado por rafacbf

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

¡Hombre! apt-get no deja de ser un programa por muy de la consola que sea. Si no está instalado será porque tienes instalado aptitude (digo yo).

Y, si no, pues instala apt-get desde el gestor de paquetes si puedes.

 

Saludos

 

P.D.: RECTIFICO según leo por ahí, no se puede instalar por consola. Por lo visto solo se puede usar el gestor de paquetes de Puppy.

Editado por Eduardo

Compartir este post


Enlace al post
Compartir en otros sitios

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invitado
Responder esta pregunta...

×   Has incluido contenido con formato.   Eliminar formato

  Sólo se permiten 75 emoticonos como máximo.

×   Tu enlace ha sido insertado automáticamente.   Deshacer y mostrar como enlace

×   Su contenido anterior ha sido restaurado.   Limpiar editor

×   No puedes pegar imágenes directamente. Súbelas a algún hosting de imágenes y pega la dirección URL


×
×
  • Crear Nuevo...