Ir al contenido
Gnu/Linux Vagos
  • 0
Conéctate para seguir esto  
ice

Consutla sobre dependencias en Debian SID

Pregunta

Buenas noches papilos, los vengo a molestar... con la siguiente consulta.

Resulta que una noche actualizando el sistema, me di cuenta que no tenía más gdm3 ni mi amado gnome-shell 3.16 jaja, esta bién lo admito, estaba usando cinnamon-2.6.13 muy lindo por cierto, pero bueno, justo quería volver a usar gnome y me di cuenta que no está y me figura ésto cuando intento instalar. Alguno me puede orientar o decirme como se repara ésto o debo esperar? a qué? nosé? jaja

 

0nAGDo3.png

 

Un abrazo y gracias por su tiempo!

Compartir este post


Enlace al post
Compartir en otros sitios

17 respuestas a esta pregunta

Recommended Posts

  • 0

y un día como hoy actualizaron todo y sin romperme la cabeza con dependencias, se actualizaron paquetes y ahora volví con mi amado Gnome-Shell :D

 

Ega731S.png

 

53BWhJs.png

 

Sólo era cuestión de paciencia que los devs actualicen ;) Pueden cerrar si quieren.

Editado por ice

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Eso aptitude lo resuelve. O nos mata a todos, una de dos :silba:

si, eso con aptitude seguro que te empieza a decir que paquetes son los que tienes "rotos" y estan arrastrandose por el sistema. luego es cuestion de ir tirando del hilo...

al principio me pintaban muy feo esto de las dependencias, en muchos sitios lo he oido como "el infierno de las dependencias", a mi me ha acabado resultando entretenido. con plasma5 he tenido que "corregir" a mano un monton de dependencias, que no ha sido mas que ir purgando con aptitude, y luego dejar que me instale los correctos desde la paqueteria. pero aptitude siempre te dira lo que esta molestando y debes de corregir. (apt-get es solo para emergencias, o porque aptitude no te funcione...xD)

salu2

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Eso aptitude lo resuelve. O nos mata a todos, una de dos :silba:

 

 

 

Eso aptitude lo resuelve. O nos mata a todos, una de dos :silba:

si, eso con aptitude seguro que te empieza a decir que paquetes son los que tienes "rotos" y estan arrastrandose por el sistema. luego es cuestion de ir tirando del hilo...

al principio me pintaban muy feo esto de las dependencias, en muchos sitios lo he oido como "el infierno de las dependencias", a mi me ha acabado resultando entretenido. con plasma5 he tenido que "corregir" a mano un monton de dependencias, que no ha sido mas que ir purgando con aptitude, y luego dejar que me instale los correctos desde la paqueteria. pero aptitude siempre te dira lo que esta molestando y debes de corregir. (apt-get es solo para emergencias, o porque aptitude no te funcione...xD)

salu2

 

 

bien tiren la respuesta de como :P

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

 

¿

aptitude install gnome-shell
?

 

no pasa na-da

 

NedgEJ3.png

Editado por ice

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Coñe, que le has dado que "sí" a la opción de no hacer nada :sweat:

 

Te tiene que decir qué falla exactamente y, según le vayas pidiendo, ofrecerte opciones. Puedes empezar de a poquito, paquete a paquete o dejar que aptitude busque alternativas (n) hasta que llegues a una que sea viable.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Coñe, que le has dado que "sí" a la opción de no hacer nada :sweat:

 

Te tiene que decir qué falla exactamente y, según le vayas pidiendo, ofrecerte opciones. Puedes empezar de a poquito, paquete a paquete o dejar que aptitude busque alternativas (n) hasta que llegues a una que sea viable.

pero si tiro una "n" me dice que no hay mas soluciones disponibles. si toco la y, no hace nada tampoco, si la q para salir y nada más. :(

Editado por ice

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

ni idea ni idea...con la informacion que sale en tu terminal.... por ahi tienes un problema de dependencias casi seguro, y probablemente sea una o 2, que el aptitude no te las esta pillando.

dado que cinnamon es un "fork" de gnome-shell, utiliza muchas de sus librerias, quiza la solucion mas rapida y facil tambien pase por desinstalar cinnamon al completo, y luego instalar gnome, o el entorno que quieras. pues puede que alguna libreria de cinnamon te este ocasionando ese problemilla.

un saludo

Editado por Fransis

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Paquete a paquete, centrándose en los que están generando el problema. Si no no hay manera :sweat:

Como seria, tratar de instalar paquete por paquete hasta encontrar?

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

No se si lo que voy a decir es lo mismo que dice Shiba, pero te explico que hago yo.  Cuando aptitude te señala los problemas de dependencias, pruebo a instalarlos uno a uno o bien buscarlos, descargarlos e instalarlos digamos de forma manual.  Para buscarlos y descargarlos me meto AQUI (el enlace es a sid para ti).  Si alguno de los que intento instalar me da más problemas de dependencias, busco esos otros archivos... y así sucesivamente.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

a veces juego a que me descargo por error la versión que no toca :jojojo:

jajaja, si basicamente creo que es lo que hacemos todos. pero como dice shiba, yo no descargo a mano el paquete, descargo a mano pero de repositorio, que a veces puede ser testing, o en el caso reciente de mi grafica, de la rama experimental. pero si, normalmente mis problemas con dependencias suelen ser versiones diferentes de paquetes y la mejor solucion es ir uno por uno, porque si no aptitude muchas veces ni se entera de los errores, y cuando le metes un paquete solo, de repente te dice que tiene no se cuantos paquetes mas, que no corresponden con la version.

lo suyo seria que el mismo te propusiese bajar de version esos paquetes o actualizarlos ( a veces lo hace), otras veces directamente solo te dice (tururu, que tienes estos paquetes en l a version XXXX y no voy hacer nada), y se queda tan ancho, pero bueno. una vez le pillas el truco a lidiar con aptitude, es muy sencillito y es como el ojo de shauron, al final lo acaba viendo todo y queda bastante limpito.

si no tambien lo que puedes probar, es synaptic, y entra en el filtro "roto" a ver si te sale algo, o el filtro "recomendaciones perfidas".

salu2

Compartir este post


Enlace al post
Compartir en otros sitios

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invitado
Responder esta pregunta...

×   Has incluido contenido con formato.   Eliminar formato

  Sólo se permiten 75 emoticonos como máximo.

×   Tu enlace ha sido insertado automáticamente.   Deshacer y mostrar como enlace

×   Su contenido anterior ha sido restaurado.   Limpiar editor

×   No puedes pegar imágenes directamente. Súbelas a algún hosting de imágenes y pega la dirección URL

Conéctate para seguir esto  

×
×
  • Crear Nuevo...