Ir al contenido
  • 0
Conéctate para seguir esto  
artiza

Algo salió mal (gnome 3) [resuelto]

Pregunta

Hola a todos.

 

Por una serie de (penosas) circunstancias, no me queda más remedio que rebajar mi instalacion de 64 a 32. CUPS tiene la culpa: no puedo imprimir en red salvo que la impresora esté conectada a un pc y sólo a través de samba. Esto me produce cierta demora para imprimir y, además, resulta que esa única impresora es la más saturada. Pero como, aunque algo pardillo, sigo el lema «si funciona, no lo toques», he preferido hacer el proceso en mi «mártir» (o mio portátil) no vaya a ser que la cosa empeore en lugar de arreglarse.

 

Ya tengo instalado debian testing 32 en el portátil y todo funciona razonablemente bien (conservo mi home)... salvo que gnome me recibe con el pantallazo:

ALGO SALIÓ MAL

Ocurrió un problema y el sistema no se puede recuperar.

Cierre la sesión e inténtelo de nuevo.

Pero no fue justo después de la instalación. Algo se debió corromper después del tercer o cuarto re-inicio. Por error, en lugar de pulsar ctrl-alt-F1 pulsé alt-F4 y voilà, escritorio gráfico levantado. O sea, sin aviso de reinicio de sesión.

 

He probado borrar .gconf .gnome2 .gnome2_private .config/monitor.xml y algunos más que no recuerdo con la esperanza de que se reparen volviendo a todo por defecto, pero con ningún éxito.

 

También he reconfigurado xserver-xorg, por si acaso. Nada

 

He intentado también [# gconftool-2 --recursive-unset /] y no me ha dejado. Me dice lo siguiente:

 

(gconftool-2:8742): GConf-WARNING **: Client failed to connect to the D-BUS daemon:

Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Error al eliminar la asignación recursivamente «/»: El demonio de D-Bus no está en ejecución

 

(gconftool-2:8742): GConf-WARNING **: Client failed to connect to the D-BUS daemon:

Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Creo que las gtk tienen algo que ver puesto que tengo un precioso archivito llamado .xsession-errors lleno de advertencias (142,7 kB), para mí incomprensibles.

 

Por eso recurro a alguna alma caritativa que se apiade de mi desgracia. Estoy seguro que es algo muy sencillo, pero no sé dar con ello. Como, por otra parte, con alt-F4 cierro la advertencia horrible y todo funciona... No sé si pensar en si a mi portátil le quedan horas de vida, o de si es un error menor que puede llevar a algo mayor. O qué.

 

Por otra parte, no me importaría reinstalar de nuevo. Aunque quizá sea algo que esté en mi home, con lo que nada adelanto... ¿salvo que cree otro usuario?

 

Gracias por vuestra atención.

Editado por artiza

Compartir este post


Enlace al post
Compartir en otros sitios

8 respuestas a esta pregunta

Recommended Posts

  • 0

Gracias por tu respuesta.

 

Es verdad, si tuviera nVidia o ATI me las tendría tiesas... Pero creo que la cosa no va por ahí. He creado otro usuario y todo ha vuelto a su ser. O sea que debe de haber algo incompatible que se queda en la home cuando se pasa de una distro de 64 a otra de 32. En mi caso, no pierdo mucho. Me basta con copiar y pegar lo que me interese, reconstruir y reconfigurar lo que tenía, y a seguir disfrutando.

 

Creo que debería dar el tema por solucionado porque a lo mejor no merece la pena el esfuerzo de buscar el archivo que genera el conflicto si basta con crear otro usuario. O sea, se aplica el principio de importancia relativa (el beneficio no superará nunca el coste) y asunto resuelto.

 

De nuevo, muchas gracias por tu ayuda.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Hola eMix. Se me olvidó ponerlo. La gráfica que uso es:

 

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 0c)

00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (secondary) (rev 0c)

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Pues no se que decir, con el portatil que tambien tengo una Intel integrada no he tenido nunca un problema (cruzo dedos) el sobremesa con la nvidia es el que me lleva de cabeza y lo que te decia anteriormente ayer justamente debido a una actualizacion de paquetes xorg no me iniciaba gnome3, me iniciaba en classic, saltaba un error del cairo-dock diciendome que activara el OpenGL, al activarlo ya ni siquiera arrancaba volvia directamente al login saliendo antes el cartelito que tu mencionasde "Algo salio mal..... etc....." en mi caso al desinstalar completamente cairo-dock (pensaba que era el problema) me volvio a permitir abrir sesion otra vez en classic y al realizarle un "glxgears" en el terminal salio el por que daba error y no reconocia datos ningunos, entonces recorde la actualizacion de los paquetes xorg, reinstale los drivers nvidia y otra vez a funcionar :)

 

Por eso te decia que instalaras o reinstalaras los drivers de tu grafica por si venia por ahi el problema :D

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Las configuraciones de gnome2 en gnome3 no sirven de mucho :sweat:

 

No hace falta que crees un nuevo usuario, simplemente quita los archivos de configuración de tu home y ya está, el problema viene de "algo" que hace uso de aceleración gráfica o composición que ahora ya no tienes, transparencias, docks, efectos.... algo así.

 

Para salir de dudas:

glxinfo | grep rendering

Si la respuesta es NO, es la gráfica, si la respuesta es YES, el problema es uno de los archivos de configuración, aunque no sepamos cual :P

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Gracias por vuestra paciencia e interés.

 

Me pasé dos días buscando el p**o archivo (o archivos) que pudiera ser la causa. El usuario lo pienso dejar vivo para el enrede subsiguiente.

 

Incluso pensé en cambiar de escritorio, dudando entre kde y xfce. Pero me acordé de que hay algunas dependencias con gnome y a lo mejor la cosa empeoraba. Reinstalar tampoco iba a solucionar (casi) nada, porque el usuario no iba a cambiar mucho. Soy un vago redomado y casi siempre empiezo por el método de eliminación selectiva. Así que opté por lo fácil, cambiar de usuario a ver si la cosa pitaba.

 

Además, el mártir es réplica de mi pc del trabajo salvo por algunas cosillas personales: el típico vídeo en tanga bailando la macarena, o ese otro con el traje de neopreno fucsia (que todo el mundo tiene) en al karaoke cantando los pajaritos...

 

Lo que sí lamento es haberme precipitado en haber abierto el hilo sin haber probado primero esta solución. Sé que no lo es, porque sólo he resuelto la incomodidad de tener el escritorio desmejorado, pero tengo pensado empezar por analizar en paralelo los resultados del dconf en ambos usuarios a ver si encuentro algo, y así directorio a directorio, archivillo a archivillo. Por ejemplo el .xsession-errors, que lo acabo de ver y dice un montón de cosas feas tipo "warning... this shouldn't be happen!" (ay, madre).

 

Las configuraciones de gnome2 en gnome3 no sirven de mucho :sweat:

 

No hace falta que crees un nuevo usuario, simplemente quita los archivos de configuración de tu home y ya está, el problema viene de "algo" que hace uso de aceleración gráfica o composición que ahora ya no tienes, transparencias, docks, efectos.... algo así.

 

Para salir de dudas:


glxinfo | grep rendering

Si la respuesta es NO, es la gráfica, si la respuesta es YES, el problema es uno de los archivos de configuración, aunque no sepamos cual :P

 

 

Y la respuesta fue YES. Pues ya tengo el bricolage de este fin de semana.

 

Si encuentro algo os lo haré saber.

Editado por artiza

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Bien, me puese a «leer» el .archivo .xsession-errors de mi prfil/usuario conflictivo. Como era de esperar, no entendí nada. Hace referencia a (casi) todo lo que sucede en la sesión gráfica (creo) y era, para mí, demasiada información.

 

Todos estos pasos los he realizado desde el usuario alternativo creado para evitar el entorno gráfico gnome 3 inestable del usuario conflictivo después de instalar Debian 32 sustituyendo a Debian 64 manteniendo la home original.

 

Como dijo Shiba87, debía ser un archivo de configuración. Desde el otro usuario me logueé como mi usuario conflictivo y, siendo un vago inmenso, abrí nautilus mediante el comando gksu: (alt+F2) gksu --> nautilus

 

Me fui hasta la carpeta /home/(usuario_conflictivo)/.config/dconf y copié el archivo user y lo renombré como user.old

 

Borré el archivo user.

 

Salí de mi usuario no problemático y accedí a mi usuario conflictivo mediante «Cerrar sesión».

 

Todo volvió a quedar por defecto: se crea un nuevo archivo user y asunto solucionado.

 

De nuevo, muchas gracias por las sugerencias, todas acertadas.

 

Inter nos, ahora dejaré el usuario que ha dejado de ser conflictivo para convertirlo en el usuario mártir http://gnulinuxvagos.es/public/style_emoticons/default/devil.gif

Compartir este post


Enlace al post
Compartir en otros sitios

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invitado
Responder esta pregunta...

×   Has incluido contenido con formato.   Eliminar formato

  Sólo se permiten 75 emoticonos como máximo.

×   Tu enlace ha sido insertado automáticamente.   Deshacer y mostrar como enlace

×   Su contenido anterior ha sido restaurado.   Limpiar editor

×   No puedes pegar imágenes directamente. Súbelas a algún hosting de imágenes y pega la dirección URL

Conéctate para seguir esto  

×
×
  • Crear Nuevo...