Ir al contenido
  • 0
Conéctate para seguir esto  
DarkCr0ss

Problemas con wifi

Pregunta

Buenas, tengo un pequeño problema con las redes wifi, me conecto y todo bien excepto porque me quedo sin conexión internet aunque este conectado y tengo que apagar y prender el wifi de la laptop para volver a tener conexión a internet. Personalmente creo que tiene que ver con el kernel debido a que cuando estaba usando debian-sources(en gentoo), me funcionaba bien pero ahora que estoy usando los vanilla-sources me da ese problema con la misma configuración.

 

Información que puede ser util para resolver el problema:

Driver del adaptador wifi: rtl8192ce

Version del kernel: vanilla-sources 3.14.3

dmesg: http://bpaste.net/show/262382/

emerge --info: http://bpaste.net/show/262399/

kernel .config: http://bpaste.net/show/262400/

 

Si necesitan mas información no duden en pedirla.

 

Gracias de antemano

Compartir este post


Enlace al post
Compartir en otros sitios

7 respuestas a esta pregunta

Recommended Posts

  • 0

Seguramente te pase tras un rato con la wifi inactiva. Entra en modo ahorro y no vuelve a cargar.

Prueba con esto:

Creamos el archivo rtl8192ce.conf

sudo nano /etc/modprobe.d/rtl8192ce.conf 

Y ponemos lo siguiente:

# Desactivar ahorro energia 
options rtl8192ce ips=0
# Desactivar control por HW 
options rtl8192ce fwlps=0
# Activar control por SW 
options rtl8192ce swlps=1

SI no te gusta nano puedes usar el editor que prefieras :P ahora reinicia y debería dejar de entrar en modo ahorro, y si entra al suspender el equipo por ejemplo, debería poder salir de el al estar controlado por software.

 

Un saludo

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

EDITO Vale, primero lo del loco de arriba y luego ya si eso nos liamos la manta a la cabeza :jojojo:

 

Bueno... dentro de lo malo sabemos que podemos volver a una versión de Linux en la que sí funcionaban las cosas.

 

Mientras probemos a compilar los controladores para esa versión concreta a través de backports (A.KA compat-wireless (AkA compat-drivers ))

wget https://www.kernel.org/pub/linux/kernel/projects/backports/stable/v3.14/backports-3.14-1.tar.xz
tar xvf backports-3.14-1.tar.xz
cd backports-3.14-1
make defconfig rtlwifi
sudo make install
modprobe -r rtl8192ce
modprobe rtl8192ce
Editado por Shiba87
Jodíos ninjas....

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Seguramente te pase tras un rato con la wifi inactiva. Entra en modo ahorro y no vuelve a cargar.

Prueba con esto:

Creamos el archivo rtl8192ce.conf

sudo nano /etc/modprobe.d/rtl8192ce.conf 

Y ponemos lo siguiente:

# Desactivar ahorro energia 
options rtl8192ce ips=0
# Desactivar control por HW 
options rtl8192ce fwlps=0
# Activar control por SW 
options rtl8192ce swlps=1

SI no te gusta nano puedes usar el editor que prefieras :P ahora reinicia y debería dejar de entrar en modo ahorro, y si entra al suspender el equipo por ejemplo, debería poder salir de el al estar controlado por software.

 

Un saludo

si uso este método tengo que cargar el controlador(rtl8192ce) como modulo en vez de tenerlo incrustado al kernel?

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

1º Todo lo que no sea necesario para el arranque en sí deberías meterlo como módulo, el kernel se hace más ligero y carga más rápido además de evitarte problemas.

2º Debería de funcionar ya que primero te cargará un initramfs con la configuración antes de cargar el kernel (si no estás tan loco como yo que arranco sin initramfs para ahorrar tiempo xD).

:ph34r:

Editado por WiLLiTo
ninja pawah!!

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Bueno voy a probar un rato a ver si me funciono.(Llegue a probar iniciar sin initramfs también pero me iniciaba a la misma velocidad así que mejor lo deje con el)

Depende mucho de la máquina, en ordenadores viejos se nota un motón (un athlon xp que tengo de pruebas)

Compartir este post


Enlace al post
Compartir en otros sitios

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invitado
Responder esta pregunta...

×   Has incluido contenido con formato.   Eliminar formato

  Sólo se permiten 75 emoticonos como máximo.

×   Tu enlace ha sido insertado automáticamente.   Deshacer y mostrar como enlace

×   Su contenido anterior ha sido restaurado.   Limpiar editor

×   No puedes pegar imágenes directamente. Súbelas a algún hosting de imágenes y pega la dirección URL

Conéctate para seguir esto  

×
×
  • Crear Nuevo...