Ir al contenido
Conéctate para seguir esto  
Shiba87

"Solución" temporal a los problemas gráficos en dispositivos "Inari" con Firefox OS 1.3 y 1.4

Recommended Posts

f5YoFHg.jpg

 

Para los osados que se encuentren ahora mismo probando las versiones en desarrollo de Firefox OS en algún terminal "inari", entre los que está el ZTE Open, seguramente se hayan topado una regresión bastante molesta surgida en la versión 1.4 y que ha pasado inadvertida hasta que ha entrado posteriormente en la versión 1.3 donde ha causado más de un dolor de cabeza.

 

El bug en cuestión  provoca una serie de "pantallazos blancos" a la hora de iniciar cualquier aplicación, abrir algún menú o en cualquier desplazamiento por la pantalla o, directamente hacen que el entorno gráfico se venga abajo provocando un reinicio tras otro de la interfaz.

 

El problema, según se comenta en bugzilla, es debido a los últimos cambios del HWComposer y/o algún conflicto con los controladores gráficos del ZTE.

 

La forma más sencilla de prevenir este mal hasta que el parche sea incluido en una de las próximas actualizaciones es a través del menú de ajustes, deshabilitando el "Hardware composer":

Ajustes -> Información -> Más Información -> Desarrollador -> Enable hardware composer

kQVRqES.png

 

Pero claro, si ya hemos actualizado y sin poder ver lo que ocurre en pantalla o sufriendo continuos reinicio ¿Cómo llegamos hasta ese menú?

En este caso tendremos que llevar a cabo una pequeña chapuza previa para dejar fuera de juego el compositor. Para ello nos valdremos, una vez más, de ADB

adb shell mv /system/lib/hw/hwcomposer.msm7627a.so /system/lib/hw/hwcomposer.msm7627a.s_

Como ven lo único que hemos hecho ha sido cambiar el nombre de la librería correspondiente al compositor dejándolo, momentáneamente, fuera de juego.

Ahora, tras reiniciar el dispositivo, veremos que todo ha vuelto a la normalidad y podremos acceder al menú de ajustes para deshabilitar por fin el hwcomposer.

 

Luego desharemos la chapuza, no vaya a ser que alguien la vea :silba:

adb shell mv /system/lib/hw/hwcomposer.msm7627a.s_ /system/lib/hw/hwcomposer.msm7627a.so

Aunque no es habitual, este tipo de cosas son las que pueden ocurrir por arriesgarse con versiones en desarrollo. Nada que no se resuelva con una pequeña búsqueda y trasteando un poco :manos:

 

https://bugzilla.mozilla.org/show_bug.cgi?id=952916

Compartir este post


Enlace al post
Compartir en otros sitios

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invitado
Responder en este tema...

×   Has incluido contenido con formato.   Eliminar formato

  Sólo se permiten 75 emoticonos como máximo.

×   Tu enlace ha sido insertado automáticamente.   Deshacer y mostrar como enlace

×   Su contenido anterior ha sido restaurado.   Limpiar editor

×   No puedes pegar imágenes directamente. Súbelas a algún hosting de imágenes y pega la dirección URL

Conéctate para seguir esto  

×
×
  • Crear Nuevo...