Ir al contenido
  • 0
Conéctate para seguir esto  
xXFacusXx

Problema, placa de wifi interna!!

Pregunta

Hola compañeros, como estan?

Esta vez vengo un pequeño gran problema jeje

 

El asunto es que no puedo instalar los drivers de la placa de WiFi de mi notebook, me salen unos errores y me frena la instalacion, les paso a comentar..

 

La placa que tengo es esta:

 

Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)

 

La distro: Linux Mint 15 Cinnamon

 

Bien, yo lo que hago es descargar los drivers de http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=48&PFid=48&Level=5&Conn=4&DownTypeID=3&GetDown=false&Downloads=true#RTL8188CE

 

Luego los descomprimo y entro a la carpeta como root a travez del terminal, luego digito esta linea:

make install

Luego de hacer esto, recibo este error:

make -C /lib/modules/3.8.0-19-generic/build M=/home/xxfacusxx/Descargas/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013 modules
make[1]: Entering directory `/usr/src/linux-headers-3.8.0-19-generic'
  CC [M]  /home/xxfacusxx/Descargas/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013/base.o
In file included from /home/xxfacusxx/Descargas/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013/base.c:39:0:
/home/xxfacusxx/Descargas/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013/pci.h:247:15: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘rtl_pci_probe’
make[2]: *** [/home/xxfacusxx/Descargas/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013/base.o] Error 1
make[1]: *** [_module_/home/xxfacusxx/Descargas/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.8.0-19-generic'
make: *** [all] Error 2

Antes usaba estos drivers en Mint 13 mate, y me corrian bien. Luego actualice el kernel en esta distro, instalandome el 3.2 y me iba bien tambien. Ahora con mint 15 con el kernel 3.8 no quiere irme, me conecta unos segundos y luego ya no conecta mas!! :(

 

Pensaba en compilar un kernel anterior o no se ya que hacer.. a ver si me pueden ayudar.

 

Desde ya muchas gracias.

Compartir este post


Enlace al post
Compartir en otros sitios

23 respuestas a esta pregunta

Recommended Posts

  • 0

Bien, olviden mi pregunta anterior.. ya instale una version de Debian de 64 bits testing, cuya version trae kernel 3.10, instale los drivers oficiales de debian para mi placa de wifi:

aptitude install firmware-realtek

Y de momento va bien, por ahi se laguea un poco pero el internet va.
Lo unico que voy a tener que buscar otros repositorios, porque los que he seleccionado son super lentos, pero eso ya es otra cosa.

 

Muchas gracias por todo y por la paciencia.

Se puede dar por SOLUCIONADO el tema.

Saludos.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Los controladores Realtek son los que están mal, no el kernel. Parece ser un bug bastante común.

 

Sería cuestión de probar con los compat-drivers:

 

 

wget https://www.kernel.org/pub/linux/kernel/projects/backports/stable/v3.8.3/compat-drivers-3.8.3-2-snpu.tar.xz
tar xvf compat-drivers-3.8.3-2-snpu.tar.xz
cd compat-drivers-3.8.3-2-snpu
make
sudo make install
sudo make unload

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

 

Los controladores Realtek son los que están mal, no el kernel. Parece ser un bug bastante común.

 

Sería cuestión de probar con los compat-drivers:

 

wget https://www.kernel.org/pub/linux/kernel/projects/backports/stable/v3.8.3/compat-drivers-3.8.3-2-snpu.tar.xztar xvf compat-drivers-3.8.3-2-snpu.tar.xzcd compat-drivers-3.8.3-2-snpumakesudo make installsudo make unload

Muchas gracias compi.. te cuento acabo de hacer lo que me indicas y me sale esto al final y me frena la instalacion:

 

make[1]: Leaving directory `/usr/src/linux-headers-3.8.0-19-generic'
No se porque no me deja entrar a ese directorio.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

En esa línea simplemente informa que está "saliendo" del directorio, no tiene mayor importancia.

Aparte que para salir en algún momento tuvo que entrar, vamos, digo yo :P

 

Si compila sin errores sólo queda instalar y comprobar si el módulo funciona

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

En esa línea simplemente informa que está "saliendo" del directorio, no tiene mayor importancia.

Aparte que para salir en algún momento tuvo que entrar, vamos, digo yo :P

 

Si compila sin errores sólo queda instalar y comprobar si el módulo funciona

jajaja si claro.. perdon jaja estoy medio dormido (recien me levanto) y soy un poco duro con el ingles jeje

 

Compilo sin errores, la instale y reinicie, no quiso ir.. o sea, conecta unos segundos y luego ya no va.

 

 

EDITO:

 

he intentado de nuevo, al darle a sudo make unload, supuestamente me inicia los drivers, verdad? bueno, cuando hago esto pierdo la conexion wifi, quiero decir, ahora la tengo con el cable, pero cuando le doy a el comando antes mensionado, no me deja usar el wifi al desconectar el cable.

Editado por xXFacusXx

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

A ver si le damos un empujoncito:

 

 

sudo modprobe rtl8192ce

 

En caso de funcionar, para que se cargue siempre durante el arranque:

 

echo 'rtl8192ce' | sudo tee -a /etc/modules

 

También podría ser que lo que falle es el administrador de redes y nos estemos rompiendo la cabeza con los controladores, no sería la primera vez :jojojo:

intenta también conectando mediante wicd

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

A ver si le damos un empujoncito:

sudo modprobe rtl8192ce

En caso de funcionar, para que se cargue siempre durante el arranque:

echo 'rtl8192ce' | sudo tee -a /etc/modules

También podría ser que lo que falle es el administrador de redes y nos estemos rompiendo la cabeza con los controladores, no sería la primera vez :jojojo:

intenta también conectando mediante wicd

Bien compi te cuento..

 

Al ejecutar este comando:

sudo modprobe rtl8192ce

me tomo bien el wifi y me dejo conectarme, pero solo unos segundos y despues se corto.

 

Acudi a instalar WICD como me has dicho y desintalando Network Manager, luego de esto, me lleve una sorpresa al reiniciar, me salian errores y no tenia red de ningun tipo jajaja

Buscando encontre esto:

    rm /etc/resolv.conf
    ln -s /run/resolvconf/resolv.conf
    rm /var/lib/wicd/resolv.conf.orig
    ln -s /run/resolvconf/resolv.conf /var/lib/wicd/resolv.conf.orig

Con esas lineas ya me salia la interfaz de WICD y pude configurar para conectarme. Ahora bien, conecta al wifi, pero tambien unos segundos, tambien probe iniciar el drivers con la linea que me diste antes la del "empujonsito" y lo mismo.

 

Segui investigando lo de los drivers originales de realtek y es problema de una incompatibilidad con el kernel 3.8, para unas versiones anteriores dicen que hay que agregar un " = " en una linea de un archivo que tiene adentro (un header), con lo que lo probe tambien y me exploto la instalacion.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Está complicadilla la cosa. Es lo que tiene tirar de versiones inestables, que luego toca sufrir :jojojo:

 

Sólo se me ocurre desactualizar Linux hasta que a Realtek le de por actualizar el controlador para nuevas versiones del Kernel. Y ya como "ideal" estaría el mantenerse en un distribución estable o al menos con bastante soporte :P

 

Una prueba así un poco por las bravas:

 

x86

 

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2-precise/linux-headers-3.2.0-030200-generic-pae_3.2.0-030200.201201042035_i386.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2-precise/linux-image-3.2.0-030200-generic-pae_3.2.0-030200.201201042035_i386.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2-precise/linux-headers-3.2.0-030200_3.2.0-030200.201201042035_all.deb
sudo dpkg -i linux-image* linux-headers*

 

x86_64

 

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2-precise/linux-headers-3.2.0-030200-generic_3.2.0-030200.201201042035_amd64.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2-precise/linux-image-3.2.0-030200-generic_3.2.0-030200.201201042035_amd64.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2-precise/linux-headers-3.2.0-030200_3.2.0-030200.201201042035_all.deb
sudo dpkg -i linux-image* linux-headers*

 

Reinicia con el kernel 3.2 y veamos si se puede o no se puede

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Está complicadilla la cosa. Es lo que tiene tirar de versiones inestables, que luego toca sufrir :jojojo:

 

Sólo se me ocurre desactualizar Linux hasta que a Realtek le de por actualizar el controlador para nuevas versiones del Kernel. Y ya como "ideal" estaría el mantenerse en un distribución estable o al menos con bastante soporte :P

 

Una prueba así un poco por las bravas:

 

x86

 

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2-precise/linux-headers-3.2.0-030200-generic-pae_3.2.0-030200.201201042035_i386.debwget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2-precise/linux-image-3.2.0-030200-generic-pae_3.2.0-030200.201201042035_i386.debwget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2-precise/linux-headers-3.2.0-030200_3.2.0-030200.201201042035_all.debsudo dpkg -i linux-image* linux-headers*
 

x86_64

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2-precise/linux-headers-3.2.0-030200-generic_3.2.0-030200.201201042035_amd64.debwget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2-precise/linux-image-3.2.0-030200-generic_3.2.0-030200.201201042035_amd64.debwget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2-precise/linux-headers-3.2.0-030200_3.2.0-030200.201201042035_all.debsudo dpkg -i linux-image* linux-headers*
 

Reinicia con el kernel 3.2 y veamos si se puede o no se puede

Perfecto compi, instalando los drivers oficiales de realtek iniciando con el kernel 3.2 e inicializando rtl8192ce corre bien, incluso ahora marca la intensidad de la señal. Aun asi, de vez en cuando se me reinicia la conexion, pero ya corre.

 

Creo que me cambiare a una version estable como dices, ya con lo que me has ayudado tengo muchas mas herramientas para poder darle pelea al wifi.. y este gestor de redes que me has dicho, creo que es mas estable que el network controller, por lo que probare de usar este.

 

Ahora mismo voy a descargar vuestra distro y a probar como me va la red con ella.. sino volvere al Mint Maya que me iba bien, pero la lie hace un tiempo con el archivo de configuracion de kde y no me dejaba cambiarlo por el de otra interfaz ni nada y al momento de instalar algunas aplicaciones me explotaba. jeje eso es por meter mano donde no debo, pero si no rompo no aprendo jajajaja

 

Muchas gracias compi, de verdad, por la ayuda y por la paciencia!! :)

Ya te contare como termino.

 

ANEXO:

 

Pude instalar los drivers en el kernel 3.8 añadiendo estas lineas:

#ifndef __devinit
#define __devinit
#define __devinitdata
#endif
en el archivo: pci.h

 

Y aun asi, no iba bien.

 

En fin, a descargar y probar su distro que esteticamente se ve hermosa, a ver que tal va!! :)

 

Saludos.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Jeje me dieron ganas de probarlo!! Me fasina el explorar y mas si es el papa de muchas distros!! jeje

Acabo de instalar Mint 13 Cinnamon y viendo el tutorial de la instalacion de debian mira lo que he encontrado:

 

 


Realtek

Para las tarjetas Realtek existe un paquete en los repositorios non-free que es compatible con los siguientes modelos:

RTL8188CE, RTL8188CUS, RTL8188DE, RTL8188SU, RTL8191SE, RTL8191SU, RTL8192CE, RTL8192CU, RTL8192DE, RTL8192E, RTL8192SE, RTL8192SU, RTL8192U

El paquete es firmware-realtek

aptitude install firmware-realtek

 

 

Si agrego los repositorios de debian y luego ese comando para instalar los drivers, quizas me soluciona todos los problemas.. ya que la placa que tengo esta primera en la lista!! jeje
Por probar no pierdo nada mas que tiempo.. de momento estoy actualizando.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

:jajaja: bueno el internet me va super lento.. sigue actualizando, cuando termine probare el wifi y te cuento.. sino ya luego probare debian a ver que tal va. Aun que no se si hoy ya, que tengo dos examenes en la facultad esta semana. :/ Pero me incomoda no tener la pc en condiciones, si algo me molesta mucho es eso.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Bien instale Mint 13 Cinnamon, luego los drivers de Realtek oficiales, descargados desde la pagina que esta en el primer comentario de este post. Y al parecer va bien, esperemos siga asi, sino luego cambiare a debian con los drivers que proporciona este a ver que tal va.

 

Muchas gracias por ayudar tan rapido!! :)

Saludos.

Compartir este post


Enlace al post
Compartir en otros sitios
  • 0

Falsa alarma.. :(

 
Luego de descargar algunas cosas, se me reiniciaba el internet a cada rato, cambie el gestor de red y lo mismo.. Asi que me voy al Papi ahora!! jeje SAN DEBIAN!! :P
Ya les contare, que el internet me va lento, los servidores de Debian estan saturados y esto me esta tardando unas 20 horas  :shock:

 

Mientras tanto estoy instalando una version estable que tengo, la ultima que me la regalo un amigo.. a ver que tal va esa con los drivers, descargare de los repos ofiaicles con tu tuto compi y tratare de acomodarla a mi gusto.

 

Yo uso la pc mas que nada para programar en C++, java y desarrollo android. Asi que cuanto menos aplicaciones tenga es mejor, vere el tema de compilar el kernel, con lo justo tambien. Pero eso ya mas adelante.. ya les seguire contando.

 

EDITO:

Para no crear un doble post, preferi editar este.. tengo novedades.

PAPA SI QUE SABE!!!!!!!! jajajaja

 

San Debian, soluciono mi problema con la placa de wifi!! Les cuento..

 

Instale debian stable Wheezy, al momento de querer insalar los drivers de la placa de wifi, no me dejaba, porque eran non-free, asi que acudi a modificar los repositorios, yo soy Argentino y solo le añadi dos lineas de españa (aun que ya encontre las de argentina, que luego probare) y al resto las edite (solo las que necesitaba editar). En fin, llevo ya un rato corriendo con el WiFi, sin un solo reinicio y rapida como debe ser.
Ya estoy descargando algunas aplicaciones basicas para mi, como QT Creator, Yakuake, MonoDevelop....

 

Ahora tengo un pequeño gran problema jejeje no todo podia ser de color rosa jajajaja Instale una version de 32 bits, es que recorde que tenia un dvd y lo instale, cuando ya estaba instalando recorde que era de 32 bits, ya que me mostro el kernel :(

Hay algua forma de instalar el kernel de 64 bits y que me cambie todos los archivos a esta version? He leido que hay muchas cosas por cambiar y aun asi no todas lo haran.. yo la necesito con 64 bits para sacarle el mayor rendimiento y porque necesito compilar android.

Perdon por desviar el tema, pero es que no me di cuenta.

Editado por xXFacusXx

Compartir este post


Enlace al post
Compartir en otros sitios

Registra una cuenta o conéctate para comentar

Debes ser un miembro de la comunidad para dejar un comentario

Crear una cuenta

Regístrate en nuestra comunidad. ¡Es fácil!

Registrar una cuenta nueva

Iniciar Sesión

¿Ya tienes cuenta? Conéctate aquí.

Iniciar Sesión
Conéctate para seguir esto  

×