Ir al contenido
Juanro49

Actualiza GNU/Linux y gestiona kernels fácilmente con DistroUpdate

Recommended Posts

Buenas! les dejo por aquí esta herramienta que he realizado a partir de un fork de mintUpdate.

 

DistroUpdate es un fork de mintUpdate que permite instalar y usar esta herramienta en cualquier distribución GNU/Linux basada en Debian o Ubuntu. Además, permite gestionar los kernels disponibles de forma gráfica.

 

Mejoras respecto a mintUpdate:

  • Instalable en cualquier distribución basada en Debian o Ubuntu
  • Desbloqueada la gestión de kernels para poder ver los kernels de todos los repos que tengamos añadidos al sistema, en lugar de solo los que hay en los repos de la distribución
  • Añadido soporte para ver changelog y reporte de bugs para kernels de los repos de debian y kernels de terceros como liquorix o xammod

 

 

Para la mayoría de usuarios de este foro no es necesaria esta herramienta, ya que nos desenvolvemos bien con la terminal (y amamos su rapidez), pero esta herramienta está destinada para aquellos iniciados que prefieren gestionar kernels y actualizaciones de forma gráfica y le tienen respeto a la línea de comandos, o para aquellos que consigan convencer a amigos y familiares a que se adentren al mundo GNU/Linux y les sea lo mas amigable posible. DistroUpdate permite que los mas iniciados puedan gestionar las actualizaciones mas fácilmente y tengan un abanico de distribuciones mas amplio para elegir en lugar de solo las típicas de Mint y Ubuntu.

 

Mas info --> https://github.com/juanro49/distroupdate

 

68747470733a2f2f692e696d6775722e636f6d2f

 

68747470733a2f2f692e696d6775722e636f6d2f

 

Instalación

echo 'deb https://gitlab.com/patojad/repository/raw/patojad/debs/ patojad main' | sudo tee /etc/apt/sources.list.d/patojad.list
wget -qO - https://gitlab.com/LynxOS/repository/raw/lynxos/LynxPub.gpg | apt-key add -
sudo apt update
sudo apt install distroupdate

 

Compartir este post


Enlace al post
Compartir en otros sitios

Interesante, estaba pensando en cambiar el núcleo de mi sistema para disfrutar de las mejores de la gráfica AMD pero no quiero romper nada ahora mismo ya que estoy tratando de diagnosticar un problema que tengo y no se de donde viene, pero le echaré un ojo a la herramienta un poco más adelante.

Compartir este post


Enlace al post
Compartir en otros sitios
hace 1 hora, uzanto dijo:

Interesante, estaba pensando en cambiar el núcleo de mi sistema para disfrutar de las mejores de la gráfica AMD pero no quiero romper nada ahora mismo ya que estoy tratando de diagnosticar un problema que tengo y no se de donde viene, pero le echaré un ojo a la herramienta un poco más adelante.

 

Que gráfica es? yo tengo una RX 5500M y para que funcionase bien tuve que bajar los firmwares de AMD manualmente desde el repo del kernel

Compartir este post


Enlace al post
Compartir en otros sitios
hace 23 minutos, Juanro49 dijo:

 

Que gráfica es? yo tengo una RX 5500M y para que funcionase bien tuve que bajar los firmwares de AMD manualmente desde el repo del kernel

una RX 5600 XT yo tuve que hacer lo mismo en Debian cuando tenía el núcleo 5.4, ahora con el 5.5 creo que no es necesario y están mejorando cosas en núcleos posteriores.

Compartir este post


Enlace al post
Compartir en otros sitios
On 21/4/2020 at 20:43, Juanro49 dijo:

Buenas! les dejo por aquí esta herramienta que he realizado a partir de un fork de mintUpdate.

 

DistroUpdate es un fork de mintUpdate que permite instalar y usar esta herramienta en cualquier distribución GNU/Linux basada en Debian o Ubuntu. Además, permite gestionar los kernels disponibles de forma gráfica.

 

Mejoras respecto a mintUpdate:

  • Instalable en cualquier distribución basada en Debian o Ubuntu
  • Desbloqueada la gestión de kernels para poder ver los kernels de todos los repos que tengamos añadidos al sistema, en lugar de solo los que hay en los repos de la distribución
  • Añadido soporte para ver changelog y reporte de bugs para kernels de los repos de debian y kernels de terceros como liquorix o xammod

 

 

Para la mayoría de usuarios de este foro no es necesaria esta herramienta, ya que nos desenvolvemos bien con la terminal (y amamos su rapidez), pero esta herramienta está destinada para aquellos iniciados que prefieren gestionar kernels y actualizaciones de forma gráfica y le tienen respeto a la línea de comandos, o para aquellos que consigan convencer a amigos y familiares a que se adentren al mundo GNU/Linux y les sea lo mas amigable posible. DistroUpdate permite que los mas iniciados puedan gestionar las actualizaciones mas fácilmente y tengan un abanico de distribuciones mas amplio para elegir en lugar de solo las típicas de Mint y Ubuntu.

 

Mas info --> https://github.com/juanro49/distroupdate

 

68747470733a2f2f692e696d6775722e636f6d2f

 

68747470733a2f2f692e696d6775722e636f6d2f

 

Instalación


echo 'deb https://gitlab.com/patojad/repository/raw/patojad/debs/ patojad main' | sudo tee /etc/apt/sources.list.d/patojad.list
wget -qO - https://gitlab.com/LynxOS/repository/raw/lynxos/LynxPub.gpg | apt-key add -
sudo apt update
sudo apt install distroupdate

 

Acabo de intentar instalar el .deb y me salta un error.

dpkg: error al procesar el archivo distroupdate_5.6.4_all.deb (--install):
 intentando sobreescribir `/usr/share/icons/hicolor/16x16/apps/software-properties.png', que está también en el paquete software-properties-gtk 0.96.20.2-2.1

Está intentando escribir un archivo que va viene instalado en otro paquete ¿Quizás deberías añadir software-properties-gtk como dependencia en vez de hacer esto? la verdad es que no tengo mucha idea del tema ya que no soy desarrollador.

Desempaqueté el .deb, eliminé ese icono de todos los tamaños y me funciona, ya te dejaré la opinion por aquí cuando lo pruebe mejor.

Compartir este post


Enlace al post
Compartir en otros sitios
Acabo de intentar instalar el .deb y me salta un error.
dpkg: error al procesar el archivo distroupdate_5.6.4_all.deb (--install):intentando sobreescribir `/usr/share/icons/hicolor/16x16/apps/software-properties.png', que está también en el paquete software-properties-gtk 0.96.20.2-2.1

Está intentando escribir un archivo que va viene instalado en otro paquete ¿Quizás deberías añadir software-properties-gtk como dependencia en vez de hacer esto? la verdad es que no tengo mucha idea del tema ya que no soy desarrollador.
Desempaqueté el .deb, eliminé ese icono de todos los tamaños y me funciona, ya te dejaré la opinion por aquí cuando lo pruebe mejor.

Lo revisare, gracias!!

Enviado desde mi NOVA CAN-L11 mediante Tapatalk

Compartir este post


Enlace al post
Compartir en otros sitios

oh, que buena pinta, me lo apunto para instalarlo en las distros debian que me quedan aka neon.

un saludo y gracias. has pensado en subirlo a snap o flat? te lo digo porque desde ahi, una vez lo instalas en el sistema, snap o flatpak te lo mantiene actualizado tambien...

 

Compartir este post


Enlace al post
Compartir en otros sitios

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invitado
Responder en este tema...

×   Has incluido contenido con formato.   Eliminar formato

  Sólo se permiten 75 emoticonos como máximo.

×   Tu enlace ha sido insertado automáticamente.   Deshacer y mostrar como enlace

×   Su contenido anterior ha sido restaurado.   Limpiar editor

×   No puedes pegar imágenes directamente. Súbelas a algún hosting de imágenes y pega la dirección URL


×
×
  • Crear Nuevo...