Ir al contenido

Buscar en La Comunidad

Mostrando resultados por etiquetas 'dependencias'.

  • Buscar Por Etiquetas

    Añade etiquetas separadas por comas.
  • Buscar Por Autor

Tipo de Contenido


Foros

  • Contacto con el staff
    • Novedades / Anuncios del foro
    • Sugerencias
    • Problemas relacionados con el foro
  • Zona general de charla
    • Presentaciones
    • Charla
    • Zona de Humor, Curiosidades y Otros
    • Mascotas Vagos
    • Noticias del Mundo
    • Tecnología
    • Ayuda y consultas de carácter general
  • Zona GNU/Linux
    • Ayuda, consultas y soporte GNU/Linux
    • Distribuciones GNU/Linux
    • Repositorios. Software GNU/Linux
    • Personalización
    • Raspberry Pi
    • Arduino
    • Manuales / Tutoriales / Guías GNU/Linux
    • Programación
    • Noticias GNU/Linux
    • Hablando de GNU/Linux
  • Zona Gaming
    • Juegos GNU/Linux
    • Noticias Gamer
    • Charla Gamer
  • Zona Móvil
    • Ayuda y soporte para dispositivos móviles
    • Apps Móviles
    • Manuales / Tutoriales / Guías Móviles
    • Roms para dispositivos Móviles
    • Noticias sobre dispositivos Móviles
    • Hablando sobre dispositivos Móviles
  • Zona Mozilla
    • Ayuda, consultas y soporte Mozilla
    • Aplicaciones Mozilla
    • Roms Firefox OS
    • Manuales / Tutoriales / Guías Mozilla
    • Noticias Mozilla
    • Hablando de Mozilla
  • Microsoft
    • Papelera del Foro

Encontrar resultados en...

Encontrar resutados que...


Fecha de Creación

  • Start

    Fin


Última Actualización

  • Start

    Fin


Filtrar por numero de...

Joined

  • Start

    Fin


Grupo


Página Web


Diaspora


Pump


GNU Social


Google +


Twitter


Facebook


Xmpp


Skype


Steam


Desura


MediaGoblin


Youtube


Vimeo


Picasa


Flickr


Email


Lugar


Intereses

Encontramos 3 resultados

  1. Buenas noches papilos, los vengo a molestar... con la siguiente consulta. Resulta que una noche actualizando el sistema, me di cuenta que no tenía más gdm3 ni mi amado gnome-shell 3.16 jaja, esta bién lo admito, estaba usando cinnamon-2.6.13 muy lindo por cierto, pero bueno, justo quería volver a usar gnome y me di cuenta que no está y me figura ésto cuando intento instalar. Alguno me puede orientar o decirme como se repara ésto o debo esperar? a qué? nosé? jaja Un abrazo y gracias por su tiempo!
  2. Script casero para resolver dependencias en Slackware Escribi un pequeño script para obtener un listado ordenado ( ordenado por prioriad de dependencia) de las dependencias necesarias (solo lista las que necesitas en tu sistema) para instalar un paquete en Slackware. Es para agilizar un poco la resolucion de dependencias y no hacerlo de forma tan manual, es cierto que existen paquetes que resuelven las dependencias solos, pero yo prefiero no usarlos y ver que estoy instalando. Hago uso de la pagina SlackBuilds para obtener informacion de los paquetes, ya que uso ese repositorio mediante Sbopkg para instalarlos de forma mas rapida. El script por ahi es un poco precario, pero funciona bastante bien, resuelve las dependencias de forma recursiva , avisa si ya esta instalado, o si no es necesario instalar ninguna dependencia. #!/bin/bash #=============================================================================== # # FILE: dependencias.sh # # USAGE: ./dependencias.sh paquete # # DESCRIPTION: Resolver dependencias para un paquete determinado, el script # proporcionas un listado ordenado de paquetes a instalar # para sistemas basados en SLACKWARE. # # OPTIONS: # REQUIREMENTS: Curl, wget, gawk # NOTES: - # AUTHOR: Skilltik Henry Suarez skilltik@gmail.com # ORGANIZATION: --- # CREATED: 17/04/14 # REVISION: 0.2 #=============================================================================== packages_dir=/var/log/packages/ function resuelve(){ for paquete in $@ do lista='' lista=`ls $packages_dir | grep $paquete-'[[:digit:]]*\>' ` if [ "${#lista}" == 0 ] then c=" " echo "$paquete$c" >> resul curl -s "slackbuilds.org/result/?search=$paquete&sv=14.1" > salida.html ; variable=`grep -i $paquete\/ salida.html | gawk '{print $6}' FS="\"" | gawk '{print $4}' FS="/"` nombreokpaquete=`grep -i $paquete\/ salida.html | gawk '{print $6}' FS="\"" | gawk '{print $5}' FS="/"` wget -q http://slackbuilds.org/slackbuilds/14.1/$variable/$nombreokpaquete/$nombreokpaquete.info ; vari=`grep REQUIRES $nombreokpaquete.info` vari=`echo ${vari:10: -1}` rm *.info if [ "${#vari}" != 0 ] then resuelve $vari fi fi done } for arreglo in $@ do curl -s "slackbuilds.org/result/?search=$arreglo&sv=14.1" > verifica.html ; verificapaq=`grep -i "No results" verifica.html ` rm verifica.html if [ "${#verificapaq}" == 0 ] then resuelve $arreglo if [ -f resul ] then tac resul > resul2 cat resul2 | tr -s " " "\n" > resul awk '!array_temp[$0]++' resul > resul2 cat resul2 | tr -s "\n" " " > resul tr -d "\n" < resul > resul2 echo "|-----------------------------------------------------------|" echo "Las dependencias a resolver para $arreglo son :" cat resul2 echo " " echo "|-----------------------------------------------------------|" echo " " rm resul resul2 rm salida.html else echo "|-----------------------------------------------------------|" echo "No hay dependencias por resolver para $arreglo " lista=`ls $packages_dir | grep $paquete-'[[:digit:]]*\>' ` if [ "${#lista}" != 0 ] then echo "$lista ya se encuentra instalado" fi echo "|-----------------------------------------------------------|" fi else echo "|-----------------------------------------------------------|" echo " $arreglo no existe en base de datos" echo "|-----------------------------------------------------------|" fi done Por ejemplo, consideremos este listado de paquetes que tenemos en mente para instalar: dvdrip openlp paqueteimaginario ffmpeg tan solo ejecutamos el scritp de esta forma: ./dependencias.sh dvdrip openlp paqueteimaginario ffmpeg Y con esto estamos listo para instalarlos de la forma que prefieran, yo uso SBopkg, asi que para instalar Dvdrip, solo ejecuto : sbopkg -i "transcode perl-libintl perl-extutils-pkgconfig perl-extutils-depends perl-glib perl-cairo perl-pango perl-gtk2 perl-event dvdrip" y se va a ir instalando en el orden necesario. Dudas, errores o sugerencias me avisan.
  3. Keryx es software libre multiplataforma creado por Chris Oliver escrito en Python, que permite la descarga de paquetes para distribuciones basadas en Debian que utilizan apt como gestor de paquetes. Esta herramienta permite y/o facilita la instalación de software en equipos GNU/Linux que no tienen conexión a internet. Es posible utilizarla en equipos con Windows instalando previamente Python 2.6 y Python GTK, así como utilizarlo de manera "portable" en un medio extraíble USB. Descarga https://launchpad.net/keryx/stable/1.0-release/+download/keryx_1.0-public21_portable.zip Web https://launchpad.net/keryx
×
×
  • Crear Nuevo...