Ir al contenido

Buscar en La Comunidad

Mostrando resultados por etiquetas 'aptitude'.

  • Buscar Por Etiquetas

    Añade etiquetas separadas por comas.
  • Buscar Por Autor

Tipo de Contenido


Foros

  • Contacto con el staff
    • Novedades / Anuncios del foro
    • Sugerencias
    • Problemas relacionados con el foro
  • Zona general de charla
    • Presentaciones
    • Charla
    • Zona de Humor, Curiosidades y Otros
    • Mascotas Vagos
    • Noticias del Mundo
    • Tecnología
    • Ayuda y consultas de carácter general
  • Zona GNU/Linux
    • Ayuda, consultas y soporte GNU/Linux
    • Distribuciones GNU/Linux
    • Repositorios. Software GNU/Linux
    • Personalización
    • Raspberry Pi
    • Arduino
    • Manuales / Tutoriales / Guías GNU/Linux
    • Programación
    • Noticias GNU/Linux
    • Hablando de GNU/Linux
  • Zona Gaming
    • Juegos GNU/Linux
    • Noticias Gamer
    • Charla Gamer
  • Zona Móvil
    • Ayuda y soporte para dispositivos móviles
    • Apps Móviles
    • Manuales / Tutoriales / Guías Móviles
    • Roms para dispositivos Móviles
    • Noticias sobre dispositivos Móviles
    • Hablando sobre dispositivos Móviles
  • Zona Mozilla
    • Ayuda, consultas y soporte Mozilla
    • Aplicaciones Mozilla
    • Roms Firefox OS
    • Manuales / Tutoriales / Guías Mozilla
    • Noticias Mozilla
    • Hablando de Mozilla
  • Microsoft
    • Papelera del Foro

Encontrar resultados en...

Encontrar resutados que...


Fecha de Creación

  • Start

    Fin


Última Actualización

  • Start

    Fin


Filtrar por numero de...

Joined

  • Start

    Fin


Grupo


Página Web


Diaspora


Pump


GNU Social


Google +


Twitter


Facebook


Xmpp


Skype


Steam


Desura


MediaGoblin


Youtube


Vimeo


Picasa


Flickr


Email


Lugar


Intereses

Encontramos 6 resultados

  1. hola a todos, pues como dice el titutlo, tengo un problema con un paquete que parece que se le atraganto a linux mint. estamos hablando de liquorix, y es que en una de las ultimas versiones que me llego, este parece que no termino de instalar, pero dpkg no me deja hacer nada, aptitude o apt tampoco, ni eliminarlo, ni reinstalarlo, nada... el problema, es que se ve afectado todo el sistema, ya que no me deja actualizar nada mas, ni instalar nada nuevo... os pego mis ultimos avances... bartop@bartop:~$ sudo aptitude purge linux-headers-4.19.0-13.1-liquorix-amd64 Se ELIMINARÁN los siguientes paquetes: linux-headers-4.18.0-15.1-liquorix-amd64{u} linux-headers-4.18.0-16.2-liquorix-amd64{u} linux-headers-4.19.0-13.1-liquorix-amd64{p} linux-modules-extra-4.15.0-38-generic{u} linux-modules-extra-4.15.0-42-generic{u} 0 paquetes actualizados, 0 nuevos instalados, 5 para eliminar y 89 sin actualizar. Necesito descargar 0 B de archivos. Después de desempaquetar se liberarán 448 MB. ¿Quiere continuar? [Y/n/?] y dpkg: error al procesar el paquete linux-headers-4.19.0-13.1-liquorix-amd64 (--remove): el paquete está en un estado muy malo e inconsistente - debe reinstalarlo antes de intentar desinstalarlo. (Leyendo la base de datos ... 495762 ficheros o directorios instalados actualmente.) Desinstalando linux-headers-4.18.0-15.1-liquorix-amd64 (4.18-18ubuntu1~bionic) ... Desinstalando linux-headers-4.18.0-16.2-liquorix-amd64 (4.18-20ubuntu1~bionic) ... Desinstalando linux-modules-extra-4.15.0-38-generic (4.15.0-38.41) ... Desinstalando linux-modules-extra-4.15.0-42-generic (4.15.0-42.45) ... Se encontraron errores al procesar: linux-headers-4.19.0-13.1-liquorix-amd64 E: Sub-process /usr/bin/dpkg returned an error code (1) Estado actual: 1231 (-2) nuevos. bartop@bartop:~$ sudo aptitude upgrade Resolviendo las dependencias... Se instalarán los siguiente paquetes NUEVOS: linux-headers-4.19.0-15.1-liquorix-amd64{a} linux-image-4.19.0-15.1-liquorix-amd64{a} Se actualizarán los siguientes paquetes: adobe-flashplugin chromium-codecs-ffmpeg-extra dirmngr e2fslibs e2fsprogs firefox firefox-locale-en firefox-locale-es gir1.2-gnomebluetooth-1.0 gir1.2-javascriptcoregtk-4.0 gir1.2-webkit2-4.0 gnome-bluetooth gnupg gnupg-l10n gnupg-utils gpg gpg-agent gpg-wks-client gpg-wks-server gpgconf gpgsm gpgv ibverbs-providers initramfs-tools initramfs-tools-bin initramfs-tools-core krb5-locales libarchive13 libcaca-dev libcaca0 libcom-err2 libegl-mesa0 libegl1-mesa libegl1-mesa-dev libexiv2-14 libext2fs2 libgbm1 libgl1-mesa-dev libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libgles2-mesa libgles2-mesa-dev libglx-mesa0 libgnome-bluetooth13 libgssapi-krb5-2 libgweather-3-15 libgweather-common libibverbs-dev libibverbs1 libjavascriptcoregtk-4.0-18 libk5crypto3 libkrb5-3 libkrb5support0 libnss-myhostname libnss-systemd libnss3 libpam-systemd librdmacm1 libsmbclient libss2 libsystemd0 libudev-dev libudev1 libwayland-egl1-mesa libwbclient0 libwebkit2gtk-4.0-37 libxatracker2 linux-firmware linux-headers-liquorix-amd64 linux-image-liquorix-amd64 linux-libc-dev mesa-common-dev mint-mirrors mintbackup netplan.io nplan psmisc python-samba samba samba-common samba-common-bin samba-libs systemd systemd-sysv udev usbmuxd Se RECOMIENDAN los siguientes paquetes, pero NO se instalarán: adobe-flash-properties-gtk adobe-flash-properties-kde e2fsprogs-l10n gnome-control-center samba-dsdb-modules samba-vfs-modules unity-control-center xul-ext-ubufox 87 paquetes actualizados, 2 nuevos instalados, 0 para eliminar y 2 sin actualizar. E: No se puede encontrar una fuente para descargar la versión «4.19-8ubuntu1~bionic» de «linux-headers-4.19.0-13.1-liquorix-amd64:amd64» Después de desempaquetar se usarán 363 MB. ¿Quiere continuar? [Y/n/?] y E: No se puede encontrar una fuente para descargar la versión «4.19-8ubuntu1~bionic» de «linux-headers-4.19.0-13.1-liquorix-amd64:amd64» E: Error interno: no se pudo generar la lista de paquetes a descargar E: Quizá las listas de paquetes están desactualizadas, intente «aptitude update» (o equivalente); de otra forma algunos paquetes o versiones no están disponibles desde la fuente de repositorio actual bartop@bartop:~$ haber si me podeis hechar una mano, pinta a que tendra una solucion muy sencilla pero no doy con ella, ya os digo, reinstalar no sirve de nada, purgar tampoco.... Gracias
  2. Apt-fast es un script shell que permite la paralelización de descargas de paquetes deb, tanto con apt-get, apt o aptitude. Éste nos permite descargar varios paquetes simultáneamente, desde diferentes mirros estableciendo varias conexiones por cada uno, en lugar de descargarlos de uno en uno como ocurre por defecto. Esto tiene una ventaja para el usuario, ya que puede exprimir al máximo su conexión a Internet para descargar los paquetes deb mucho más deprisa, pero también tenemos que tener en cuenta el lado del servidor, ya que las descargas en paralelo, para quien las sirve, suponen trabajo extra y no son ni remotamente tan divertidas como para quien los descarga. En este sentido, además de no exagerar con el número de conexiones y descargas en paralelo, tendremos a bien definir varios mirrors en el archivo de configuración, para no sobrecargar uno sólo, sino hacer descargas de distintos paquetes desde diferentes servidores cada uno. PPA Existe un reporitorio PPA desde el que podemos descargar e instalar Apt-fast. Tan sencillo como add-apt-repository ppa:saiarcot895/myppa aptitude update aptitude install apt-fast Manualmente Pero como ya nos conocemos, vamos a indicar también cómo instalar el script manualmente desde github. Como dependencias tendremos los paquetes aria2 y, obviamente, git. El proceso es tan sencillo como clonar el repositorio github, copiar el binario del script a /usr/bin (con permisos de ejecución) y sus archivo de configuración a /etc aptitude install aria2 git git clone https://github.com/ilikenwf/apt-fast /tmp/apt-fast cd /tmp/apt-fast cp apt-fast /usr/bin chmod +x /usr/bin/apt-fast cp apt-fast.conf /etc Bash completion La opción de autocompletado bash es muy útil a la hora de trabajar con paquetes, así que nos conviene activar dicha opción antes de empezar a lidiar con apt-fast cp completions/bash/apt-fast /etc/bash_completion.d chown root:root /etc/bash_completion.d/apt-fast . /etc/bash_completion Zsh completion Igualmente, sin el lugar de bash nos valemos de zsh, la situación es la misma, pero el proceso ligeramente distinto. cp completions/zsh/_apt-fast /usr/share/zsh/functions/Completion/Debian chown root:root /usr/share/zsh/functions/Completion/Debian/_apt-fast source /usr/share/zsh/functions/Completion/Debian/_apt-fast Páginas Man Porque en algún momento puede que necesitemos consultar el manual cp ./man/apt-fast.8 /usr/share/man/man8 gzip -f9 /usr/share/man/man8/apt-fast.8 cp ./man/apt-fast.conf.5 /usr/share/man/man5 gzip -f9 /usr/share/man/man5/apt-fast.conf.5 Configuración Apt-fast cuenta con un asistente, que nos aparecerá tanto al instalar el paquete como al invocar la orden: dpkg-reconfigure apt-fast Pero ya que nos hemos estado ensuciando las manos desde el principio, voy a seguir con la configuración manual. El archivo de configuración de apt-fast está bien comentado, así que me limitaré a hablar de las opciones más relevantes en nuestro caso dentro de /etc/apt-fast.conf: Por defecto utilizará apt-get, pero los que ya me conocen saben que en mi caso siempre recomiendo aptitude en su lugar, así que: Definir mirrors El listado de mirrors es muy importante, como ya hemos dicho, así que nos tomaremos un momento para definirlos. No es necesario que los especifiquemos tal y como los tenemos en /etc/apt/sources.list, sólo necesitamos la dirección del mirror, ni ramas ni opciones ni nada por el estilo, tal y como se expresa en los ejemplos, simplemente una serie de direcciones separadas por comas: Número máximo de conexiones, definido por _MAXNUM. El valor por defecto es de 5, es decir, 5 descargas en paralelo, que es un valor bastante bueno, así que salvo que tengamos otros planes, podemos dejarlo así (¿Han visto cuantos mirros he definido antes? ) Máximo de conexiones por servidor. De nuevo el valor por defecto es más que suficiente Descargando e instalando paquetes Apt-fast no se diferencia de las herramientas utilizadas hasta ahora. De hecho, hemos definido la que utilizará por defecto, así que las opciones a utilizar serán las mismas que apt-get o aptitude, sólo que el comanda será apt-fast Repositorio github https://github.com/ilikenwf/apt-fast
  3. Me han propuesto hacer una guía entre todos que cubra lo básico que necesita un usuario para tener Debian completamente funcional. La idea es ir completándola con los aportes que hagamos todos, para llegar a crear una gran guía o wiki, que sirva para todos aquellos que empiezan con Debian y también para los que llevan tiempo utilizando esta Distribución. Hacer una "guía" de este tipo es complicado, porque nadie hace la misma instalación de Debian, todos acaban con entornos, paquetes y herramientas distintos, pero eso no nos vamos a echar atrás ¿Verdad?. He de aclarar que, como toda distribución GNU/Linux, Debian puede configurarse según lo que cada usuario necesita y ese precisamente es el objetivo de la guía, que cada uno pueda llegar a tener Debian completamente configurado según sus necesidades o gustos. Como su propio nombre indica, se trata de una guía, una referencia a utilizar para instalar y configurar una instalación, no se trata de seguir los pasos al pie de la letra copiando y pegando comandos en la consola sin saber lo que estamos haciendo, sino de tener una referencia a la hora de configurar la distribución. Importante La Rama de Debian en la que se centra la guía es la Testing, que es la recomendada para uso en equipos de escritorio. Esta rama es Half Rolling Release y contiene paquetes bastante actuales. Para hacernos una pequeña idea de cómo funciona esta distribución a grandes rasgos y por qué se ha recomendado usar la rama Testing para equipos de escritorio: Infografía creada por claudiocomputing Al ser una guía en plan general/universal todos los procedimientos se llevarán a cabo con comandos en consola (al menos todo lo que yo aporte) y nada (o muy poco) se hará a través de herramientas gráficas, porque no todos tendremos ni el mismo entorno gráfico ni las mismas aplicaciones y los pasos a seguir tienen que valer para todo el mundo. Todos los comandos que aparecen en la guía, a excepción de cuando especifique lo contrario, serán ejecutados como root Teoría ¿Cómo trabaja la comunidad Debian? Apt-get vs Aptitude Empecemos desde el principio Descargar Debian Instalación básica Cosas que hacer después de instalar Debian Ahora vamos justo después de terminar la instalación, no importa si fue una instalación mínima, completa, o con un entorno gráfico u otro. 0. Habilitar la orden sudo (si así lo prefieres y no lo hiciste durante la instalación) 1. Modificar los repositorios 2. Codecs multimedia, plugins de flash y OpenJDK (Java) 3. Herramientas y librerías para compresión/descompresión de Archivos 4. Librerías y componentes básicos para compilar 5. Controladores para tarjetas gráficas 6. Controladores para tarjetas Wifi 7. Touchpads (portátiles) 8. Instalando el navegador Iceweasel (Fork de Firefox para Debian) 9. Instalando el gestor de correo Icedove (Fork de Thunderbird para Debian) Mejoras Generales y de Rendimiento 1 Paquetes para optimización de recursos 2 Repriorizar el uso de la swap 3 Montar los temporales en Ram 4 Mejorar el consumo de energía 5 Actualizar el microcódigo del procesador 6 Habilitar soporte multiarquitectura 7 Hacer autologin sin necesidad de gestor de acceso (Display Manager) y lanzar el entorno gráfico OJO No realizar si se desconoce lo que este método implica 8 Linux Liquorix y Optimización mediante scripts 9 Compilar Linux "a medida" 10 Mejorar rendimiento con Apt-build 11 Optimizando el arranque con SytemD 12 Discos de estado sólido (SSD). Optimización y configuración 13 Debian amd64 y UEFI Otros procedimientos útiles 1 Añadir repositorios PPA (Semi)automáticamente 2. LibreOffice 3. Última versión de Wine 4. Instalar cliente Steam 5. Bash completion Entornos gráficos Apariencia Libro de "Trucos" Debian DIRECCIONES DE INTERÉS P.D. Cualquier cosa que haya olvidado o que quieran que incluya, sólo escríbanla, la idea es hacer una buena guía con los aportes que hagamos entre todos
  4. Instalando programas luego de usar el comando add-apt-repository intenté usar apt-get update pero daba error: E: No se pudo bloquear /var/lib/apt/lists/lock - open (11: Recurso no disponible temporalmente) En internet dice que ocurre cuando uno forza la salida del Gestor de Aplicaciones, pero no creo que lo haya hecho. O también cuando un proceso está usando aptitude Para arreglarlo hay que borrar el archivo que nombra el error escribiendo: sudo rm /var/lib/apt/lists/lock Por lo que entiendo es un archivo que se crea cuando se instala un programa, y se borra cuando se termina de instalar. En mi caso pienso que no se borró, y por eso tuve que hacerlo manualmente
  5. Leyendo LMDE Cosillas he visto un tema sobre este asunto y me ha parecido una idea interesante, ya que siempre se habla de cómo subir de rama en Debian, de actualizar paquetes, de adquirir nuevas versiones, pero nunca se tiene en cuenta el proceso inverso ¿De qué manera se puede descender a una rama más estable?¿Cómo volver a una versión anterior de cierto paquete? La respuesta es más sencilla de lo que imaginamos, pues todo gira alrededor del apt-pinning. Si recordamos las diferentes preferencias que se pueden asignar, encontraremos que por encima de 1000 cumpliría exactamente con lo que buscamos: Siendo así, sólo nos queda hacer dos cosas antes de proceder con la "desactualización" de paquetes y es que tendremos que definir correctamente la rama a la que queremos descender en nuestro sources.list y, por supuesto, configurar el preferences como es debido. Para el ejemplo, supondremos un salto de rama desde Unstable a Testing. Para cualquier otro caso es exactamente igual, simplemente definiendo la rama correspondiente. En primer lugar nuestro /etc/apt/sources.list, que luciría de entrada tal que así: Además de simplemente cambiar de rama, debemos tener en cuenta las cualidades y condiciones de cada una. En este caso, tendré a bien incluir también le repositorio Security, que no existe para la rama Unstable, pero sí para la Testing, que es a la queremos movernos. Una vez modificado y guardados los cambios, como es habitual, ejecutaremos: aptitude update Para recibir las nuevas listas de paquetes. A efectos prácticos ya habríamos hecho el descenso de rama, a partir de ahora todos los paquetes que instalemos procederán de una rama más estable que la que estábamos utilizando anteriormente. Pero seguimos teniendo un problema y es que los paquetes qe ya hab´ian sido instalados desde la rama superior siguen en la misma versión y no sufrirán ningún cambio hasta que la rama en la que nos encontramos ahora actualice dichos paquetes a una versión superior a la instaladas, algo que para las ramas stable y/o oldstable no ocurrirá jamás. Para forzar la desactualización crearenos o editaremos el /etc/apt/preferences, recordando que debemos asignar una prioridad de 1000 o más para forzar la instalación de paquetes sin importar su versión. Guardamos los cambios y procedemos, ahora sí, a desactualizar paquetes. Mucho cuidado aquí, pues no hay que olvidar que estamos hablando del sistema entero, sobra decir que nos valdremos de aptitude para resolver correctamente los problemas de dependencias que pueden llegar a surgir y que estaremos muy atentos a lo que nos pida instalar o desinstalar durante el proceso. Si no queremos arriesgar más de la cuenta, podemos obtar por un: aptitude safe-upgrade O si queremos algo más profundo, aunque posiblemente también más arriesgado: aptitude full-upgrade EL término medio, como no, sería el habitual aptitude upgrade Siempre pueden quedar paquetes que no se desactualicen, bien por problemas de dependencias o cualquier otra razón, pero mayormente, la desactualización y cambio de rama se hará efectivo, una vez aptitude haya terminado de descargar e instalar la enorme cantidad de paquetes que componen nuestro sistema
  6. Un comando que he encontrado para desinstalar las dependencias innecesarias después de ejecutar "apt-get build-dep" para compilar algún programa: sudo aptitude markauto $(apt-cache showsrc NOMBRE_PAQUETE | grep Build-Depends | perl -p -e 's/(?:[\[(].+?[\])]|Build-Depends:|,|\|)//g') Se sustituye NOMBRE_PAQUETE por el nombre del paquete que se haya compilado. Lo cierto es que el comando me parece un poco "largo", si alguien tiene alguna corrección o simplificación, o algún otro método, bienvenido sea. Un saludo
×