Jump to content

pazos

Miembros
  • Posts

    22
  • Joined

  • Last visited

About pazos

Género

  • Género
    Sin_especificar

pazos's Achievements

Recién llegado

Recién llegado (1/11)

41

Reputation

  1. vale, me has pillado, no tengo ni idea de por que no te funciona. Todo parece correcto en las capturas. Lo que puedes probar es a meterle la version oficial de zte para españa: http://download.ztedevices.com/UpLoadFiles/product/550/3363/soft/2013110810201108.zip (ojo: tienes que descomprimir el archivo zip y dentro de el hay otro .zip que copiaras a la tarjeta SD) y probar a actualizar desde recovery. Esta version (la 1.1.0B01TME) si permite hacer downgrade o incluso volcado nand con los pasos que previamente has probado.
  2. @@oalejandro621: tengo visto ese error, pero es muy poco descriptivo , puedes colgar la captura de la interfaz del programa antes de que te salga el error?
  3. @@oalejandro621: puedes colgar una captura de pantalla del error? Estas usando un sistema de 32 bits? en tu telefono: ajustes>informacion> fijate si tienes la version 1.1.0B04TME, que es con la que yo he probado.
  4. @@oalejandro621: los ultimos moviles entregados por movistar (al menos en españa) estan teniendo el problema que comentas. La solucion es sencilla, consiste en usar un programa de volcado en memoria y flashear a traves de él el CWM recovery, para poder luego instalar cualquier imagen que gustes. Debes hacer el procedimiento desde un Windows de 32bits (zte no hace estas herramientas para linux ) y previamente instalar los drivers USB de ZTE {desde aqui: http://download.ztedevices.com/UpLoadFiles/product/643/3598/soft/2013102209104544.zip }. El movil lo apagas y desenchufas, una vez apagado aprietas VOL+, VOL- y POWER) el led rojo se deberia encender pero el movil no vibra. Conectalo ahora al PC y mira si es detectado como "ZTE Handset Diagnostic..." En ese caso puedes seguir adelante Volcado en nand de CWM: he colgado aqui > http://ul.to/m85gj7o0 una copia de los archivos necesarios para hacer el volcado de CWM a nuestro telefono. Solo tienes que descomprimir la carpeta en algun lado, abrir el programa como administrador y comprobar que solo la casilla "recovery" esta marcada y que tu telefono es reconocido. Despues pulsa el boton del fondo a la izquierda. Si todo va bien deberias tener en tu ZTE Open la imagen de recuperacion CWM, y con ello lo que tu quieras -no doy garantia-
  5. marca las comprobaciones automaticas a "comprobar mensualmente" (en ajustes > informacion) y dime si persiste el problema
  6. @@TensinG: las actualizaciones las ofrece mozilla, y son diarias. Al aplicarlas (te debería preguntar si la quieres aplicar ahora o mas tarde) se reinicia la interfaz grafica y se aplica la instalacion. Despues de eso si vas a comprobar actualizaciones (en informacion del dispositivo) te debería decir que estas a la ultima. Al día / semana / mes siguiente volverá a comprobar las actualizaciones en funcion de como lo tengas configurado.
  7. A mi me funciona el UpgradeTool las tres veces que lo he probado en moviles ZTE Open: 1- volcado de imagen recovery CWM y Stock (mi telefono requetemodificado, blobs V1.1.0B02-openUK. fastboot ok) 2- volcado de imagen recovery CWM (telefono de un amigo, recien comprado, blobs V1.1.0B01-TME fastboot capado) 3- volcado completo ( mi telefono despues de borrar todas las particiones de la memoria nand (montadas en /dev/mtd/mtdX) nota: ME PARECE UNA LOCURA) BORRAR TODAS LAS PARTICIONES DEL TELEFONO, solo digo que lo he hecho y que despues he podido actualizar a traves del metodo de volcado nand lo que si me parece seguro es instalar CWM desde la version 1.1.0 de Timofonica. Lo he hecho desde Windows 7 SP1 32 BITS, despues de instalar los drivers usb de ZTE disponibles en http://download.ztedevices.com/UpLoadFiles/product/643/3598/soft/2013102209104544.zip.
  8. @Igg2: a mi en la 1.3 SI me funcionan las actualizaciones a traves de las nightlies de mozilla, repite el procedimiento y ya verás echo 'pref("app.update.channel", "nightly");' > updates.js echo 'pref("app.update.url.override", "http://update.boot2gecko.org/inari/1.3.0/%CHANNEL%/update.xml?build_id=%BUILD_ID%&version=%VERSION%");' >> updates.js Aun asi esto no sustituye una actualizacion completa ya que solo actualiza gecko y gaia (la interfaz de usuario y el motor de renderizado web), gonk (la distribucion basada en linux con el HAL de android) no se actualiza, por lo que los bugs derivados de gonk no se "arreglan" actualizando por nightly. Yo estoy ahora preparando una 1.3 (con el boot.img generado en la compilacion ) y todo el hardware funciona, incluido el GPS, la unica pega es que el teclado numerico no funciona a la hora de desbloquear la SIM, ya que por defecto viene marcada una opcion del menu de desarrolladores (enable APZ for all..) que interfiere con el funcionamiento del teclado, al desactivarla todo va bien
  9. @@feiticeiro: olvida el privado que te mande Gracias a la informacion que ha colgado Igg2 aqui: http://gnulinuxvagos.es/topic/2454-rom-para-zte-open-firefox-os-12-multilenguaje-fastboot-activado/?p=15562 creo haber encontrado la solucion para tu movil. De hecho lo he probado yo mismo con el mio y funciona correctamente. Como señala Igg2 en su post necesitas arrancar el movil pulsando las teclas VOL+ y VOL- . El movil arrancara y Windows lo reconocera como "ZTE Handset Diagnostic..." (no me acuerdo si he instalado algun driver para que esto sea así, en ese caso te lo puedes descargar de ztedevices.com ) Como digo me descargue el archivo del dropbox, borre todos los arquivos innecesarios (realmente la solucion mas facil para ver si funcionaba sin arriesgarme a joder mi movil era flashear la particion de recovery solamente) lo he hecho dos veces, la primera desde CWM a la recovery de firefox os, y la segunda al reves, las dos veces me ha funcionado estupendamente. Como en tu caso solo necesitas cambiar de recovery para solucionar el error de verificacion de firma he subido mi carpeta a uploaded.net :http://ul.to/m85gj7o0 Solo necesitas descomprir la carpeta y ejecutar el archivo NandDL_firefox.exe como administrador (por si acaso ). Solo deberia quedarte marcada la casilla de recovery puesto que el resto de particiones se han borrado (en caso contrario mira que el programa detecte "bien" la carpeta donde estan los archivos partition.mbn, partition-zte.mbn y recovery.img ) cuando conectes el movil en modo "diagnostico" el programa lo reconocera y solo necesitaras pulsar el boton del fondo a la izquierda. Esto actualizara tu recovery a CWM y ya podras flashear cualquier imagen sin firmar Antes de hacer nada de esto te recomiendo que te pases por el post de Igg2 y te leas las instrucciones que el menciona, para que te puedas situar un poquito mejor. Espero que te funcione, muchas gracias a Igg2 por compartir la info ) Saludos
  10. @Igg2: estas hablando de la 1.3, verdad? Se te muestra el icono del GPS en la barra de notificaciones?
  11. @@feiticeiro: todas las 1.1.0xyz estan firmadas con la misma clave, si no funciona una no funciona ninguna. Tienes a mano una 1.0.1xyz ???
  12. @@feiticeiro: como ya te adelanté por privado, si la update-signed.zip no funciona es porque ZTE ha vuelto a cambiar la verificacion de firma. Voy a intentar explicarlo lo mejor posible: -Todas las imagenes colgadas en ZTEdevices están firmadas -Las firmas difieren entre la 1.0.1 y la 1.1.0 (por eso,cuando activo el fastboot, ZTE saco dos updates de la 1.1.0, uno para actualizar DESDE la 1.0.1 y otro para actualizar desde la 1.1.0) -Aunque ZTE cambiara el procedimiento de verificacion de firmas en la version colgada en http://firefox.ztems.com, los dos archivos (el antiguo y el nuevo) se parecen en que no entran en conflicto con el procedimiento de verificacion de firmas del recovery de firefox-os, por lo que estan firmados igual. -Las imagenes para los ZTE Open vendidos por ebay difieren con las vendidas por los operadores telefonicos: la actualizacion mediante recovery comprueba si cierta linea esta presente en /system/build.prop, y da error en caso contrario. Dicho esto pueden pasar tres cosas: - zte ha firmado el update.zip con las firmas empleadas en la 1.0.1 - zte ha firmado el update.zip con las firmas empleadas en la 1.1.0 - zte sigue dando asco y da otra vuelta de tuerca a los usuarios firmando la actualizacion con otras claves distintas Las posibilidades de que el tercer supuesto pase /creo yo\ son minimas, ya que ZTE ofrece dicha actualizacion como una transicion entre Android y Firefox OS, y es consecuente que el nuevo sistema sea capaz de actualizarse con las actualizaciones oficiales del fabricante. De todo anterior, y de tu experiencia, podemos deducir: 1 - las claves de desarrollo NO FUNCIONAN 2 - las actualizaciones para los ZTE OPEN (American y European Standard) fallaran al comprobar el build.prop y no actualizaran el software 3 - es probable que funcione la actualizacion 1.1.0B04 de telefonica movistar españa (o cualqueira de otro carrier), en caso contrario habria que probar con la version 1.0.1B01TME (porque las firmas de los updates difieren) o incluso con la antigua imagen colgada en http://firefox.ztems.com (eso si algun usuario tiene la gentileza de subirla, yo tengo que mirar este finde en el equipo secundario a ver si todavia la guardo) Yo en lo particular te recomiendo que pruebes las versiones mencionadas y que no desistas Ya nos contarás )
  13. @@feiticeiro: como te dije en mozilla-hispano necesitas primero instalar el update.zip de http://firefox.ztems.com. Despues de instalarlo instala el archivo que te acabas de bajar y ya veras como funciona
  14. Hola oalejandro621, Si es posible volver atras, pero es un poco tedioso y la verdad no se si el servicio tecnico de ZTE tiene forma de saber si el telefono ha sido flasheado o no con una version diferente. @Igg2: en que compañia estas? tienes los datos del apn configurados para datos/a-gps? Si vuelves a los firmwares de ZTE te funciona el GPS sin estar conectado a internet? . Yo con simyo he tenido que reconfigurar los datos del apn para tener el 3g/a-gps funcionando? Ahora mismo obtengo geolocalizacion en unos 40 segundos en la rom 1.2 que esta colgada arriba. Si estas en una compañia distinta a Orange / Movistar / Yoigo / Vodafone antes de nada comprueba que los ajustes del proovedor sean los correctos. De todas formas la oferta de colgar aqui el "adb logcat | grep GPS" sigue en pie, y asi podemos ver si hay alguna diferencia entre tu log y el mio
  15. @@Ereos: la diferencia principal son los blobs. La version que tu tienes lleva los blobs de zte 1.0.1, la nueva lleva los blobs de zte 1.1.0. Son distintos, los primeros te darian problema al compilar tu una 1.3, por el HWComposer... la otra diferencia es que en la segunda version el detector de proximidad funciona de serie, cosa que en la primera no. Igg2: el GPS es un A-GPS y necesita datos del proovedor para funcionar (la geolocalizacion depende de los datos, vamos). A mi en TODAS las versiones que he probado la geolocalizacion me funciona si, y solo si, tengo activados los datos (no se si con wifi funciona y no puedo probarlo en casa ). Es cierto que en la 1.3 los inari estan teniendo problemas con esto. Tambien puede ser lo que tu dices, que falte algun fichero en data/misc (xt_wifi quizas, gpsone_daemon NO esta en las versiones de ZTE). De todas maneras puedes hacer un "adb logcat | grep GPS" y colgar aqui el resultado de activar-esperar 30"-desactivar-esperar 30"-volver a activar, a ver si se ve algo raro
×
×
  • Create New...