Ir al contenido

Ranking


Contenido Popular

Mostrando contenido con la reputación más alta en 21/01/19 en todas las áreas

  1. 1 punto
    Nible

    Utilidad para conectar un Smartphone al Wifi con un QR

    Saludines GNU/Linuxeros Hace poco leí en un articulo que se pueden usar los códigos QR para conectar el Smartphone a la red WiFi simplemente escaneando el código con un programa como Barcode Scanner, ahorrándose uno así la faena de buscar el nombre de la red e introduciendo la contraseña manualmente. Para generar el QR existen páginas web con un simple formulario que hasta ofrecen en github su código fuente en Javascript, concretamente he visto esta: https://qifi.org La idea me pareció fantástica, ya que en casa a uno le pueden pedir esos datos cuando menos se lo espera. Pero la idea de poner todos esos datos en una web publica no me hace mucha gracia, aunque en la página aseguran que el código javascript se ejecuta localmente y no se envía nada a nadie. A pesar de eso, solo se trata de codificar una cadena cuyo "estándar" se encuentra aquí: https://github.com/zxing/zxing/wiki/Barcode-Contents#wifi-network-config-android Así que pensé en hace un aplicación local igual de sencilla para generar los QR que no tenga muchas dependencias, por eso he elegido usar programación con bash y zenity para la GUI y a elección del usuario python-qrcode o qrencode para generar el QR. Para la GUI habría quedado mejor con PyGTK o TkInter pero de momento es lo que hay. A continuación os dejo los comandos para instalar estas dependencias (que me extrañaría que no las tuvieseis ya instaladas) y el programa en si: Ubuntu: sudo apt-get install zenity python-qrcode Arch: sudo pacman -S zenity python-qrcode Para el que prefiera qrencode: sudo apt-get install qrencode o sudo pacman -S qrencode El script usando zenity: Para los que no quieran instalar zenity, sin GUI: Hace tiempo que no hago nada en bash así que es posible que os salte algún que otro error. Pero como es un simple script podéis corregirlo y personalizarlo vosotros mismos (he procurado mantener la legibilidad del código lo mejor posible), y si es muy grave me lo comentáis por aquí y edito el mensaje para corregirlo. Yo he realizado varias pruebas y me ha funcionado todo correctamente así que espero que no me acribilléis con muchos reportes XD Y eso es todo, espero que os pueda ser útil
  2. 1 punto
    portaro

    problema con un paquete...ni palante ni patras

    Genial que te funcione amigo eso se debe a la opción --force que me parecio que te haria el buen trabajo pero no te dije informacion que te puede ser util de futuro - hay que tener cuidado al hacer esta opcion con errores de estos ya que te puede quebrar el sistema si por alguna razon no tienes kernel alternativo o bien te empieza a dar remocion de paqueteria desktop, asi mismo si pide upgrade de boot y grub y no te lo hace automatico. Más que nada es informacion util para otros que vean este post para no hacerlo sin leer el terminal y los cambios que hara. En tu caso no te dije nada porque me puse a leer tus alteraciones y se cernia solo sobre el linux-image que querias remover por lo tanto no daria problemas a terceros paquetes y si no tubieras otro kernel te saldria mensaje de que no hay linux image alternative. Un saludo y a disfrutar de tu sistema que como vez siempre se puede arreglar un problema.
  3. 1 punto
    Fransis

    problema con un paquete...ni palante ni patras

    Genial, muchas gracias. funcionando con el sudo dpkg --remove --force-all, me dio el mismo aviso de que el paquete se encontraba en mal estado y necesitaba reinstalarlo pero no lo encontraba, aun asi lo pudo remover correctamente, reconstruir la base de datos despues y ya me vuelven a funcionar los repositorios!! muchas gracias
  4. 1 punto
    portaro

    problema con un paquete...ni palante ni patras

    Prueba con el comando purge remove ya que la referencia que te esta dando es de que al hacer purge te quiere instalar otro paquete de sustitucion y el cual no hay en el enlaze que este buscando. Combina los comandos purge remove a ver si lo hace o bien combinando con el -f (force). sudo apt-get remove --purge paquete O bien intenta con el gestor de paquetes alternativo dpkg → sudo dpkg --remove --force-all paquete. https://help.ubuntu.com/community/RemoveOldKernels
  5. 1 punto
    Fransis

    problema con un paquete...ni palante ni patras

    Einnn?! Enviado desde mi MI 8 mediante Tapatalk
×