Saltar al contenido

Gnu/Linux Vagos usa cookies. Lea nuestra Política de privacidad para más información.    Acepto el uso de cookies

Foto
Ayuda GNU/Linux

Linux Mint con 2 Placas de Video y 4 Monitores

Ayuda GNU/Linux linuxmint nvidia dual gpu

  • Por favor, loguéate para poder responder
3 respuestas a este tema

#1 DESCONECTADO   norkru

norkru

    Recién llegado

  • Registrado: 11/01/2017
  • Mensajes: 2
  • Galletas: 4



Escrito 11 January 2017 - 14:53

Estimados, antes que nada, me presento, soy de Argentina, un placer ser parte del foro.

Les comento mi problema:

Tengo instalado Linux Mint 32 bits 17. 1

Tengo en el Equipos instalado 2 placas de Video nVidia GT 720, las cuales son detectadas:

 

WdKuGfd.png

 

Necesito hacer funcionar 4 monitores, la idea es usar 2 puertos de cada placa, con Ubuntu, logre que funcionara, pero la app que necesito no corre en ubuntu, en Mint Corre perfectamente, la app funciona, pero no logro hacer andar los monitores. 

Por ejemplo en Nvidia X Server, veo que me detecta las dos placas, incluso me detecta el monitor en la segunda placa, pero no me lo habilita:

 

ttai6kG.png

 

Si habilito la placa de forma manual, al reiniciar me arroja un error:

 

dOx5n0a.jpg

 

 

Podrían ayudarme?

Gracias.


  • pacoeloyo y Rohlling les gusta esto

#2 DESCONECTADO   Shiba87

Shiba87

    Administrador

  • Registrado: 19/07/2012
  • Mensajes: 8056
  • Galletas: 37149

Género:








Lugar:/home/shiba

Escrito 12 January 2017 - 01:39

Te sale más rentable modificar el /etc/X11/xorg.conf, para especificar claramente que tienes dos GPUs idénticas conectadas a 4 pantallas y, a partir de ahí, gestionar cómo vas a administrarlas, ya sea clonarlas, extender el escritorio o lo que sea.

 

Lo primero sería pedirle un poco de ayuda a nvidia-sconfig

nvidia-xconfig --composite

Eso debería darte una configuración muy básica y, quién sabe, quizá te ahorre el resto del trabajo :P

 

Opciones que pueden interasarte del Xconfig:

 

nvidia-xconfig --x-screens-per-gpu=X

Donde la X representa el número de pantallas (Que no monitores que maneja cada GPU)

 

Aunque si quieres una macropantalla a 4 monitores, tendrías que optar por la opción opuesta:

nvidia-xconfig --no-separate-x-screens

 

O hilar más fino y dárselo un poco más masticado

nvidia-xconfig --x-screens-per-gpu=1

1 para todas ellas

 

En última instancia siempre podrías definir manualmente en el Xorg.conf cada monitor, pantalla y GPU y quién maneja cada cosa y cómo.


  • pacoeloyo, Rohlling, Mgbu y 1 otro le gusta esto

jdIWHUE.png


#3 DESCONECTADO   norkru

norkru

    Recién llegado

  • Registrado: 11/01/2017
  • Mensajes: 2
  • Galletas: 4



Escrito 12 January 2017 - 14:04

Te sale más rentable modificar el /etc/X11/xorg.conf, para especificar claramente que tienes dos GPUs idénticas conectadas a 4 pantallas y, a partir de ahí, gestionar cómo vas a administrarlas, ya sea clonarlas, extender el escritorio o lo que sea.

 

Lo primero sería pedirle un poco de ayuda a nvidia-sconfig

nvidia-xconfig --composite

Eso debería darte una configuración muy básica y, quién sabe, quizá te ahorre el resto del trabajo :P

 

Opciones que pueden interasarte del Xconfig:

nvidia-xconfig --x-screens-per-gpu=X

Donde la X representa el número de pantallas (Que no monitores que maneja cada GPU)

 

Aunque si quieres una macropantalla a 4 monitores, tendrías que optar por la opción opuesta:

nvidia-xconfig --no-separate-x-screens

O hilar más fino y dárselo un poco más masticado

nvidia-xconfig --x-screens-per-gpu=1

1 para todas ellas

 

En última instancia siempre podrías definir manualmente en el Xorg.conf cada monitor, pantalla y GPU y quién maneja cada cosa y cómo.

 

Gracias @Shiba87 he estado probando, incluso viendo las configuraciones avanzadas de nvidia-xconfig, pero sigo sin solucionarlo.

 

Al momento de activar un monitor de la segunda placa de video, al reiniciar me arroja el error de Cinnamon.

 

Gracias., te muestro la configuración del archivo de cuando lo activo.

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 331.20  (buildd@komainu)  Mon Feb  3 15:11:14 UTC 2014

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" RightOf "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "LG Electronics E1941"
    HorizSync       30.0 - 61.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Monitor"
    # HorizSync source: unknown, VertRefresh source: unknown
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "LG Electronics 20M35"
    HorizSync       0.0 - 0.0
    VertRefresh     0.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 720"
    BusID          "PCI:1:0:0"
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 720"
    BusID          "PCI:6:0:0"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "nvidia-auto-select +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "metamodes" "nvidia-auto-select +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Esa configuración es con dos placas, y un monitor en cada placa, cuando habilito el segundo monitor de la placa "2" o "Device1".

 

Update: He probado instalar un ubunto, y si seteo nvidia x server de la misma forma que lo hago en Linux Mint, funciona perfectamente los monitores en ambas placas. Como ultima prueba; he copiado el archivo "xorg.conf"  de ubuntu y lo he pegado en Mint, y no hay caso, directamente no ingresa al escritorio de Mint. 

 

Gracias.


Editado por norkru, 12 January 2017 - 20:08 .

  • pacoeloyo y Rohlling les gusta esto

#4 DESCONECTADO   Shiba87

Shiba87

    Administrador

  • Registrado: 19/07/2012
  • Mensajes: 8056
  • Galletas: 37149

Género:








Lugar:/home/shiba

Escrito 13 January 2017 - 23:21

Es muy raro. No veo probema en el xorg.conf e incluso si lo hubiera, bien o mal algo tendría que levantar en las pantallas.
Yo apuntaría a un problema de Cinnamon. Sería cuestión de probar con otro entorno/gestor de ventanas para confirmarlo


  • pacoeloyo y Rohlling les gusta esto

jdIWHUE.png






También etiquetado con una o más de estas palabras: Ayuda GNU/Linux, linuxmint, nvidia, dual gpu