Saltar al contenido

Gnu/Linux Vagos usa cookies. Lea nuestra Política de privacidad para más información.    Acepto el uso de cookies

Foto
Ayuda GNU/Linux

Tearing en CS GO

Ayuda GNU/Linux

  • Por favor, loguéate para poder responder
12 respuestas a este tema

#1 DESCONECTADO   Pacman

Pacman

    Linuxero avanzado

  • Registrado: 30/01/2014
  • Mensajes: 372
  • Galletas: 1515

Género:







Lugar:/home/Pacman

Escrito 22 October 2016 - 16:00

Buenas a tod@s, me he pillado unos cuantos juegos en Steam para linux y uno de ellos me está dando problemas (CS GO), me da mucho tearing, he probado a activar la opción VSYNC y a poner el "mode filtering" en "triple", y sí el tearing se quita, pero a costa de que el juego va a tirones, da un tiron cada 3, 4 segundos, injugable. Había leido por internet que mucha gente tenía el problema con el VSYNC que tengo yo, que lo desactivan y que simplemente limitam el FrameRate a 60 con el comando "fps_max 60", he probado a hacerlo y me produce el efecto contrario, el tearing aumenta aún más.

 

El caso es que no es cosa del driver de NVIDIA, por que portal 1 y 2 van de lujo, sin tearing, a 1080p y 60 fps prácticamente estables. También he probado a tocar ajustes de nvidia-settings, jugando con los ajustes opengl pero nada.

 

¿A alguien más le ha pasado esto y me puede echar una mano?

 

Gracias.

 

PD: Mi gráfica es una gtx 660 Ti de 2Gb y tengo 16 Gb de Ram.


Editado por Pacman, 22 October 2016 - 16:01 .

  • pacoeloyo, portaro, Rohlling y 2 mas les gusta esto

5573989658.png


#2 DESCONECTADO   Shiba87

Shiba87

    Administrador

  • Registrado: 19/07/2012
  • Mensajes: 8058
  • Galletas: 37151

Género:








Lugar:/home/shiba

Escrito 22 October 2016 - 16:42

Con la sincronización siempre hay un coste bastante importante en cuanto a rendimiento, así que no sé hasta qué punto se podrá afinar :sweat:

 

La prueba "universal" al vuelo:

nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"

 

Si ves que va y no hace que el equipo muera en el intento, es cuestión de añadirlo luego en el /etc/X11/xorg.conf dentro de la sección screen

Section "Screen"
Identifier "Screen0"
Option "metamodes" "nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"
Option "AllowIndirectGLXProtocol" "off"
Option "TripleBuffer" "on"
EndSection

 

De todas formas, yo levantaría las Xs y lanzaría el juego sin nada más debajo, a ver si algún componente del entorno gráfico/gestor de ventanas podría estar interfiriendo, agravando el problema (que no causando porque está claro que el juego tiene algo de serie).

 

Por ejemplo (a ver si no la cago, para variar :jojojo:)

startx steam -applaunch 730 -- :2

  • eMix, pacoeloyo, portaro y 7 mas les gusta esto

jdIWHUE.png


#3 DESCONECTADO   eMix

eMix

    Administrador

  • Registrado: 19/07/2012
  • Mensajes: 2640
  • Galletas: 10482

Género:






Lugar:/home/emix

Escrito 22 October 2016 - 20:28

A mi se me fue como dice Shiba, editando el xorg.conf y es casi la misma gráfica, debe funcionar :)
  • Shiba87, pacoeloyo, portaro y 3 mas les gusta esto

168in88.png


#4 DESCONECTADO   Oscar77

Oscar77

    Miembro

  • Registrado: 17/11/2015
  • Mensajes: 137
  • Galletas: 427

Género:





Escrito 22 October 2016 - 23:18

Que sabio el señor Shiba...

 

Iva a poner esa mágica línea que cita del xorg.conf.

 

Esto es como medicina mágica para el Tearing  :)

 

Cuéntenós el autor del post si mejora la cosa.

 

Saludos!


  • Shiba87, pacoeloyo, portaro y 3 mas les gusta esto

image.jpg


#5 DESCONECTADO   Pacman

Pacman

    Linuxero avanzado

  • Registrado: 30/01/2014
  • Mensajes: 372
  • Galletas: 1515

Género:







Lugar:/home/Pacman

Escrito 23 October 2016 - 08:50

Shiba tio eres un genio, he probado lo que me has pasado:

nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"

Y no hay ni rastro de tearing, incluso sin el VSYNC activado, limitando el framerate a 60 tampoco a tearing, funciona de perlas. Ahora voy a añadirlo al Xorg para que funcione cada vez que arranque y listo.

 

Muchas gracias, no sabes la cantidad de cosas que he probado en los ajustes del juego y en Nvidia settings sin resultado alguno.


  • Shiba87, pacoeloyo, portaro y 4 mas les gusta esto

5573989658.png


#6 DESCONECTADO   Pacman

Pacman

    Linuxero avanzado

  • Registrado: 30/01/2014
  • Mensajes: 372
  • Galletas: 1515

Género:







Lugar:/home/Pacman

Escrito 23 October 2016 - 09:19

Bueno, ahora probando un poco más el juego, veo que si tiene algo de tearing, pero muy poco, vamos, que es un tearing muy aceptable.


  • pacoeloyo, portaro, Fransis y 2 mas les gusta esto

5573989658.png


#7 DESCONECTADO   Oscar77

Oscar77

    Miembro

  • Registrado: 17/11/2015
  • Mensajes: 137
  • Galletas: 427

Género:





Escrito 23 October 2016 - 10:39

Bueno, ahora probando un poco más el juego, veo que si tiene algo de tearing, pero muy poco, vamos, que es un tearing muy aceptable.

Ahora que tienes la  "línea mágica" puedes jugar con alguna opción dentro de tu juego para ver si mejora la cosa.

 

Yo en principio cuando descubrí esa línea la verdad no tuve problemas.

 

Un saludo.


  • Shiba87, pacoeloyo, portaro y 3 mas les gusta esto

image.jpg


#8 DESCONECTADO   Fransis

Fransis

    Pingüino

  • Registrado: 08/04/2013
  • Mensajes: 848
  • Galletas: 3171

Género:








Lugar:Madrid

Intereses:Despertar

Escrito 25 November 2016 - 17:40

y en bumbleblee, como lo puedo hacer? en que archivo deberia de meterlo? intel.conf, xorg.conf, nvidia.conf??? funcionaria?? o lo voy a romper todo... jijiji


  • pacoeloyo, portaro, Rohlling y 1 otro le gusta esto

5g1v4-2f6h.jpg


#9 DESCONECTADO   Oscar77

Oscar77

    Miembro

  • Registrado: 17/11/2015
  • Mensajes: 137
  • Galletas: 427

Género:





Escrito 25 November 2016 - 18:48

la línea mágica se agrega en xorg.conf compañero, en la sección screen, tal que así, te pongo el mio :

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "metamodes" "nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

  • pacoeloyo, portaro, Fransis y 2 mas les gusta esto

image.jpg


#10 DESCONECTADO   eMix

eMix

    Administrador

  • Registrado: 19/07/2012
  • Mensajes: 2640
  • Galletas: 10482

Género:






Lugar:/home/emix

Escrito 26 November 2016 - 13:37

y en bumbleblee, como lo puedo hacer? en que archivo deberia de meterlo? intel.conf, xorg.conf, nvidia.conf??? funcionaria?? o lo voy a romper todo... jijiji


Al no encontrar por ningún lado xorg.conf en manjaro edite el nvidia.conf y funciono. No deberías tener problemas :ok:
  • pacoeloyo, portaro, limón y 3 mas les gusta esto

168in88.png


#11 DESCONECTADO   Fransis

Fransis

    Pingüino

  • Registrado: 08/04/2013
  • Mensajes: 848
  • Galletas: 3171

Género:








Lugar:Madrid

Intereses:Despertar

Escrito 04 January 2017 - 17:03

pregunta tonta... esto porque no viene configurado asi por defecto??? incompatibilidad con algunas distros o entornos???

no entiendo, creo que es algo que deberia de configurarse asi una vez instalas el driver de nvidia... no?


  • portaro y Rohlling les gusta esto

5g1v4-2f6h.jpg


#12 DESCONECTADO   portaro

portaro

    Gran Pingüino

  • Registrado: 20/07/2012
  • Mensajes: 2140
  • Galletas: 8188

Género:









Lugar:Chaves - Portugal

Intereses:Antropologia & Humanidades.
Gambas.
GNU/Linux.
Programación Básica.

Escrito 04 January 2017 - 18:28

A mi ya me paso ese famoso tearing con un problema que me lo fue ayudando a solventar el amigo Shiba87 en determinada ocasión , me recomendaron eso mismo meter mano al xorg y si que funciona un poco pero a veces puede que no sea la mejor opción ya que de mi experiencia yo te diria que empezaras por buscar una version de Kernel a la cual le vaya bien el driver gráfico y despues si hace falta metes mano al xorg (que si usas el kernel optimo no lo vas a necesitar casi seguro) , en mi caso tube mejoras con el kernel que me la liaba editando el xorg pero las mejoras no estaban todo lo bueno comparadas con un nuevo kernel que salio despues por lo tanto creo que seria bueno recomendarte eso estar atento a la version Kernel y por comparación si tienes un kernel anterior que sabes que te funcionaba todo bien y esta en repositorios instalalo y punto y despues te esperas que un nuevo Kernel que salga sea tan bueno como ese otro anterior y pasas de usar el intermedio (el presente ) y listo solo tienes que probar a ver el rendimiento en el nuevo kernel que pueda salir de upgrade de version de ese mismo elemento.
  • pacoeloyo y Rohlling les gusta esto

#13 DESCONECTADO   pacoeloyo

pacoeloyo

    Dios pingüino

  • Registrado: 20/07/2012
  • Mensajes: 2617
  • Galletas: 10647

Género:









Lugar:costa granadina

Intereses:Mi hija, y seguir avanzando en la vida

Escrito 04 January 2017 - 18:54

Una duda, hace tiempo se hizo en el foro una comparativa de juegos corriendo en diferentes entorno de escritorio. La conclusión si recuerdo bien fue, que cuánto más ligero es el escritorio mejor va el juego. ¿ Se podría probar lanzar el juego desde una terminal sin entorno gráfico o desde un entorno ligero? lxde o openbox por poner un ejemplo.

Enviado desde mi Aquaris E4
  • Rohlling le gusta esto

Me rompes el alma con tu fragilidad y tu tristeza. No se qué clase de alimaña te pudo infringir tanto dolor. Me duele en las entrañas tu pena. Pero te juro que tienes mi mano para agarrarte. Que tienes dentro de ti la fuerza que no encuentras. Que aunque el mundo te abandone, siempre contarás con mi ayuda, y que, aunque hayas llegado a creer a los que decían que no vales nada, tú, como cada persona de este mundo,

tiene el valor de un universo entero.

Levánta la cabeza. Sonríe. Se feliz.

Gnu/Linux x86_64 kernel 3.13.0-100 Almuñequero-Sexitano Granadino

Somos linuxeros y estamos orgullosos de serlo!

Cada uno en su sitio, pero unidos por una misma causa