Saltar al contenido

Gnu/Linux Vagos usa cookies. Lea nuestra Política de privacidad para más información.    Acepto el uso de cookies

Foto
Ayuda GNU/Linux

Hacer funcionar bluetooth ath3k

Ayuda GNU/Linux bluetooth debian atheros problema blueman error

  • Por favor, loguéate para poder responder
10 respuestas a este tema

#1 DESCONECTADO   Mgbu

Mgbu

    Gurú

  • Registrado: 22/11/2013
  • Mensajes: 767
  • Galletas: 2796

Género:






Lugar:C:\Usuarios\Mgbu

Intereses:Programación, Astronomía, Ciencia, Telecomunicaciones

Escrito 29 December 2015 - 21:29

No puedo hacer funcionar mi bluetooth en Debian Stable Jessie, en Linux Mint tampoco

Mi adaptador bluetooth es Atheros AR3011 viene integrado en la placa madre

 

Apenas instalé debian instalé los drivers de atheros con un .deb porque mi wifi tambien es atheros. Como no tenía internet me pasé el deb por pendrive

sudo dpkg -i firmware-atheros_0.43_all.deb

Mi intento fue instalar esto:

sudo aptitude install bluetooth blueman pulseaudio-module-bluetooth pavucontrol bluez-firmware firmware-linux

Tengo non-free activado. Apenas lo hice funcionó, ahora unos días después dejó de funcionar. Cuando entro a blueman no me aparece nada en la parte de adapters

 

Creo que la clave es esta linea de dmesg:

ath3k: probe of 3-12.1:1.0 failed with error -110

En windows 10 tampoco funciona, me aparece como si estuviera todo bien pero no detecta ningun dispositivo, se queda buscando. Pero creo que windows está mas cerca, porque la lucecita de bluetooth que tiene la placa se prende. En Linux no, se prende al prender la PC pero despues de un tiempo se apaga

 

Algunas salidas de comandos:

En algunos lados leí de rfkill pero no se exactamente que hace y si me va a ayudar


Editado por Mgbu, 29 December 2015 - 21:43 .

  • pacoeloyo, Karibe y Rohlling les gusta esto
:notoy:

#2 DESCONECTADO   Shiba87

Shiba87

    Administrador

  • Registrado: 19/07/2012
  • Mensajes: 8061
  • Galletas: 37167

Género:








Lugar:/home/shiba

Escrito 30 December 2015 - 16:56

¿Por qué un deb y no desde repositorios? :ohh:

 

No digo que de repente vaya a funcionar porque no sé qué modelo es exactamente, pero entre una versión tan antigua como esa y la actual (mira en backports), hay una diferencia notable en cuanto a dispositivos soportados. Aparte de incompatibilidades como podría ser la que sufres :sweat:


  • pacoeloyo, Karibe, Rohlling y 1 otro le gusta esto

jdIWHUE.png


#3 DESCONECTADO   Mgbu

Mgbu

    Gurú

  • Registrado: 22/11/2013
  • Mensajes: 767
  • Galletas: 2796

Género:






Lugar:C:\Usuarios\Mgbu

Intereses:Programación, Astronomía, Ciencia, Telecomunicaciones

Escrito 30 December 2015 - 17:33

A lo mejor lo arregla, usé el deb porque no tenía wifi entonces no podía usar aptitude

 

La versión que me aparece en synaptic es la misma, 0.43. Pero claro, no conocía eso de backports, estuve leyendo de acá

 

Entonces debería agregar los backports a mi sources.list:

deb http://http.debian.net/debian jessie-backports main

Y después hacer:

sudo aptitude -t jessie-backports install firmware-atheros

Probé pero no pasa nada, dice:

No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 51 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.

Lo tengo que borrar y volver a instalar? cuando lo borre me quedo sin Wifi y no puedo usar cable ethernet. Descargo el deb nuevo?


  • pacoeloyo, Karibe y Rohlling les gusta esto
:notoy:

#4 DESCONECTADO   Shiba87

Shiba87

    Administrador

  • Registrado: 19/07/2012
  • Mensajes: 8061
  • Galletas: 37167

Género:








Lugar:/home/shiba

Escrito 30 December 2015 - 17:38

Sin actualizar primero la lista de paquetes no vas a conseguir mucho :P


  • pacoeloyo, Karibe, Rohlling y 1 otro le gusta esto

jdIWHUE.png


#5 DESCONECTADO   Mgbu

Mgbu

    Gurú

  • Registrado: 22/11/2013
  • Mensajes: 767
  • Galletas: 2796

Género:






Lugar:C:\Usuarios\Mgbu

Intereses:Programación, Astronomía, Ciencia, Telecomunicaciones

Escrito 30 December 2015 - 18:07

El mirror estaba mal :icon_ouch:

De todas formas lo arreglé y sigue sin pasar nada. El mirror que uso ahora es

deb http://ftp.cl.debian.org/debian jessie-backports main

Cuando hago

sudo aptitude -t jessie-backports upgrade

Supongo que eso actualiza todo lo que se puede a backports, me aparece esto:

Resolving dependencies...                
The following NEW packages will be installed:
  irqbalance{a} libgphoto2-port12{a} libmediaart-2.0-0{a} libnuma1{a} libpagemaker-0.0-0{a} librygel-core-2.6-2{a} 
  librygel-renderer-2.6-2{a} librygel-server-2.6-2{a} libsoxr0{a} linux-image-4.2.0-0.bpo.1-amd64{a} 
The following packages will be REMOVED:
  libcmis-0.4-4{u} libetonyek-0.1-1{u} libgltf-0.0-0{u} libmwaw-0.3-3{u} liborcus-0.8-0{u} librygel-core-2.4-2{u} 
  librygel-renderer-2.4-2{u} librygel-server-2.4-2{u} libuuid-perl{u} libwps-0.3-3{u} perlmagick{u} 
The following packages will be upgraded:
  exim4 exim4-base exim4-config exim4-daemon-light fonts-opensymbol geany geany-common geoip-database inkscape 
  libgphoto2-6 libgphoto2-l10n libjs-jquery libmtp-common libmtp-runtime libmtp9 libnet-dbus-perl libpcap0.8 
  libpulse-mainloop-glib0 libpulse0 libpulsedsp librados2 librbd1 libreoffice-avmedia-backend-gstreamer 
  libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw libreoffice-gnome 
  libreoffice-gtk libreoffice-impress libreoffice-math libreoffice-style-galaxy libreoffice-style-tango 
  libreoffice-writer libvdpau1 lintian linux-base linux-image-amd64 linux-libc-dev pulseaudio 
  pulseaudio-module-bluetooth pulseaudio-module-x11 pulseaudio-utils python-six python3-six python3-uno rygel 
  uno-libs3 ure xserver-xorg-video-intel 
51 packages upgraded, 10 newly installed, 11 to remove and 0 not upgraded.
Need to get 153 MB of archives. After unpacking 219 MB will be used.
Do you want to continue? [Y/n/?] n
Abort.

Ahí no encuentro a firmware-atheros. No instalé todo eso porque decía que era mala idea.

 

Supongo que ahí se debería actualizar firmware-atheros porque en packages.debian.org aparece una versión más nueva :hmmm:

 

EDIT:

 

Ahhhh!!!!!!

 

Es non-free!

 

El mirror queda así:

deb http://ftp.cl.debian.org/debian jessie-backports main contrib non-free

Ahí se está instalando

 

EDIT:

 

No se arregló, sigue igual


Editado por Mgbu, 30 December 2015 - 18:25 .

  • Shiba87, pacoeloyo, Karibe y 1 otro le gusta esto
:notoy:

#6 DESCONECTADO   Mgbu

Mgbu

    Gurú

  • Registrado: 22/11/2013
  • Mensajes: 767
  • Galletas: 2796

Género:






Lugar:C:\Usuarios\Mgbu

Intereses:Programación, Astronomía, Ciencia, Telecomunicaciones

Escrito 31 December 2015 - 13:27

Hoy la prendí y está funcionando :ohh:

No sé como será la cosa, me voy a tener que poner a probar

 

Estoy en Linux Mint, esto dice hoy dmesg


  • pacoeloyo y Rohlling les gusta esto
:notoy:

#7 DESCONECTADO   Shiba87

Shiba87

    Administrador

  • Registrado: 19/07/2012
  • Mensajes: 8061
  • Galletas: 37167

Género:








Lugar:/home/shiba

Escrito 31 December 2015 - 15:17

post-41538-Shia-Labeouf-Magic-gif-Imgur-


  • artiza, Karibe, Rohlling y 2 mas les gusta esto

jdIWHUE.png


#8 DESCONECTADO   Mgbu

Mgbu

    Gurú

  • Registrado: 22/11/2013
  • Mensajes: 767
  • Galletas: 2796

Género:






Lugar:C:\Usuarios\Mgbu

Intereses:Programación, Astronomía, Ciencia, Telecomunicaciones

Escrito 01 January 2016 - 15:01

El problema es que a veces deja de funcionar

Tendria que hacer un reporte de bug? Nunca hice un reporte, me da un poco de cosa que moleste y publique cualquier cosa

Supongo que si hago una instalacion desde cero y tengo problema (y en windows funciona) es un bug
  • pacoeloyo y Rohlling les gusta esto
:notoy:

#9 DESCONECTADO   Mgbu

Mgbu

    Gurú

  • Registrado: 22/11/2013
  • Mensajes: 767
  • Galletas: 2796

Género:






Lugar:C:\Usuarios\Mgbu

Intereses:Programación, Astronomía, Ciencia, Telecomunicaciones

Escrito 02 January 2016 - 20:54

Creo que encontré un patron

Probé bastante a reiniciar y apagar y prender:

Mint      Si
  Reinicio
Debian    Si   
  Reinicio
Debian    Si
  Apagar y Prender
Debian    No
  Reinicio
Debian    No
  Reinicio
Debian    No
  Apagar y Prender
Debian    No
  Reinicio
Debian    No
  Reinicio
Mint      No
  Reinicio
Debian    No
  Apagar y Prender
Mint      Si
  Reinicio
Debian    Si
  Apagar y Prender
Debian    No
  Reinicio
Mint      No
  Apagar y Prender
Debian    No
  Apagar y Prender
Mint      Si
  Reinicio
Mint      Si

Ahi dice cuando funcionó y cuando no. Por lo que veo solamente funciona si prendo la computadora en Linux mint, después sigue funcionando hasta que la apague

Si la prendo en Debian no funcione hasta que la apague totalmente y la prenda en Mint (No vale prender en Debian y reiniciar en Mint)

 

Que pasa? Los drivers se cargan solamente al prender y no al reiniciar?

 

Algo aparte es que ayer o anteayer probé a instalar bluedevil, cinnamon-bluetooth y gnome-bluetooth en Linux Mint a ver si instalaban algo que hacía falta. Pero no creo que haya sido lo que lo arregló, porque normalmente no enciendo la computadora directamente a Mint sino que primero trabajo en Debian y después me paso a mint
 


  • pacoeloyo y Rohlling les gusta esto
:notoy:

#10 DESCONECTADO   Shiba87

Shiba87

    Administrador

  • Registrado: 19/07/2012
  • Mensajes: 8061
  • Galletas: 37167

Género:








Lugar:/home/shiba

Escrito 03 January 2016 - 16:26

Habría que comprobar si el controlador está cargado o no al arrancar y qué es lo que ocurre, en una de la veces que no se carga, si se fuerza con modprobe


  • pacoeloyo y Rohlling les gusta esto

jdIWHUE.png


#11 DESCONECTADO   Mgbu

Mgbu

    Gurú

  • Registrado: 22/11/2013
  • Mensajes: 767
  • Galletas: 2796

Género:






Lugar:C:\Usuarios\Mgbu

Intereses:Programación, Astronomía, Ciencia, Telecomunicaciones

Escrito 03 January 2016 - 22:40

:hmmm:

 

Hice lsmod al iniciar para ver que modulos están cargados cuando anda y cuando no anda bluetooth (es lo que entiendo por lo que dijiste) y es medio raro:

 

Debian con bluetooth

 

Debian sin bluetooth

 

Mint con bluetooth

 

Mint sin bluetooth

 

Es muy largo para verlo de esa forma, así que les hice grep probando cosas:

 

grep ath3k

 

Debian con bluetooth

Nada

Debian sin bluetooth

ath3k                  16781  0 
bluetooth             374429  10 bnep,ath3k,btusb,rfcomm
usbcore               195427  7 ath3k,btusb,ehci_hcd,ehci_pci,usbhid,ath9k_htc,xhci_hcd

Mint con bluetooth

ath3k                  20480  0 
bluetooth             491520  23 bnep,ath3k,btusb,rfcomm

Mint sin bluetooth

ath3k                  20480  0 
bluetooth             491520  12 bnep,ath3k,btusb,rfcomm

Las otras pruebas no dieron nada raro creo

 

 

No entiendo, es como que cuando no funciona el bluetooth me sobra el modulo de ath3k

 

No se cual es el foro mas apto para preguntas asi

 

Haciendo pruebas con rmmod y modprobe no llegue a nada, también probé a poner a ath3k en blacklist para que no se cargue pero tampoco hace nada


Editado por Mgbu, 03 January 2016 - 22:54 .

  • artiza y Rohlling les gusta esto
:notoy:





También etiquetado con una o más de estas palabras: Ayuda GNU/Linux, bluetooth, debian, atheros, problema, blueman, error